Jump to content

Обновление роняет систему


Equalizer
 Share

Recommended Posts

Коллеги, добрый день.

Ситуация следующая: имеем Keenetic Giga 2. С обновлениями до 2.16.D.8.0-0 проблем не было. 2.16.D.8.0-2 уронило систему и загнало роутер в бутлуп, восстановил прошивку с помощью рекавери. Думал, какой-то глюк. Благо, бэкапы наше всё. Вышло обновление 2.16.D.9.0-0, ситуация повторилась с небольшой разницей - роутер бесконечно моргает индикатором питания, после hard reset загорается лишь питание, порт 0 (от провайдера) и 1, куда воткнут шнур от компа. Опять же, вернуть к жизни помогает лишь рекавери и заливка 2.16.D.8.0-0 из бэкапа. В чём может быть проблема, у кого какие идеи?

Link to comment
Share on other sites

9 часов назад, Equalizer сказал:

Коллеги, добрый день.

Ситуация следующая: имеем Keenetic Giga 2. С обновлениями до 2.16.D.8.0-0 проблем не было. 2.16.D.8.0-2 уронило систему и загнало роутер в бутлуп, восстановил прошивку с помощью рекавери. Думал, какой-то глюк. Благо, бэкапы наше всё. Вышло обновление 2.16.D.9.0-0, ситуация повторилась с небольшой разницей - роутер бесконечно моргает индикатором питания, после hard reset загорается лишь питание, порт 0 (от провайдера) и 1, куда воткнут шнур от компа. Опять же, вернуть к жизни помогает лишь рекавери и заливка 2.16.D.8.0-0 из бэкапа. В чём может быть проблема, у кого какие идеи?

Вот еще здесь посмотрите. Аналогичная проблема была у людей как с подключенным модемом, так и без него. 

У самого Giga 2. Но почитав всё это, решил, что мне хорошо и на 2.16.D.7.0-1. Решил пока не обновляться.

Edited by gvan
Link to comment
Share on other sites

Пока не вижу нигде ничего подозрительного.

Смотрите, между 8.0-0 и 8.0-2 разница только в версии tsmb, больше ничего не менялось. Если вы не используете tsmb, то для вас они вообще идентичны.

Уверены, что это не железка начинает "крякать"?

Link to comment
Share on other sites

8 часов назад, Le ecureuil сказал:

Пока не вижу нигде ничего подозрительного.

Смотрите, между 8.0-0 и 8.0-2 разница только в версии tsmb, больше ничего не менялось. Если вы не используете tsmb, то для вас они вообще идентичны.

Уверены, что это не железка начинает "крякать"?

на одной из гига 2 та же ситуация, помогает только установка 2.05 через рекавери. При обновлении до 7.0, 8.0 и 9.0 бутлуп. Вторая и третья гига2 работают нормально на последней прошивке.

Как снять селфтест когда роутер уже не загружается?

Link to comment
Share on other sites

23 часа назад, gvan сказал:

У самого Giga 2. Но почитав всё это, решил, что мне хорошо и на 2.16.D.7.0-1. Решил пока не обновляться.

GigaII (2.16.D.9.0-0), проблем с обновлением не возникло! Также на эту версию ПО были успешно обновлены Keenetic 4G III rev.B, Keenetic Lite III rev.B, Keenetic Lite III

Link to comment
Share on other sites

8 часов назад, Le ecureuil сказал:

Пока не вижу нигде ничего подозрительного.

Смотрите, между 8.0-0 и 8.0-2 разница только в версии tsmb, больше ничего не менялось. Если вы не используете tsmb, то для вас они вообще идентичны.

Уверены, что это не железка начинает "крякать"?

По идее, если бы были проблемы с ПЗУ, то он и из рекавери бы не восстановился. Да и после восстановления путем подкидывания из бэкапа файла с прошивкой 2.16.D.8.0-0 через веб интерфейс, он её принимает. Правда, после обновления все также не загружается, но hard reset через кнопку на корпусе спасает ситуацию. Подкидываем из бэкапа файл настроек и получаем рабочую систему, как было до вышеописанных манипуляций. Более того, я ради эксперимента брал бэкап прошивки с другого giga 2, где нет таких проблем с обновлением. Проделывал вышеописанные операции, и роутер тоже прекрасно обновлялся до 2.16.D.9.0-0. Суть в том, что проблемный роутер сам естественным путём не может обновиться.

Вы можете на стенде развернуть конфигурацию с помощью файлов, что я прикладывал и проверить, как поведет себя система при обновлении? Мне кажется, что определённое сочетание компонентов прошивки и системных настроек при обновлении как-то негативно влияет на процесс установки и рушит систему.

Link to comment
Share on other sites

3 минуты назад, stefbarinov сказал:

GigaII (2.16.D.9.0-0), проблем с обновлением не возникло! Также на эту версию ПО были успешно обновлены Keenetic 4G III rev.B, Keenetic Lite III rev.B, Keenetic Lite III

Да, поддерживаю, Keenetic Lite 3 тоже без проблем обновляется до 2.16.D.9.0-0

Link to comment
Share on other sites

2 часа назад, Equalizer сказал:

Вы можете на стенде развернуть конфигурацию с помощью файлов, что я прикладывал и проверить, как поведет себя система при обновлении? Мне кажется, что определённое сочетание компонентов прошивки и системных настроек при обновлении как-то негативно влияет на процесс установки и рушит систему.

GigaII почила в бозе давно уже, став архивной моделью. 2.16 пилит по доброте душевной ОДИН человек. 

Link to comment
Share on other sites

5 минут назад, Mamay сказал:

2.16 пилит по доброте душевной ОДИН человек

Думаю, что модераторы могли бы создать тему в курилке, с номером кошелька этого ОДНОГО человека 😃

чтобы ему на вкусняшки могли скидывать благодарные люди ) 

  • Upvote 2
Link to comment
Share on other sites

4 часа назад, Equalizer сказал:

По идее, если бы были проблемы с ПЗУ, то он и из рекавери бы не восстановился. Да и после восстановления путем подкидывания из бэкапа файла с прошивкой 2.16.D.8.0-0 через веб интерфейс, он её принимает. Правда, после обновления все также не загружается, но hard reset через кнопку на корпусе спасает ситуацию. Подкидываем из бэкапа файл настроек и получаем рабочую систему, как было до вышеописанных манипуляций. Более того, я ради эксперимента брал бэкап прошивки с другого giga 2, где нет таких проблем с обновлением. Проделывал вышеописанные операции, и роутер тоже прекрасно обновлялся до 2.16.D.9.0-0. Суть в том, что проблемный роутер сам естественным путём не может обновиться.

Вы можете на стенде развернуть конфигурацию с помощью файлов, что я прикладывал и проверить, как поведет себя система при обновлении? Мне кажется, что определённое сочетание компонентов прошивки и системных настроек при обновлении как-то негативно влияет на процесс установки и рушит систему.

Выложите ссылки на yadisk на эти файлы ПО последовательных версий и конфиг мне в личку, попробую на g2 из позаливать по-очереди и посмотреть в uart. Но если ничего не увижу, то сорян.

Link to comment
Share on other sites

2 часа назад, plagioklaz сказал:

Думаю, что модераторы могли бы создать тему в курилке, с номером кошелька этого ОДНОГО человека 😃

чтобы ему на вкусняшки могли скидывать благодарные люди ) 

Деньги все портят (ц), потому не нужно ничего подобного )

  • Upvote 1
Link to comment
Share on other sites

1 час назад, Le ecureuil сказал:

Деньги все портят (ц), потому не нужно ничего подобного )

А я был бы рад за такой способ высказать хоть какое-то материальное "спасибо"! А чтоб не портили - поставьте условие No strings attached и все дела :-)

Link to comment
Share on other sites

33 минуты назад, Le ecureuil сказал:

Выложите ссылки на yadisk на эти файлы ПО последовательных версий и конфиг мне в личку, попробую на g2 из позаливать по-очереди и посмотреть в uart. Но если ничего не увижу, то сорян.

Отправил. Попробуйте с 2.16.D.8.0-0 и приложенного конфига обновиться естественным путём

Link to comment
Share on other sites

Добрый день!

Giga2. 2.16.D.7.0-1
Сегодня увидел, что есть обновление. Обновился. Теперь, горит только индикатор питания и номер порта в кот. подключён кабель.
Ни рекавери, ни tftp не помогают.
При попытке войти в режим рекавери, "питание" моргает пять раз, и больше ничего не происходит.
Есть ли способы восстановить роутер?

P.S. Пробовал разные кабели (из офф. инструкции)
"Важно! Если интернет-центр Zyxel Keenetic Giga II или Zyxel Keenetic Ultra не получает с tftp-сервера bin-файл, попробуйте использовать Ethernet-кабель, состоящий из 2-х витых пар (4 жилы), который поддерживает скорость передачи данных до 100 Мбит/с FD. В коробке с Giga II и Ultra поставляется Ethernet-кабель, который состоит из 4-х витых пар (8 жил))"

Не помогло. При использовании 2-х пар - номер порта не загорается (если что).

Edited by g7acnt7
Link to comment
Share on other sites

19 минут назад, g7acnt7 сказал:

Ни рекавери, ни tftp не помогают.

А вы ждете указанное время:

"7. Примерно через 5-7 минут устройство перезагрузится и будет готово к работе с новой микропрограммой."

https://help.keenetic.com/hc/ru/articles/213966149

 

 

Link to comment
Share on other sites

6 minutes ago, krass said:

А вы ждете указанное время:
https://help.keenetic.com/hc/ru/articles/213966149

"4. Отпустите кнопку "Сброс", когда на интернет-центре начнет мигать индикатор "Статус".

Процесс восстановления запустится автоматически через несколько секунд"

Прогресс-бар в окне рекавери даже не начинает заполняться. Окно как было при запуске, так и висит.
Последняя попытка - 10 минут ожидания.

Edited by g7acnt7
Link to comment
Share on other sites

12 часа назад, g7acnt7 сказал:

Добрый день!

Giga2. 2.16.D.7.0-1
Сегодня увидел, что есть обновление. Обновился. Теперь, горит только индикатор питания и номер порта в кот. подключён кабель.

У меня такая же проблема. Была версия 2.16.D.9.0-0. Решил обновится на  2.16.D.9.0-1,  после этого роутер не загрузился, горит только индикатор питания . На роутере было настроено резервирование канала и вставлен 4G модем Huawei

Link to comment
Share on other sites

https://help.keenetic.com/hc/ru/articles/214470865

восстанавливайте данным способом

отключите антивирус, и ОБЯЗАТЕЛЬНО отключите фаервол (Брандмауэр)  в вашем антивирусе , либо встроенный в винду брандмауэр (панель управления- брандмауэр windows) именно включенный брандмауэр не дает залить recovery прошивку

 

если время позволит я продолжу извращаться над роутером в следующие выходные ( буду пробовать через Tftpd64 ловить логи на с записью на компьютер, так как селфтест бесполезен в моем случае и пока посижу на 2.16.D.6.0-1 )

Edited by jiji
опечатки
Link to comment
Share on other sites

6 часов назад, Александр Воробьёв сказал:

И?

И то, что пока вы мне не принесете логи, по которым я смогу понять что проиходит, это никто вам даже не попытается исправить.

Link to comment
Share on other sites

2 минуты назад, Le ecureuil сказал:

И то, что пока вы мне не принесете логи, по которым я смогу понять что проиходит, это никто вам даже не попытается исправить.

Так это было адресовано не Вам.

  • Upvote 1
Link to comment
Share on other sites

22 часа назад, g7acnt7 сказал:

Добрый день!

Giga2. 2.16.D.7.0-1
Сегодня увидел, что есть обновление. Обновился. Теперь, горит только индикатор питания и номер порта в кот. подключён кабель.
Ни рекавери, ни tftp не помогают.
При попытке войти в режим рекавери, "питание" моргает пять раз, и больше ничего не происходит.
Есть ли способы восстановить роутер?

P.S. Пробовал разные кабели (из офф. инструкции)
"Важно! Если интернет-центр Zyxel Keenetic Giga II или Zyxel Keenetic Ultra не получает с tftp-сервера bin-файл, попробуйте использовать Ethernet-кабель, состоящий из 2-х витых пар (4 жилы), который поддерживает скорость передачи данных до 100 Мбит/с FD. В коробке с Giga II и Ultra поставляется Ethernet-кабель, который состоит из 4-х витых пар (8 жил))"

Не помогло. При использовании 2-х пар - номер порта не загорается (если что).

Аналогичная проблема, только я обновлял с 2.16.D.9.0-0 на 2.16.D.9.0-1

Рекавери и tftpd не помогает, после включения питания при зажатом сбросе загорается и начинает  индикатор питания (несколько раз) а дальше глухо.

Все делал по инструкциям https://help.keenetic.com/hc/ru/articles/214470865 и https://help.keenetic.com/hc/ru/articles/213966149

Edited by bardenol
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...