Jump to content

Перестал работать youtube-dl


Recommended Posts

Доброго времени суток!
После обновления пакетов opkg upgrade перестал работать youtube-dl

Traceback (most recent call last):
  File "/opt/bin/youtube-dl", line 33, in <module>
    sys.exit(load_entry_point('youtube-dl==2021.6.6', 'console_scripts', 'youtube-dl')())
  File "/opt/bin/youtube-dl", line 25, in importlib_load_entry_point
    return next(matches).load()
StopIteration

Лог установки обновления пакетов
 

Скрытый текст

BusyBox v1.33.1 (2021-07-08 20:18:22 UTC) built-in shell (ash)

~ # opkg update
Downloading http://bin.entware.net/mipselsf-k3.4/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/entware
Downloading http://bin.entware.net/mipselsf-k3.4/keenetic/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/keendev
~ # opkg upgrade
Upgrading php7-mod-curl on root from 7.4.20-1 to 7.4.22-1...
Downloading http://bin.entware.net/mipselsf-k3.4/php7-mod-curl_7.4.22-1_mipsel-3.4.ipk
Upgrading alsa-lib on root from 1.2.5-1 to 1.2.5.1-1...
Downloading http://bin.entware.net/mipselsf-k3.4/alsa-lib_1.2.5.1-1_mipsel-3.4.ipk
Upgrading python3-urllib on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-urllib_3.9.6-2_mipsel-3.4.ipk
Upgrading python3-light on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-light_3.9.6-2_mipsel-3.4.ipk
Upgrading bash on root from 5.1-3 to 5.1.8-1...
Downloading http://bin.entware.net/mipselsf-k3.4/bash_5.1.8-1_mipsel-3.4.ipk
Upgrading python3-pydoc on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-pydoc_3.9.6-2_mipsel-3.4.ipk
Upgrading libcurl on root from 7.77.0-1 to 7.78.0-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libcurl_7.78.0-1_mipsel-3.4.ipk
Upgrading uhttpd_kn on root from 2021-03-21-15346de8-2 to 2021-03-21-15346de8-3...
Downloading http://bin.entware.net/mipselsf-k3.4/keenetic/uhttpd_kn_2021-03-21-15346de8-3_mipsel-3.4.ipk
Upgrading mc on root from 4.8.26-1b to 4.8.27-2...
Downloading http://bin.entware.net/mipselsf-k3.4/mc_4.8.27-2_mipsel-3.4.ipk
Upgrading pciids on root from 0.347-1 to 0.350-1...
Downloading http://bin.entware.net/mipselsf-k3.4/pciids_0.350-1_mipsel-3.4.ipk
Upgrading libnghttp2 on root from 1.43.0-1 to 1.44.0-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libnghttp2_1.44.0-1_mipsel-3.4.ipk
Removing obsolete file /opt/lib/libnghttp2.so.14.20.1.
Upgrading php7-cgi on root from 7.4.20-1 to 7.4.22-1...
Downloading http://bin.entware.net/mipselsf-k3.4/php7-cgi_7.4.22-1_mipsel-3.4.ipk
Upgrading libpcre on root from 8.44-4 to 8.45-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libpcre_8.45-1_mipsel-3.4.ipk
Removing obsolete file /opt/lib/libpcre.so.1.2.12.
Upgrading python3-email on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-email_3.9.6-2_mipsel-3.4.ipk
Upgrading libnettle on root from 3.6-1 to 3.7.3-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libnettle_3.7.3-1_mipsel-3.4.ipk
Removing obsolete file /opt/lib/libhogweed.so.6.0.
Removing obsolete file /opt/lib/libnettle.so.8.0.
Upgrading libpcre2-32 on root from 10.36-1 to 10.37-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libpcre2-32_10.37-1_mipsel-3.4.ipk
Removing obsolete file /opt/lib/libpcre2-32.so.0.10.1.
Upgrading python3-cgitb on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-cgitb_3.9.6-2_mipsel-3.4.ipk
Upgrading python3-decimal on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-decimal_3.9.6-2_mipsel-3.4.ipk
Upgrading libblkid on root from 2.36.1-2 to 2.37-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libblkid_2.37-1_mipsel-3.4.ipk
Upgrading libmbedtls on root from 2.16.10-1 to 2.16.11-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libmbedtls_2.16.11-1_mipsel-3.4.ipk
Removing obsolete file /opt/lib/libmbedtls.so.2.16.10.
Removing obsolete file /opt/lib/libmbedcrypto.so.2.16.10.
Removing obsolete file /opt/lib/libmbedx509.so.2.16.10.
Upgrading python3-xml on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-xml_3.9.6-2_mipsel-3.4.ipk
Upgrading python3-setuptools on root from 56.0.0-1a to 56.0.0-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-setuptools_56.0.0-2_mipsel-3.4.ipk
Upgrading usbids on root from 0.347-1 to 0.350-1...
Downloading http://bin.entware.net/mipselsf-k3.4/usbids_0.350-1_mipsel-3.4.ipk
Upgrading php7-cli on root from 7.4.20-1 to 7.4.22-1...
Downloading http://bin.entware.net/mipselsf-k3.4/php7-cli_7.4.22-1_mipsel-3.4.ipk
Upgrading python3-pkg-resources on root from 56.0.0-1a to 56.0.0-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-pkg-resources_56.0.0-2_mipsel-3.4.ipk
Upgrading libpython3 on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/libpython3_3.9.6-2_mipsel-3.4.ipk
Upgrading libpcre2 on root from 10.36-1 to 10.37-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libpcre2_10.37-1_mipsel-3.4.ipk
Removing obsolete file /opt/lib/libpcre2-posix.so.2.
Removing obsolete file /opt/lib/libpcre2-8.so.0.10.1.
Removing obsolete file /opt/lib/libpcre2-posix.so.2.0.3.
Upgrading php7-mod-json on root from 7.4.20-1 to 7.4.22-1...
Downloading http://bin.entware.net/mipselsf-k3.4/php7-mod-json_7.4.22-1_mipsel-3.4.ipk
Upgrading curl on root from 7.77.0-1 to 7.78.0-1...
Downloading http://bin.entware.net/mipselsf-k3.4/curl_7.78.0-1_mipsel-3.4.ipk
Upgrading python3-ncurses on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-ncurses_3.9.6-2_mipsel-3.4.ipk
Upgrading python3-distutils on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-distutils_3.9.6-2_mipsel-3.4.ipk
Upgrading python3-codecs on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-codecs_3.9.6-2_mipsel-3.4.ipk
Upgrading transmission-remote on root from 3.00-11 to 3.00-14...
Downloading http://bin.entware.net/mipselsf-k3.4/transmission-remote_3.00-14_mipsel-3.4.ipk
Upgrading python3-multiprocessing on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-multiprocessing_3.9.6-2_mipsel-3.4.ipk
Upgrading php7-mod-session on root from 7.4.20-1 to 7.4.22-1...
Downloading http://bin.entware.net/mipselsf-k3.4/php7-mod-session_7.4.22-1_mipsel-3.4.ipk
Upgrading libffi on root from 3.3-2 to 3.4.2-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libffi_3.4.2-1_mipsel-3.4.ipk
Removing obsolete file /opt/lib/libffi.so.7.
Removing obsolete file /opt/lib/libffi.so.7.1.0.
Upgrading libuuid on root from 2.36.1-2 to 2.37-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libuuid_2.37-1_mipsel-3.4.ipk
Upgrading python3-base on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-base_3.9.6-2_mipsel-3.4.ipk
Upgrading python3 on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3_3.9.6-2_mipsel-3.4.ipk
python3-gdbm was autoinstalled and is now orphaned, removing.
Removing package python3-gdbm from root...
Upgrading opt-ndmsv2 on root from 1.0-14 to 1.0-15...
Downloading http://bin.entware.net/mipselsf-k3.4/keenetic/opt-ndmsv2_1.0-15_mipsel-3.4_kn.ipk
Removing obsolete file /opt/sbin/reboot.sh.
Upgrading python3-sqlite3 on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-sqlite3_3.9.6-2_mipsel-3.4.ipk
Upgrading openvpn-openssl on root from 2.5.3-1 to 2.5.3-2...
Downloading http://bin.entware.net/mipselsf-k3.4/openvpn-openssl_2.5.3-2_mipsel-3.4.ipk
Upgrading python3-readline on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-readline_3.9.6-2_mipsel-3.4.ipk
Upgrading libpcap on root from 1.10.0-1 to 1.10.1-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libpcap_1.10.1-1_mipsel-3.4.ipk
Removing obsolete file /opt/lib/libpcap.so.1.10.0.
Upgrading libuv on root from 1.41.0-3 to 1.41.1-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libuv_1.41.1-1_mipsel-3.4.ipk
Upgrading python3-dbm on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-dbm_3.9.6-2_mipsel-3.4.ipk
libdb47 was autoinstalled and is now orphaned, removing.
Removing package libdb47 from root...
Upgrading libjpeg-turbo on root from 2.1.0-1 to 2.1.1-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libjpeg-turbo_2.1.1-1_mipsel-3.4.ipk
Upgrading php7 on root from 7.4.20-1 to 7.4.22-1...
Downloading http://bin.entware.net/mipselsf-k3.4/php7_7.4.22-1_mipsel-3.4.ipk
Upgrading python3-openssl on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-openssl_3.9.6-2_mipsel-3.4.ipk
Upgrading libmount on root from 2.36.1-2 to 2.37-1...
Downloading http://bin.entware.net/mipselsf-k3.4/libmount_2.37-1_mipsel-3.4.ipk
Upgrading transmission-daemon on root from 3.00-11 to 3.00-14...
Downloading http://bin.entware.net/mipselsf-k3.4/transmission-daemon_3.00-14_mipsel-3.4.ipk
Upgrading python3-asyncio on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-asyncio_3.9.6-2_mipsel-3.4.ipk
Upgrading python3-cgi on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-cgi_3.9.6-2_mipsel-3.4.ipk
Upgrading python3-logging on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-logging_3.9.6-2_mipsel-3.4.ipk
Upgrading python3-ctypes on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-ctypes_3.9.6-2_mipsel-3.4.ipk
Upgrading youtube-dl on root from 2021.4.7-1 to 2021.6.6-1...
Downloading http://bin.entware.net/mipselsf-k3.4/youtube-dl_2021.6.6-1_mipsel-3.4.ipk
Removing obsolete file /opt/lib/python3.9/site-packages/youtube_dl-2021.4.7-py3.9.egg-info/entry_points.txt.
Removing obsolete file /opt/lib/python3.9/site-packages/youtube_dl-2021.4.7-py3.9.egg-info/dependency_links.txt.
Removing obsolete file /opt/lib/python3.9/site-packages/youtube_dl-2021.4.7-py3.9.egg-info/top_level.txt.
Removing obsolete file /opt/lib/python3.9/site-packages/youtube_dl/extractor/blinkx.pyc.
Removing obsolete file /opt/lib/python3.9/site-packages/youtube_dl-2021.4.7-py3.9.egg-info/PKG-INFO.
Removing obsolete file /opt/lib/python3.9/site-packages/youtube_dl-2021.4.7-py3.9.egg-info/SOURCES.txt.
Upgrading transmission-cli on root from 3.00-11 to 3.00-14...
Downloading http://bin.entware.net/mipselsf-k3.4/transmission-cli_3.00-14_mipsel-3.4.ipk
Upgrading python3-lzma on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-lzma_3.9.6-2_mipsel-3.4.ipk
Upgrading libgdbm on root from 1.19-2 to 1.19-3...
Downloading http://bin.entware.net/mipselsf-k3.4/libgdbm_1.19-3_mipsel-3.4.ipk
Upgrading transmission-web on root from 3.00-11 to 3.00-14...
Downloading http://bin.entware.net/mipselsf-k3.4/transmission-web_3.00-14_all.ipk
Upgrading python3-unittest on root from 3.9.5-2 to 3.9.6-2...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-unittest_3.9.6-2_mipsel-3.4.ipk
Configuring alsa-lib.
Configuring libnettle.
Configuring libjpeg-turbo.
Configuring libpcre2.
Configuring php7.
Configuring libcurl.
Configuring php7-mod-curl.
Configuring libuuid.
Configuring libuv.
Configuring libpcre.
Configuring libpython3.
Configuring python3-base.
Configuring libffi.
Configuring python3-light.
Configuring python3-email.
Configuring python3-urllib.
Configuring bash.
Configuring python3-pydoc.
Configuring libgdbm.
Configuring uhttpd_kn.
Configuring libmbedtls.
Configuring libblkid.
Configuring libmount.
Configuring mc.
Configuring pciids.
Configuring libnghttp2.
Configuring php7-cgi.
Configuring libpcre2-32.
Configuring python3-cgi.
Configuring python3-cgitb.
Configuring python3-decimal.
Configuring python3-xml.
Configuring python3-asyncio.
Configuring python3-codecs.
Configuring python3-ctypes.
Configuring python3-dbm.
Configuring python3-distutils.
Configuring python3-logging.
Configuring python3-lzma.
Configuring python3-multiprocessing.
Configuring python3-ncurses.
Configuring python3-openssl.
Configuring python3-readline.
Configuring python3-sqlite3.
Configuring python3-unittest.
Configuring python3.
Configuring python3-pkg-resources.
Configuring python3-setuptools.
Configuring usbids.
Configuring php7-cli.
Configuring libpcap.
Configuring php7-mod-json.
Configuring curl.
Configuring transmission-remote.
Configuring php7-mod-session.
Configuring opt-ndmsv2.
Updating /opt/etc/ld.so.cache... done.
Configuring openvpn-openssl.
Configuring transmission-daemon.
Configuring youtube-dl.
Configuring transmission-cli.
Configuring transmission-web.
Collected errors:
 * resolve_conffiles: Existing conffile /opt/etc/passwd is different from the conffile in the new package. The new conffile will be placed at /opt/etc/passwd-opkg.
 * resolve_conffiles: Existing conffile /opt/etc/transmission/settings.json is different from the conffile in the new package. The new conffile will be placed at /opt/etc/transmission/settings.json-opkg.
 

 

Link to comment
Share on other sites

Надо больше информации...

ZKO2

Скрытый текст

 

~ # 
~ # youtube-dl --verbose -o 'CD' https://www.youtube.com/watch?v=xxx
[debug] System config: []
[debug] User config: []
[debug] Custom config: []
[debug] Command-line args: ['--verbose', '-o', 'CD', 'https://www.youtube.com/watch?v=xxx']
[debug] Encodings: locale UTF-8, fs utf-8, out utf-8, pref UTF-8
[debug] youtube-dl version 2021.06.06
[debug] Python version 3.9.6 (CPython) - Linux-3.4.113-mips-with-glibc2.27
[debug] exe versions: none
[debug] Proxy map: {}
[youtube] xxx: Downloading webpage
[youtube] xxx: Downloading player c29c59cf
[debug] Default format spec: best/bestvideo+bestaudio
[debug] Invoking downloader on 'https://r2---sn-2vnu-hg8e.googlevideo.com/videoplayback?expire=xxx'
[download] Destination: CD
[download]  79.2% of 8.45MiB at 65.49KiB/s ETA 00:27[download] Got server HTTP error: [Errno 131] Connection reset by peer. Retrying (attempt 1 of 10)...
[download] Destination: CD
[download] 100% of 8.45MiB in 03:30
~ # 
~ # youtube-dl -o 'CD1' https://www.youtube.com/watch?v=xxx
[youtube] xxx: Downloading webpage
[download] Destination: CD1
[download] 100% of 8.45MiB in 03:20
~ # 
~ # ls -al CD*
-rw-r--r--    1 root     root       8863116 Oct 21  2018 CD
-rw-r--r--    1 root     root       8863116 Oct 21  2018 CD1
~ #

KN-2710

Скрытый текст

 

~ # 
~ # youtube-dl -o 'CD' https://www.youtube.com/watch?v=xxx
[youtube] xxx: Downloading webpage
[youtube] xxx: Downloading player c29c59cf
[download] Destination: CD
[download] 100% of 8.45MiB in 00:00
~ # 
~ # ls -al CD
-rw-r--r--    1 root     root       8863116 Oct 21  2018 CD
~ # 

 

 

Link to comment
Share on other sites

1 час назад, TheBB сказал:

Надо больше информации...

 

Какая именно информация необходима?

~ # uname -a
Linux Keenetic-3179 4.9-ndm-4 #2 SMP Thu Jul 15 18:55:15 MSK 2021 mips GNU/Linux
~ # python3 -V
Python 3.9.6
~ # /opt/bin/youtube-dl --version
Traceback (most recent call last):
  File "/opt/bin/youtube-dl", line 33, in <module>
    sys.exit(load_entry_point('youtube-dl==2021.6.6', 'console_scripts', 'youtube-dl')())
  File "/opt/bin/youtube-dl", line 25, in importlib_load_entry_point
    return next(matches).load()
StopIteration
~ # youtube-dl --version
Traceback (most recent call last):
  File "/opt/bin/youtube-dl", line 33, in <module>
    sys.exit(load_entry_point('youtube-dl==2021.6.6', 'console_scripts', 'youtube-dl')())
  File "/opt/bin/youtube-dl", line 25, in importlib_load_entry_point
    return next(matches).load()
StopIteration


 

~ # youtube-dl -o 'CD' https://www.youtube.com/watch?v=xxx
Traceback (most recent call last):
  File "/opt/bin/youtube-dl", line 33, in <module>
    sys.exit(load_entry_point('youtube-dl==2021.6.6', 'console_scripts', 'youtube-dl')())
  File "/opt/bin/youtube-dl", line 25, in importlib_load_entry_point
    return next(matches).load()
StopIteration

Пробовал удалить python3 и youtube-dl и установить по новой. Результат аналогичный.

Link to comment
Share on other sites

Мешают "хвосты", оставшиеся после обновления. Или вычищать руками, или удалить все пакеты python`a + удалить директорию "/opt/lib/python3.9" и накатить пакеты обратно.

Link to comment
Share on other sites

1 час назад, TheBB сказал:

Мешают "хвосты", оставшиеся после обновления. Или вычищать руками, или удалить все пакеты python`a + удалить директорию "/opt/lib/python3.9" и накатить пакеты обратно.

Да, всё решилось. Путём полной переустановки Entware (тоже не взлетело с первого раза, ругнулось на установку glibc). Так как пробовал удалить python3 и зависимости и видать что-то пошло не так. Спасибо!

Подскажите пожалуйста или ткните пальцем где почитать, как поступать в следующий раз? Имеется ввиду как правильно обновлять пакеты, чтобы избежать повторения аналогичной ситуации. Потому как полноценная переустановка каждый раз Entware не очень удобный вариант, хотя и не самый трудоёмкий.
То есть стоит ли обновлять командами opkg update && opkg upgrade ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...