Jump to content
  • 0

Некорректная работа Wake-on-LAN


dimon27254
 Share

Question

После обновления KN-3010 с 3.7.4 на 3.8.4 заметил, что при попытке разбудить устройство по сети, WoL пакеты стали отправляться по-другому. Нижеописанное происходит и на 3.9 Alpha 7.

Теперь отправка идет на интерфейсы с security-level private и public.

Bridge0 имеет security-level private, у Bridge1 security-level protected.

Судя по логу, отправка идет также в PPPoE (PPPoE0), IPoE (GigabitEthernet0/Vlan11) и Wireguard (Wireguard3), имеющие security-level public, что сопровождается ошибкой:

Скрытый текст

1336854299_(20).png.e4464f987f8046e1604661726a3f3806.png

При этом, устройства на Bridge0 успешно пробуждаются, а на интерфейсе Bridge1 пробуждение устройств не происходит, так как туда не отправляются пакеты WoL.

Если же на Bridge1 поставить security-level private, то пакеты начинают туда уходить:

Скрытый текст

565425590_2022-08-28111236.png.fe6c85100d488f6b8a4a1f3c6789ccc7.png

На 3.7.4 поведение иное, там отправка пакета идет только на интерфейсы private (Bridge0) и protected (Bridge1). Все работает корректно:

Скрытый текст

311109131_(19).png.bde3ef0a0705f94c18a7106b18617760.png

В документации по CLI для 3.7-3.9 также написано, что отправка идет только на интерфейсы private и protected.

@Le ecureuil, где-то закралась ошибка в коде 3.8-3.9, или же изменилась работа WoL?

Edited by dimon27254
Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Добавлю еще эффект. К mesh-ретранслятору по проводу подключен PC. Заменил ретранслятор Giga III с 3.7.х на новый Ultra KN-1810 с 3.8.5. Теперь PC не может уйти в режим сна, точнее уходит, примерно на минуту, и самопроизвольно пробуждается по WOL (который никто не шлет).

Link to comment
Share on other sites

  • 0
9 часов назад, PVN сказал:

Добавлю еще эффект. К mesh-ретранслятору по проводу подключен PC. Заменил ретранслятор Giga III с 3.7.х на новый Ultra KN-1810 с 3.8.5. Теперь PC не может уйти в режим сна, точнее уходит, примерно на минуту, и самопроизвольно пробуждается по WOL (который никто не шлет).

А вы уверены, что в настройках сетевки не включено Wake On Link?

Link to comment
Share on other sites

  • 0
11 час назад, 4e.Guevara сказал:

А вы уверены, что в настройках сетевки не включено Wake On Link?

.. был заменен только роутер Giga III с 3.7.х на новый Ultra KN-1810 на который сразу установилась 3.8.5, настройки PC не менялись.

До замены, WOLan работал правильно, только по запросу. 

WOLink отключен

Скрытый текст

image.jpeg.36373a847e6f20c7c6d1d7d0a2aeb2c6.jpeg

Пришлось отключить разрешение на вывод PC из ждущего режима, что для меня крайне неудобно

Скрытый текст

image.jpeg.c13bd856dff93c925d380e8a3f10a3fb.jpeg

 

Link to comment
Share on other sites

  • 0
10 минут назад, 4e.Guevara сказал:

Отключите и проверьте. Для WoL достаточно только Wake on Magic Packet

Да! Все работает как надо. Вы кудесник)

Спасибо!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...