Перейти к содержимому
  • 0

4.0 Alpha 3: Не активируются Wireguard подключения


Andyroll

Вопрос

Вообще баг появился сразу при выходе 4.0 Alpha, подумал может кто заметит, напишет....

Всё на видео.

Баг. Версия 4.0 Alpha 3 

https://i.imgur.com/Vm5FBby.mp4

 

Ошибка не воспроизводится. Версия ПО 3.9.0

Изменено пользователем Andyroll
UPD добавил ссылку на видео
Ссылка на комментарий
Поделиться на других сайтах

Рекомендуемые сообщения

  • 0
В 13.01.2023 в 02:38, Andyroll сказал:

Вообще баг появился сразу при выходе 4.0 Alpha, подумал может кто заметит, напишет....

Всё на видео.

Баг. Версия 4.0 Alpha 3 

https://i.imgur.com/Vm5FBby.mp4

 

Ошибка не воспроизводится. Версия ПО 3.9.0

 

так в профиле должно быть 2 конекта VPN и ваш провайдер.

Ссылка на комментарий
Поделиться на других сайтах

  • 0
6 часов назад, PASPARTU сказал:

так в профиле должно быть 2 конекта VPN и ваш провайдер.

Та, не. Вы же видели пример с 3.9. Сделал ради спорт. интереса (зачем хз). Ничего не получилось, проблема осталась. Интересно то что к примеру с тем же Warp ну или с другим VPN провайдером, соединение может подхватиться а может и нет, ну чаще нет. Фиг знает... Сидим на 3.9...

Ссылка на комментарий
Поделиться на других сайтах

  • 0
2 часа назад, Andyroll сказал:

Та, не. Вы же видели пример с 3.9. Сделал ради спорт. интереса (зачем хз). Ничего не получилось, проблема осталась. Интересно то что к примеру с тем же Warp ну или с другим VPN провайдером, соединение может подхватиться а может и нет, ну чаще нет. Фиг знает... Сидим на 3.9...

А что вы скажите ПО 404 - три wireguard соединения, первое warp, второе wg-proton, третье vpnjantit. В итоге имеем speedtest и yandex измеритель

Скрытый текст

1485693866_-4.thumb.jpg.bba8b72ef2f30febc477eb1c55b5ed6d.jpg

1952008072_-2.jpg.e64c74354c063c03f50a47e5790a33dc.jpg

Теперь на что хотелось бы обратить внимание при проверки на вашем сайте

Скрытый текст

444486892_-5.jpg.4f18bfec0e9caf303f031df7baa68074.jpg

В моем случае на ПК и с FF браузером (так как некоторые сервисы просят не FF браузер то была замена на user agent - yandex) на котором выключен webrtc и стоит uBlock Origin, так же AdguarhHome DNS на роутере (со своими настройками и фильтрами, он же для всех трех каналов wireguard) кроме как на warp подключение не смог определить не чего.

На смартфоне Sams и его родном браузере Интернета без разницы на каком канале - speedtest показывает провайдера, yandex измеритель аналогично, ваш ipaddress аналогично. 

Механизм этого всего - клиент в профиле - это маркировка пакетов для данного профиля и создание таблицы маршрутизации с привязкой к данному профилю. Данный механизм не подвергался изменениям скорей всего. Проверю позже на 3.9 которая на основном канале ради спортивного интереса.

Изменено пользователем vasek00
Ссылка на комментарий
Поделиться на других сайтах

  • 0
8 часов назад, vasek00 сказал:

А что вы скажите ПО 404 - три wireguard соединения, первое warp, второе wg-proton, третье vpnjantit. В итоге имеем speedtest и yandex измеритель

  Показать содержимое

1485693866_-4.thumb.jpg.bba8b72ef2f30febc477eb1c55b5ed6d.jpg

1952008072_-2.jpg.e64c74354c063c03f50a47e5790a33dc.jpg

Теперь на что хотелось бы обратить внимание при проверки на вашем сайте

  Показать содержимое

444486892_-5.jpg.4f18bfec0e9caf303f031df7baa68074.jpg

В моем случае на ПК и с FF браузером (так как некоторые сервисы просят не FF браузер то была замена на user agent - yandex) на котором выключен webrtc и стоит uBlock Origin, так же AdguarhHome DNS на роутере (со своими настройками и фильтрами, он же для всех трех каналов wireguard) кроме как на warp подключение не смог определить не чего.

На смартфоне Sams и его родном браузере Интернета без разницы на каком канале - speedtest показывает провайдера, yandex измеритель аналогично, ваш ipaddress аналогично. 

Механизм этого всего - клиент в профиле - это маркировка пакетов для данного профиля и создание таблицы маршрутизации с привязкой к данному профилю. Данный механизм не подвергался изменениям скорей всего. Проверю позже на 3.9 которая на основном канале ради спортивного интереса.

Я на Хромом серфю просторы интернетов. 

По поводу сайта который у меня в примере, выбрал этот, для данного поста, что бы видно было флаг страны (без ip, зачем их палить). Так что на всех остальных сайтах по проверки вашего ip (browserleaks.commyip.ruwhoer.net/ru, etc.) всё тоже самое. В смысле на 3.9.. всё работает, на 4.0.. редко подхватывает VPN соединения и показывает ip vpn, но чаще тупо адрес моего провайдера как будто я и впн не включал. Единственное, я последнее время использую вот такую настройку https://i.imgur.com/ATpTXPX.png, поля DNS и MTU оставляю пустыми на всех VPN соединениях (если что то не то с открытием сайтов произойдёт, то можно и MTU подкрутить). 

Используются DoT от NextDNS

Ссылка на комментарий
Поделиться на других сайтах

  • 0
18 часов назад, Andyroll сказал:

Так что на всех остальных сайтах по проверки вашего ip (browserleaks.commyip.ruwhoer.net/ru, etc.) всё тоже самое. В смысле на 3.9.. всё работает, на 4.0.. редко подхватывает VPN соединения и показывает ip vpn, но чаще тупо адрес моего провайдера как будто я и впн не включал.

Так и не понял что там редко подхватывается и где Вообще баг появился сразу при выходе 4.0 Alpha

На VPN wireguard warp на ваших сайтах browserleaks.commyip.ruwhoer.net/ru описанную вами проблему не заметил, светился адрес от cloudflare warp 104.28....... Версия последняя 4.0

 

Ссылка на комментарий
Поделиться на других сайтах

  • 0

Alpha 5, та же шняга.

Хз, может дохленький по железу этот лайт.

На 3.9... Подключил, соединение (любого vpn провайдера) подхватилось, полетел по интернет сети, шарится.

Ссылка на комментарий
Поделиться на других сайтах

  • 0
В 23.01.2023 в 12:47, vasek00 сказал:

VPN wireguard warp

warp у меня почему та на 4.0... чаще всего подхватывается, а вот другие (такие как KeepSolid VPN Unlimited, proton vpn, ещё какой то...) беда. Заладили, warp, warp...

Ссылка на комментарий
Поделиться на других сайтах

  • 0
В 23.01.2023 в 12:47, vasek00 сказал:

Так и не понял что там редко подхватывается

В терминах не силён, как есть так и называю. Вы видео смотрели? Ещё раз посмотрите. и увидите что на 4.0 при переносе  устройства "Применение политик" в профиль с активным vpn, ничего не срабатывает. Ip адрес ( далее на видео видно, что на сайте виден флаг РБ, а должен быть англиЦкий например) остаётся от моего прова.

Ссылка на комментарий
Поделиться на других сайтах

  • 0
2 часа назад, Andyroll сказал:

В терминах не силён, как есть так и называю. Вы видео смотрели? Ещё раз посмотрите. и увидите что на 4.0 при переносе  устройства "Применение политик" в профиль с активным vpn, ничего не срабатывает. Ip адрес ( далее на видео видно, что на сайте виден флаг РБ, а должен быть англиЦкий например) остаётся от моего прова.

Есть клиент и два профиля в которых WG - постоянно один, а иногда другой другой канал WG, при перемещение пользователя по профилям без проблем все меняется (уточню тут не сразу, сек. до 3-5 тут и вопросов не должно возникнуть по этим 3-5сек.). Как работало всю жизнь на draft c 3.9 так и работает на draft c 4.0.х.

С Wireguard от Proton так же вопросов нет.

2 часа назад, Andyroll сказал:

Заладили, warp, warp...

То что используется без проблем про то и заладили.

Ссылка на комментарий
Поделиться на других сайтах

  • 0
4 часа назад, vasek00 сказал:

(уточню тут не сразу, сек. до 3-5 тут и вопросов не должно возникнуть по этим 3-5сек.)

Ну вы явно не на "полудохлом" лайт это всё делаете. А так да, бывает и до 3-5 секунд "активируется" бывает быстрей :), но это всё на 3.9...

Ссылка на комментарий
Поделиться на других сайтах

  • 0
3 часа назад, Andyroll сказал:

Ну вы явно не на "полудохлом" лайт это всё делаете. А так да, бывает и до 3-5 секунд "активируется" бывает быстрей :), но это всё на 3.9...

О какой активации идет речь, вы про что, я даже не писал про это. В данном профиле уже все давно активировано, вы просто перемещаете пользователя из одного профиля в другой. 

Изменено пользователем vasek00
Ссылка на комментарий
Поделиться на других сайтах

  • 0
12 минуты назад, vasek00 сказал:

В данном профиле уже все давно активировано, вы просто перемещаете пользователя из одного профиля в другой. 

Активацией называю то когда VPN работает на устрйстве. Запускаю VPN (активирую что ли), потом в оконцовке переношу ус-во (во вкладке "Применение политик") в профиль(политика доступа) "VPN". На 3.9 активируется VPN подключение на устройстве перенесённом в этот профиль, на 4.0... не активируется. Вы видео пересмотрите внимательно. Боже....

 

Изменено пользователем Andyroll
UPD
Ссылка на комментарий
Поделиться на других сайтах

  • 0

Активация vpn правильней сказать это "подъем/up" сетевого интерфеса wireguard/openvpn/pptp/l2tp и т.д. Есть клиент в данном профиле или нет не имеет значения. Помещая клиента в данный профиль в нем есть маршрут по умолчанию через данный сетевой интерфейс wireguard/openvpn/pptp/l2tp и т.д. В другом профиле через другой интерфейс. Проблему с подъемом данного интерфейса можно увидеть в логе. 

Проблема не возможности клиентом в данном профиле открыть страницу в интернете если нет ошибок в логе связана с настройками dns/фильтрами.

Ссылка на комментарий
Поделиться на других сайтах

  • 0
7 часов назад, vasek00 сказал:

Проблема не возможности клиентом в данном профиле открыть страницу в интернете

Так страницы открываются но без ip VNP провайдера. Как будто не перетаскивал клиента в профиль VPN. Попробую наверно позже, снова на 4.0... перейти и глянуть лог, (но вроде ничего криминально не было, краем глаза смотрел...). Если полезут ошибки, после момента перетягивания клиента в профиль VPN, отпишусь.

Изменено пользователем Andyroll
орфография
Ссылка на комментарий
Поделиться на других сайтах

  • 0

Вобщем, если убирать у Wireguard подключений чекбокс'ы с "Использовать для выхода в интернет"(как я обычно и делал на 3.9 и ранее), а потом включать обратно по нужде, то появляется данный баг. Что бы баг ушёл, нужно в "Приоритеты подключений" вкладка "Политики доступа в интернет" - Политика дотупа, удалить и по новой создать профиль VPN(на моём примере в видео).

В профиле впн можно ставить чекбокс на любое подключение VPN, далее уже во вкладке "Применение политик" перетягивать Устройство (как в моём примере на видео) в профиль VPN.

Итого: Убираю чекбоксы с "Использовать для выхода в интернет" и за компанию снимаю эти (их снятие/оставление не влияет на баг, проверял без перезагрузки и с перезагрузкой роутера),  потом, когда нужно, возвращаю назад, далее получаю баг. Это на 4.0.., на 3.9.. этого нет. 

Ссылка на комментарий
Поделиться на других сайтах

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Гость
Ответить на вопрос...

×   Вставлено в виде отформатированного текста.   Вставить в виде обычного текста

  Разрешено не более 75 смайлов.

×   Ваша ссылка была автоматически встроена.   Отобразить как ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставить изображения напрямую. Загрузите или вставьте изображения по ссылке.

  • Сейчас на странице   0 пользователей

    • Нет пользователей, просматривающих эту страницу
×
×
  • Создать...