Jump to content

Долгая загрузка чего-то. Приложение зависает.


Recommended Posts

Здравствуйте!

Открывая мобильное приложение на странице настроек, что видна на следующем скрине:

Скрытый текст

Screenshot_2024-06-29-00-47-45-072_com.keenetic_kn.thumb.png.c0a715aa6bd9091472bf5bfbd9c60b28.png

Я получаю только этот подзависший вид приложения. Т.е. буквально - не важно сколько ожидать - на экране крутится "это". Причем - ЧТО именно тут может подгружаться на этой странице - совершенно не ясно!? Ибо Все ожидаемые элементы интерфейса страницы присутствуют на своих местах. Т.е. я буквально ничего и не жду, чтобы увидеть после окончания этого процесса. Но оно подгружается. Что-то куда-то.

В web-версии этого портала, открываемого в браузере на стационарном компьютере - так же нет ничего такого нового/неожиданного в этом месте, равно как и процесса вечной подзагрузки тут нет. Хотя удивительного тут нет - в этой версии портала - все совсем по другому отрисовано и с другими элементами и их позициями. Ибо там же большой браузер... Места вагон.

Если же посмотреть журнал после энного времени ожидания, то в нём можно увидеть это:

Скрытый текст

Screenshot_2024-06-29-00-50-14-165_com.keenetic_kn.thumb.png.a5065f96b36a9f0eccfb7c5e8d7ce46b.png

Самое нижнее сообщение, кстати, так же постоянно повторяется при любом открытии журнала - даже когда я очень быстро туда прорываюсь сквозь зависшую подгрузку "чего-то". Вот что это такое? Оно же красное - ошибка т.е. ну и почему всегда 'not found' происходит? Что это за coalagent?

И да. Сквозь это висящее окно с кружком "вечной загрузки" оказалось можно провалиться на уровень основного интерфейса страницы настроек. И это странно кстати.

Кстати, точно так же можно провалиться и сквозь это окно:

Скрытый текст

Screenshot_2024-06-29-00-53-14-437_com.keenetic_kn.png.ad768f5240f5f3bf505d69b9bdba2e1e.png

И это очень странно и бесит. Потому как ожидается безусловно модальный диалог показа прогресса загрузки и НИКАКИМ образом я не должен иметь возможности убрать это окошко/провалиться на основной уровень интерфейса этой страницы. Ибо на ней я опять могу нажать кнопку "Обновления устройства" и.... Получить новое окно прогресса загрузки с нуля.... Хотя по факту идёт дозагрузка последних процентов ещё с первой моей попытки нажать эту кнопку. Просто этот диалог вдруг скрылся.

P.S. а еще у движка форума глючище. Моя последняя 3я фотка хоть и стоит в теге спойлер - но постоянно при любом редактировании поста дублем вылазит ЗА пределы текста. Вот сейчас в редакторе это предложение последнее, а при рендеринге - вы увидите повтор фотки из последнего спойлера....@admin

 

  • Upvote 2
Link to comment
Share on other sites

Подтверждаю, вкладка "интернет, мои сети wifi, сетевые правила" не работают в приложении "Ошибка: Что-то пошло не так" , при этом бесконечная загрузка грузит ЦП роутера с 2% до 20%, тоже самое происходит и в Web (beta). @admin

Link to comment
Share on other sites

Непонятным образом вчера (28.06) на смартфоне выбросило из приложения. После авторизации вновь поприлетали уведомления начиная с 23.06 по всем роутерам. "Потерялись" цифры приложений (sstp-server. udp-proxy и прочее) в главном окне роутера (каждого!). В каждом подразделе главного экрана устройства подолгу "вертится" кружок, типа что-то грузит (туда или обратно - непонятно). Гораздо чаще стало появляться "Ошибка. Что-то пошло не так."

 

Скрытый текст

Screenshot_20240629-145249.jpg

 

 

Скрытый текст

Screenshot_20240629-145303.jpg

 

Edited by KeyYerS
Link to comment
Share on other sites

Хм... Посмотрел тут с пяток топиков в этом разделе форума, тройку других в другом и...

И что-то я совершенно не вижу активности от разработчиков и сотрудников компании.

Типа форум совершенно чисто для общения пользователей меж собой и всё?

  • Upvote 1
Link to comment
Share on other sites

Прошивка 4.2 Alpha 16, версия приложения 52 (233) всё работает стабильно.

По поводу необходимости перелогина в телеграме https://t.me/keeneticcloud писали, что было обыло обновление на сервере.

Edited by Rootdiv
Link to comment
Share on other sites

Есть тема -

но снова что-то мешает реализовать такое уведомление в приложении.... Телеграм не у всех, а приложение - у всех /желающих/ есть. Кроме внезапных аварий, что и так понятно, все работы на серверах планируются заранее. Почему бы не отписаться в приложение уведомлением - типа "Тогда-то с такого по такое время работы на серверах, бла-бла-бла за неудобства"   А так сиди, гадай - что опять случилось...

Edited by KeyYerS
Link to comment
Share on other sites

Posted (edited)
12 часа назад, Rootdiv сказал:

версия приложения 52 (233)

Если это некая бета - то мы не на ней сидим - а на релизе. А релиз в плеймаркете лишь 51 версии. И на ней есть ошибки.

Про перелогин - вообще не понятно: куда и к чему об этом.

Edited by KuruToga
Link to comment
Share on other sites

12 минуты назад, KuruToga сказал:

Если это некая бета - то мы не на ней сидим - а на релизе. А релиз в плеймаркете лишь 51 версии. И на ней есть ошибки.

Да, это бета. У Вас в посте не сказано какая версия приложения используется. В одной из Alpha версии прошивки было изменение API и поэтому релизная версия приложения может не работать.

15 минут назад, KuruToga сказал:

Про перелогин - вообще не понятно: куда и к чему об этом.

Про перелогин это к сообщению выше.

Link to comment
Share on other sites

Posted (edited)

Ок, обновился до беты и да - эта страница портала стала открываться нормально.

Но одна ошибка в логе все равно висит:

Июн 30 14:48:52 
ndm
Core::Scgi::ThreadPool: not found: "traffic-shape" (coala/rci).

ну вот если нет какого-то модуля в моей прошивке (не суть по какой причине - ну вот не нужен компонет и точка) -

то зачем пугать меня красными ошибками? Это же нонсенс - предупреждать, что что-то не найдено - если есть четкое

мое решение не ставить это в прошивке. Да и что в принципе это за модуль такой "traffic-shape"?

Edited by KuruToga
Link to comment
Share on other sites

56 минут назад, KuruToga сказал:

ну вот если нет какого-то модуля в моей прошивке (не суть по какой причине - ну вот не нужен компонет и точка) -

то зачем пугать меня красными ошибками? Это же нонсенс - предупреждать, что что-то не найдено - если есть четкое

Об этом нужно писать сюда https://forum.keenetic.com/forum/8-тестирование-dev-сборок/

Link to comment
Share on other sites

1 час назад, KuruToga сказал:

Да и что в принципе это за модуль такой "traffic-shape"?

Модуль называется "Ограничение скорости Интернета для клиентов (Шейпер трафика)"

Link to comment
Share on other sites

Тогда напрашивается вопрос:  приложение "натягивает" свои настройки на роутер, перепроверяя свой список компонентов? Или должно тупо перечитывать с роутера ЕГО установленные/задействованные компоненты и отображать их при необходимости (наличии)?

Логически рассуждая по вышесказанному в текущей теме и в теме про "Лишний Error в логе...." возникает диссонанс:    роутер имеет "нужные" мне компоненты на борту; работает как полагается...; а приложение упорно пытается принудительно задействовать компонент "Шейпер трафика", которого на роутере нет и в помине... Вот и полон лог ошибок, которые и ошибками то в данном случае не являются; а пользователя напрягают красным цветом (да и вообще своим присутствием).

Версия 52 приложения вконец за-beta-нировалась - с 08.05.2024 с бета-релиза 226 уже до бета-релиза 234 от 29.06.2024 доспотыкалась....  И каждая последующая бета-версия в продолжение тащит все свои прежние "косяки".   Печалька!...

Link to comment
Share on other sites

Posted (edited)

Странно и другое. Я же вроде с надеждой указал в первом посте про глюки форумного движка и "вызвал" @админа,

чтобы он проверил указанный глюк. Но до сих пор никакой реакции. Походу точно в этом форуме "варимся" только мы - участники.

P.S.

Ок, по подсказке ниже взываю к @Alex Sh. 

и еще - как в редакторе сообщений топика по нажатию Enter сделать так, чтобы предложения не переносились как абзацы?

А шли сплошным "близкорасположенным" текстом?

Вот в этом посте по логике должно быть ЛИШЬ 3 логических абзаца. А по факту рендерятся 7 моих предложений как 7 абзацев.

Edited by KuruToga
  • Upvote 1
Link to comment
Share on other sites

2 часа назад, KuruToga сказал:

Странно и другое. Я же вроде с надеждой указал в первом посте про глюки форумного движка и "вызвал" @админа,

чтобы он проверил указанный глюк. Но до сих пор никакой реакции. Походу точно в этом форуме "варимся" только мы - участники.

Тут надо вызвать @Alex Sh. т.к. судя по разделу он связан с мобильной разработкой.

  • Thanks 1
Link to comment
Share on other sites

Posted (edited)

Вот, что ответил админ из телеграма, но моё сообщение об ошибке "traffic-shape": 

Цитата

Так и роутер на релихз переведите если у вас нудлевое понимание что такое бета и альфа версии и вас бомбит от красных буковок в логе которые никак не вляют на работу. Ок?

И вот скриншот переписки 

Скрытый текст

Screenshot_20240701_130124_Telegram.thumb.jpg.27bc75935502d64226d28533fc51c491.jpg

 

Edited by Rootdiv
Link to comment
Share on other sites

У мну на разных моделях с разными стабильными прошивками (не альфами и бетами) на всех при отсутствии компонента "Шейпер трафика" в логах эти "красные" ошибки.    Неаргументированно неадекватная реакция того "админа" в прилагаемой Вами переписке лишь подтверждает корявость разработчиков сервиса cloud'а, элементарно не принимавших во внимание проверку/определение установленного пользователем на роутер набора компонентов.  Вывод:  какой бы ни был у Вас набор компонентов на роутере - сервис cloud'а упорно тычется в фантомный "шейпер", пытаясь перечитать его параметры...

  • Thanks 1
Link to comment
Share on other sites

Всем за детали спасибо, ошибку на удаленный компонент поправим, и влияет ли она на долгую загрузку — проверим. Моб. админ постарается быть повнимательнее к жалобам, он там явно перегнул.

  • Thanks 3
Link to comment
Share on other sites

28 минут назад, admin сказал:

Всем за детали спасибо, ошибку на удаленный компонент поправим, и влияет ли она на долгую загрузку — проверим. Моб. админ постарается быть повнимательнее к жалобам, он там явно перегнул.

День добрый! Спасибо за "рулёжку")) НО надо внести ясность. Мой этот пост, ваш выше и еще два поста выше вашего по правде должны быть перенесены в тему "Лишний Error в логе....". Ибо именно там я решил отдельно и точечно писать про ошибку "traffic-shape". Чтобы не пересекаться с сутью моей ошибки, изложенной в этом топике.

 

  • Upvote 1
Link to comment
Share on other sites

В текущем топике суть МОЕЙ первой замеченной ошибки долгой загрузки решилась же тем образом, что оказывается надо было кроме обновления прошивки на альфу - еще и мобильное приложение до беты обновлять. Ошибка лога про неустановленный компонент на это никак не влияет. Можно и не проверять.

И еще что осталось не выясненным из моих описанных выше ошибок тут - это поведение форумного движка. В изначальном посте этого топика я не могу загнать третье фото в спойлер так, чтобы это фото САМО! без моего вмешательства! не скопировалось в самый конец текста этого поста. Как бы я не форматировал этот конец текста - обязательно после сохранения и отрисовки страницы после этого я вижу, что фото опять само "приклеивается" к концу текста поста.

 

Link to comment
Share on other sites

Posted (edited)

А вот что из НОВОГО замеченного про долгую загрузку (с учётом того, что уже стоит последняя бета мобильного приложения и последняя альфа прошивки) - это вот что: у меня резко отрубили инет. Я полез проверять журнал, чтобы убедиться, что инет реально отвалился. И вот когда я попадаю на главную страницу мобильного портала - где указаны гигабайты моего трафика, название роутера, версия его прошивки, 4 кнопки действий, перечислены клиенты сети - начиная с этого момента я вижу постоянно мельтешащий кружок загрузки чего-то, препятствующий мне спокойному входу на страницу роутера, что была мной указана в моем тут самом первом посте выше, в первом же спойлере. НО! если выше это было прояснено тем, что в прошивке сменился АПИ и в мобильном приложении сменился код его поддержки - но так как это все было сделано в бете приложения, а я её сразу не поставил - то теперь-то все составляющие вроде как верные - всё установлено верно, а тормоза-то остались!

Я сперва не придал этому значение и даже не думал тут это описывать ибо потом мне инет вернули и я забыл... До текущего момента. Когда решился проверить ситуацию с простым выдергиванием провода из WAN порта роутера. В общем у меня складывается такое впечатление, что из-за того, что приложение в ПЕРВУЮ очередь пытается зайти на мой роутер через подключенный KeenDNS/KeeneticCloud/KeenID - т.е. фигурально выражаясь, зайти ИЗВНЕ в роутер, чтобы дать мне возможность его "удалённого" управления - то .... это фиаско! Инета нет, роутер стоит ЛОКАЛЬНО в WiFi сети, прога стоит на смартфоне, сидящем в этой локальной сети, НО! управление пытается что-то там считать через кинетик-облако?! чтобы что-то там в приложении активировать/загрузить?

ЗАЧЕМ? Почему приложение долго висит при попытке зайти в роутер, когда этот роутер находится вот прям на расстоянии вытянутой руки в локалке? Чего такого важного приложению надо вытащить через Инет, что без него приложение не даёт мне по сути возможности управления роутером? Практически повторяется та же ситуация, что я описал в первом моём тут посте. Картинка же та же! Вечный кружок подгрузки чего-то там. Только теперь причина явно не в неверной версии приложения!

А дальше больше - если я все же дождусь какого-то просвета в показе бесконечной загрузки "чего-то там" - то при проваливании в раздел Управления (мы же помним, что моей целью являлась проверка журнала!) моему взгляду откроется вот это:

Скрытый текст

Screenshot_2024-07-04-11-35-56-953_com.keenetic_kn01.thumb.jpg.62f32af600d29584f662d6849837b449.jpg

Т.е. БЕЗ наличия доступа к инету! локально у меня НЕТ никаких прав и возможностей по управлению! Скрыты же ВСЕ сопутствующие элементы интерфейса этой страницы! Даже кнопки Перезагрузка тут теперь нет! И всего-то надо было потерять доступ к роутеру извне? Чтобы локально не иметь возможности сделать ничего? Чего такого важного из/через KeenDNS/KeeneticCloud/KeenID надо тащить, чтобы блокировать этим весь функционал приложения?

Да - это мобильное приложение, да - им надо пользоваться порой даже из другого города)) и да - понятно, что доступ к роутеру всегда посредством чего-то там умного "удалённого" в виде KeenDNS/KeeneticCloud/KeenID через инет - это его большая плюшка. НО! и вполне же это приложение может быть умным настолько чтобы определять факт ВОЗМОЖНОСТИ подключения к роутеру мгновенно ЛОКАЛЬНО! в той же сети, где находится и приложение и сам роутер. Чтобы позволить себе считывать все данные напрямую из него! Не зацикливаясь на том, что инета сейчас нет.

Edited by KuruToga
  • Thanks 1
Link to comment
Share on other sites

5 часов назад, KuruToga сказал:

ЗАЧЕМ? Почему приложение долго висит при попытке зайти в роутер, когда этот роутер находится вот прям на расстоянии вытянутой руки в локалке?

Приложение разработано так, чтобы нормально работать с роутером по Wi-Fi, если он при этом не подключен к интернету. Этот сценарий тестируется. Хотя мы и могли что-то упустить, давайте разберемся.

Для начала убедитесь, что Ваш телефон во время проверки не перешел на мобильную сеть. Выключите мобильный интернет на телефоне, для чистоты эксперимента оставьте только Wi-Fi. Также убедитесь, что телефон не подключился к другой Wi-Fi-сети. Если проблема сохраняется, попробуем с Вашей помощью разобраться, дальше объясним как.

Link to comment
Share on other sites

Смартфон сам на мобильный инет не может переподключаться. А я не включаю его когда есть ВайФай.
На другую сеть тоже нет возможности перейти - ибо она одна лишь доступна для входа - моя домашняя))

А КАК именно по бумагам проходит сценарий удачного тестирования?
Ибо может же оказаться так, что по ним всё нормас, если при включении приложения и при переходе на
каждую нужную страницу портала НАДО выжидать момента подзагрузки чего-то там, что выражается
в виде показа кружка загрузки(((

Ну, т.е. может у вас в скриптах/сценариях тестирования считается ок - если есть некая задержка.
А я-то пишу про то, что я вообще не вижу логики в ее наличии. Т.е. может я и напрасно бухчу?

  • Upvote 1
Link to comment
Share on other sites

7 часов назад, KuruToga сказал:

еще и мобильное приложение до беты обновлять

На 51 версии приложения "локальный" роутер (из всего длинного списка устройств активный только он), к которому я подключен по wifi, (при выключенной передаче данных по моб/связи) вроде как слегка задумчиво, но открывает свои недра во всех уровнях.

Может что при компиляции множества релизов 52-ой версии "потерялось/сломалось"?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...