Jump to content
  • 0

Доступ к web интерфейсу через wan


gaaronk
 Share

Question

14 answers to this question

Recommended Posts

  • 0
4 часа назад, gaaronk сказал:

При доступе к web интерфейсу через WAN порт раз в 5 секунд спрашивает пароль. Как это отключить?!

Это скорее похоже на бред, чем на правду. Поподробнее об условиях и окружении. Как воспроизвести эту ситуацию?

Link to comment
Share on other sites

  • 0

Сменить через CLI порт http сервера, попробовать зайти (даже изнутри) на web при помощи Safari.

В ответ на все GET или POST получать HTTP/1.1 401 Unauthorized

Чистка кэша, куков, local storage не помогает.

 

На IE такой проблемы нет.

 

Link to comment
Share on other sites

  • 0
1 минуту назад, gaaronk сказал:

Сменить через CLI порт http сервера, попробовать зайти (даже изнутри) на web при помощи Safari.

В ответ на все GET или POST получать HTTP/1.1 401 Unauthorized

Чистка кэша, куков, local storage не помогает.

 

На IE такой проблемы нет.

 

А, точно. Safari имеет бажную реализацию digest-авторизации, которая шлет неправильное значение nonce counter, и для обхода этой проблемы нужно полностью сломать и так ненадежную digest-авторизацию. Где-то уже была подобная тема, проходили.

Короче мы ничего для этого делать не будем, если реально хочется заходить из Safari - включайте SSL и заходите через него.

  • Thanks 1
Link to comment
Share on other sites

  • 0
1 minute ago, Le ecureuil said:

А, точно. Safari имеет бажную реализацию digest-авторизации, которая шлет неправильное значение nonce counter, и для обхода этой проблемы нужно полностью сломать и так ненадежную digest-авторизацию. Где-то уже была подобная тема, проходили.

Короче мы ничего для этого делать не будем, если реально хочется заходить из Safari - включайте SSL и заходите через него.

При чем в какой то момент все устаканивается и запрос на пароль не приходит, и через сафари все работает корректно.

Link to comment
Share on other sites

  • 0
4 минуты назад, gaaronk сказал:

Хмм. А как она работает?

Веб сервер так и остался на порту 8090. И там http, а не https.

Второй порт по стандартному https открывается

Link to comment
Share on other sites

  • 0

Проброс сделал. Все работает. В файрволе  сделал проброс лишнее прикрыл фильтрами.

 

Что удивительно, когда web интерфейс висит на порту 8080 то проблем в Safari нет. Перевешиваешь на другой порт - и все идет в разнос.

 

Вообщем всем спасибо за ответы.

Edited by gaaronk
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...