Jump to content

Recommended Posts

1 час назад, Piligrimm сказал:

sip.conf - копия с работающего астериска в этой же сети.

Интересует минимальный набор устанавливаемых пакетов(именно устанавливаемых), чтоб было так - установил минимум запустил, если все работает то устанавливаем следующий и проверяем. И желательно порядок установки минимального набора (а то там зависимости всякие).

Так может у старого в этом параметре его IP указан? Тут обычно говорят - конфиги в студию...

У астериска, который собирается из исходников на обычном сервере, есть специальная команда для установки минимальных конфигурационных файлов. Так что я не вспомню минимум. Тем боле что я всегда при сборке добавляю необходимые мне пакеты.

Совет - выключи автозагрузку модулей и смотри ошибки. Там тебе написано будет каких модулей не хватает.

Link to comment
Share on other sites

9 минут назад, ChaoticSerg сказал:

Так может у старого в этом параметре его IP указан? Тут обычно говорят - конфиги в студию...

У астериска, который собирается из исходников на обычном сервере, есть специальная команда для установки минимальных конфигурационных файлов. Так что я не вспомню минимум. Тем боле что я всегда при сборке добавляю необходимые мне пакеты.

Совет - выключи автозагрузку модулей и смотри ошибки. Там тебе написано будет каких модулей не хватает.

У меня в конфиге параметр externaddr не установлен (закомментирован).

Сейчас переустанавливаю всё. Изменил прошивку, ставлю другую версию Entware и будет другая сборка астериска. Потом отпишусь.

Link to comment
Share on other sites

1 час назад, Mamay сказал:

Учитесь пользоваться поиском...

Как не странно, но этот совет действительно помог ;)

При установки Entware в журнале событий кинетика 2 красные строчки:

Mar 30 13:05:39    ndmOpkg::Manager: invalid initrc "/opt/etc/initrc": no such file or directory, trying /opt/etc/init.d/.
Mar 30 13:06:18    ndmService: "Coala Agent": unexpectedly stopped.

Насколько это критично?

 

Link to comment
Share on other sites

В 30.03.2018 в 12:25, Piligrimm сказал:

У меня в конфиге параметр externaddr не установлен (закомментирован)

А вы припишите. У роутера слишком много сетевых интерфейсов. И локальные адреса тоже пропишите.

Link to comment
Share on other sites

3 часа назад, ChaoticSerg сказал:

А вы припишите. У роутера слишком много сетевых интерфейсов. И локальные адреса тоже пропишите.

Нет смысла. Все маршруты построены (динамические и статические), все сети и сервера доступны. После переустановки всё заработало и так. В принципе и должно было работать, видать глюк был.

Как я и сказал, всё заработало. Сейчас просто привожу всё в порядок (заодно и мысли) и документирую. Чуть позже поделюсь.

Да, вот вопрос. Астериск не опознает команду Read в экстеншене. Видать надо какой-то модуль доустановить. Может подскажите какой?

Всем очень признателен.

Link to comment
Share on other sites

Цитата

Проекты Entware-ng и Entware-ng-3x объединились под общим названием Entware.

все актуальные сборки теперь по адресу http://bin.entware.net/ , asterisk, представленный в этой теме, обновлён и остался по старому адресу...

Link to comment
Share on other sites

12 часа назад, TheBB сказал:

все актуальные сборки теперь по адресу http://bin.entware.net/ , asterisk, представленный в этой теме, обновлён и остался по старому адресу...

Сервер не доступен. Пинги не идут. Это только у меня?

Link to comment
Share on other sites

36 минут назад, Mamay сказал:

Оба сервера отвечают...

Да. Странно как-то. Перезагрузил кинетик и у меня всё заработало. А до перезагрузки не пинговался только этот сервер (эти сайты на одном сервере), всё остальное работало

 

Link to comment
Share on other sites

16 часов назад, Piligrimm сказал:

Да, вот вопрос. Астериск не опознает команду Read в экстеншене. Видать надо какой-то модуль доустановить. Может подскажите какой?

 

Сам себе отвечу

asterisk13-app-read

Правда перед ним установил модуль asterisk13-app-readexten, который  сам по себе ни какого эффекта не дал, но может эти оба  модуля должны быть установлены как сейчас у меня.

Link to comment
Share on other sites

  • 2 weeks later...

Доброе время суток, уважаемые форумчане!

Я новичек в данной теме - потому прошу помощи

Мой роутер:

Model Keenetic Giga II
Service tag 032-963-116-107-021
NDMS version v2.06(AAFS.0)C3

 

Хочется вставить GSM модем и использовать какой то SIP сервис (например Zadarma.com) для VOIP2GSM 

Заранее спасибо! Сорри если не туда написал. 

Прошу ткнуть носом куда смотреть.

 

Edited by Kobzantsev Maxim
Link to comment
Share on other sites

3 часа назад, Kobzantsev Maxim сказал:

Доброе время суток, уважаемые форумчане!

Я новичек в данной теме - потому прошу помощи

Мой роутер:

Model Keenetic Giga II
Service tag 032-963-116-107-021
NDMS version v2.06(AAFS.0)C3

 

Хочется вставить GSM модем и использовать какой то SIP сервис (например Zadarma.com) для VOIP2GSM 

Заранее спасибо! Сорри если не туда написал. 

Прошу ткнуть носом куда смотреть.

 

Вам нужен 2G/3G модем с активированным голосовым модулем, вот тут пример как это настроить -  https://asterisk-pbx.ru/wiki/artikle/gsm_voip_usb_chan_datacard_dongle_asterisk_huawei_e1550_e173 или https://habrahabr.ru/post/160299/

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 months later...
  • 3 weeks later...

Доброе время суток, уважаемые форумчане!

Помогите нубу.

Имеется Астериск 11, установленный отсюда .  С работой в терминале разобрался, но, похоже, не до конца. Проблема в следующем: после правки файлов конфигурации всё работает до перезагрузки роутера. Потом все правленые файлы конфигураций перезаписываются исходными ( как до правки). Нужна команда для сохранения? 

Link to comment
Share on other sites

  • 2 months later...

Добрый день.

Установил asterisk15.1.3 keenle на свой Keenetic GIGA II.

Ядро запусилось. Команда аsterisk -r работает. Но вот беда - отсутствует конфиг sip.conf.

Копирование старого конфига  (от asterisk 11) принудительно не помогло.

Как решить проблему?

Спрашиваю, так-как на своей железке компилировать из исходников не могу. GCC установить не получилось

Edited by Dmitry Koziukov
Link to comment
Share on other sites

Спасибо! Установил. SIP появился и работает.

Теперь другая проблема. для RTP есть куча зависимостей, одна из которых libsrtp2.

В списке модулей для скачивания либы нет ни для 13-й версии, ни для 15-й.

Как быть?

Edited by Dmitry Koziukov
Link to comment
Share on other sites

http://entware-3x.zyxmon.org/binaries/mipsel/experimental/libsrtp2_2.1.0-1_mipsel-3.4.ipk

модуль не установился.

Пишет, что не совместим по архитектуре. Он для mipsel.

 

Unknown package 'libsrtp2'.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for libsrtp2 found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package libsrtp2.

 

Есть где-либо для keenle?

Edited by Dmitry Koziukov
Link to comment
Share on other sites

~ # uname -a
Linux Keenetic_Giga 3.4.113 #1 SMP Tue Dec 4 22:21:58 MSK 2018 mips GNU/Linux
~ # 
~ # curl http://entware-3x.zyxmon.org/binaries/mipsel/experimental/libsrtp2_2.1.0-1_mipsel-3.4.ipk -O --
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 48337  100 48337    0     0  60195      0 --:--:-- --:--:-- --:--:--   99k
~ # opkg install libsrtp2_2.1.0-1_mipsel-3.4.ipk 
Installing libsrtp2 (2.1.0-1) to root...
Installing libpcap (1.9.0-1) to root...
Downloading http://bin.entware.net/mipselsf-k3.4/libpcap_1.9.0-1_mipsel-3.4.ipk
Configuring libpcap.
Configuring libsrtp2.
~ # 

 

Link to comment
Share on other sites

  • 1 month later...

Здравстввуйте!

Раньше в Asterisk 11.25 был пакет asterisk11-chan-dongle - 1.1-20180619-1

В тестовых сборках его не вижу. Соберите пожалуйста, ОООчень нужно!!!

https://github.com/oleg-krv/asterisk-chan-dongle

 

Кстати, что будет с  Asterisk'ом в официальном репозитории, 11-я версия ушла, а 13-я пока не появилась?

Link to comment
Share on other sites

краткий список:

Скрытый текст
  • asterisk13 13.24.0
  • asterisk15 15.7.0-1
  • asterisk{13,15}-chan-dongle 1.1-20180619
  • asterisk{13,15}-chan-sccp v4.3.1-20181225
  • asterisk{13,15}-codec-g729 1.4.3
  • asterisk{13,15}-codec-opus 20171009
  • baresip 0.6.0
  • gsmlib 1.10-20140304
  • kamailio5 5.1.6
  • libhiredis 0.14.0
  • libosip2 5.0.0
  • libpj 2.8
  • libre 0.6.0
  • librem 0.6.0
  • libsrtp2 2.2.0
  • miax 1.4
  • pcapsipdump 0.2
  • portaudio 190600_20161030
  • restund 0.4.12
  • sipp 3.5.2
  • siproxd 0.8.2
  • yate 6.1.0-1

все пакеты - .../mipsel/telephony

17 часов назад, gonsalez сказал:

Кстати, что будет с  Asterisk'ом в официальном репозитории, 11-я версия ушла, а 13-я пока не появилась?

11 версия давно переехала в entware-oldpackages-ports , где и живёт по сей день...

  • Thanks 1
Link to comment
Share on other sites

Цитата
21 час назад, TheBB сказал:

все пакеты - .../mipsel/telephony

 

 

Попробовал установить asterisk13 из http://bin.entware.net/mipselsf-k3.4/keenetic/test/telephony/  Ругается на зависимость с libedit. Такого пакета в репозитарии не нашел. А так, после ручной компияции libedit, вроде  все заработало.

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...