Jump to content
  • 0

Access + trunk VLAN port CLI Keenetic Ultra v2.06(AAGJ.0)C3


Thump
 Share

Question

Здравствуйте.

Пытаюсь получить router-on-a-stick.

Немного сбивает с толку документация по VLAN: присутствуют даже явные ошибки, ну и добавляется специфика разных версий NDMS вдобавок к аппаратным особенностям каждой из моделей.

interface GigabitEthernet0/0
    switchport mode trunk
    switchport access vlan 1
    switchport trunk vlan 2
    switchport trunk vlan 3

Не становится участником vlan 1.

При одной из попыток, наверное, несколько некорректной командой порт обгадился ARP и уже ни на что не отвечал.

На всякий случай прикладываю конфиг вложением.

running-config-vlan1-access-forum.txt

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0
4 часа назад, Thump сказал:

Здравствуйте.

Пытаюсь получить router-on-a-stick.

Немного сбивает с толку документация по VLAN: присутствуют даже явные ошибки, ну и добавляется специфика разных версий NDMS вдобавок к аппаратным особенностям каждой из моделей.


interface GigabitEthernet0/0
    switchport mode trunk
    switchport access vlan 1
    switchport trunk vlan 2
    switchport trunk vlan 3

Не становится участником vlan 1.

При одной из попыток, наверное, несколько некорректной командой порт обгадился ARP и уже ни на что не отвечал.

На всякий случай прикладываю конфиг вложением.

running-config-vlan1-access-forum.txt 2 \u041a\u0431 · 0 downloads

switchport mode access

надо добавить к конфигу порта

  • Thanks 1
Link to comment
Share on other sites

  • 0

1. Порт должен быть назначен в vlan

2. Создать сам vlan

interface FastEthernet0/0
    rename 0
    switchport mode trunk
    switchport trunk vlan 5
    switchport trunk vlan 6
    up
!
interface FastEthernet0/1
    rename 1
    switchport mode access
    switchport access vlan 5
    up
!
interface FastEthernet0/2
    rename 2
    switchport mode access
    switchport access vlan 6
    up
!
...
interface FastEthernet0/Vlan5
    rename Vlan5_H
    ...
    up
!
interface FastEthernet0/Vlan6
    rename Vlan6_M
    ...
    up
!

И обязательно поднимите прошивку с 2.06 так как

kernel: Linux version 2.6.22.15 (developers@ndmsystems.com) (gcc version 4.3.4 (embtoolkit-00083-g38691cf) ) #1 Sat Apr 2 14:21:28 UTC 2016

А с 2.08 уже

Linux version 3.4.112 (developers@ndmsystems.com) (gcc version 5.4.0 (crosstool-NG crosstool-ng-1.22.0-ndm-10 - NDMS Toolkit 1.0.0) ) #1 SMP Fri Sep 23 21:14:43 MSK 2016

Поддержка - SMP

желательно релиз 2.14/2.15 на ваше усмотрение

Edited by vasek00
Link to comment
Share on other sites

  • 0
6 hours ago, r13 said:

switchport mode access

надо добавить к конфигу порта

Да, именно с этой команды железка начала ARP-шторм. Попробую ещё раз.

Вообще, порт может быть одновременно в режимах access и trunk?

Из документации это неочевидно.

 

6 hours ago, vasek00 said:

1. Порт должен быть назначен в vlan

2. Создать сам vlan

И обязательно поднимите прошивку с 2.06

Порт назначен в vlan, сам vlan создан (см. конфиг).

Вот с прошивкой - почему обязательно? На Ultra официально всё закончилось на 2.06.

Link to comment
Share on other sites

  • 0

Прошивку лучше обновить. У меня на Ultra, порт и в "access" и "trunk" mode. Главное, что бы vid был разный. Все нормально работает, правда есть одна проблема, про неё в разделе 2.15 создана тема. Проявляет она себя только при загрузке устройства.

  • Upvote 1
Link to comment
Share on other sites

  • 0
16 часов назад, Thump сказал:

Вот с прошивкой - почему обязательно? На Ultra официально всё закончилось на 2.06. 

См. выше пост там все четко написано в чем основное отличие.

Link to comment
Share on other sites

  • 0
5 hours ago, vasek00 said:

См. выше пост там все четко написано в чем основное отличие.

Т.е. вообще необязательно и к vlan эти призывы не имеют никакого отношения, правильно?

Link to comment
Share on other sites

  • 0

было

Linux version 2.6.22.15 

будет

Linux version 3.4.112 .... #1 SMP ...

Рекомендую ознакомиться с полным пакетом доработок/изменений/улучшений https://forum.keenetic.net/forum/27-changelog-rus/  так же есть в разделе архив про релизы 2.06-2.08-2.11

Так же для справки

Цитата

сентябрь 2017

Можно сколько угодно вести разговоры про новые ядра, но после того как из ядра, начиная с версии 3.6, выпилили кэш роутинга IPv4, что сильно сказалось на производительности роутеров с не дорогими процессорами, мы точно не планируем делать такой переход в ближайшем будущем.  ..... Все, что нам нужно из новых ядер, мы портируем и переносим в наше 3.4 и пока не видим причин необходимости перехода на другие версии.

.... Сравните наше 3.4 с оригинальным и вы поймете, сколько всего нужно переделать и адаптировать по мимо драйверов, а еще убедится, что на новом ядре все будет стабильно и как нужно работать. Это ответ на "может проще сразу начать с 4", нет не проще, проще как раз перенести из нового в наше, т.к. за все остальное мы уверены, что оно работает с ожидаемым результатом.

февраль 2019 (комментарии по поводу выпиливание кеш роутинга)

.... Для этого написали модуль ядра, который совмещает в себе управление HW и SW офлоадом, и которому больше не требуется этот кэш, т.к. есть полностью своя реализация.

 

4 минуты назад, Thump сказал:

Т.е. вообще необязательно и к vlan эти призывы не имеют никакого отношения, правильно? 

По поводу призывов - ваше право хотите "сидеть" на ПО 2.06 или пользоваться всеми текущими наработками/доделками и т.д. ПО 2.14/2.15 (2018года) ваше право, работа роутера не основано только на работе vlan, она основана на маршрутизации/обработке пакетов на сетевых интерфейсах.

 

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...