Jump to content
  • 0

проблема с резолвером


bzzztomas77
 Share

Question

День добрый,

на ровном месте какая-то беда с резолвером случилась - не работает.

линк живой, по IP все работает (ssh на удаленный хост, http, проч).

но ничего не резолвит, даже с самого giga3:

Quote

(config)> tools ping www.ru

sending ICMP ECHO request to www.ru...

Failed to resolve "www.ru".

локальный процесс запущен, статистику свою обновляет:

# cat /var/ndnproxymain.stat 
# ndnproxy statistics file

Total incoming requests: 121
Proxy requests sent:     242
Cache hits ratio:        0.000 (0)
Memory usage:            49.66K

DNS Servers

                      Ip  R.Sent  A.Rcvd  NX.Rcvd  Med.Resp  Avg.Resp  Rank  
             85.21.192.5     121       0        0       0ms       0ms     1  
           213.234.192.7     121       0        0       0ms       0ms     1  

перезагрузка не помогает.

Link to comment
Share on other sites

29 answers to this question

Recommended Posts

  • 0
4 minutes ago, Илья Картавенко said:

А перенастроить пробовали?

1) настройки никакие не трогал очень давно 2) что именно перенастроить?

 

Link to comment
Share on other sites

  • 0
1 минуту назад, bzzztomas77 сказал:

1) настройки никакие не трогал очень давно 2) что именно перенастроить?

 

Попробуйте с нуля настроить роутер Кстати прошивка какая?

Link to comment
Share on other sites

  • 0
Just now, Илья Картавенко said:

Попробуйте с нуля настроить роутер Кстати прошивка какая?

ох не хотелось бы, полно всего там :(

2.15.C.0.0-0 - до ~10:00 все работало как штык.

Link to comment
Share on other sites

  • 0
1 минуту назад, bzzztomas77 сказал:

ох не хотелось бы, полно всего там :(

2.15.C.0.0-0 - до ~10:00 все работало как штык.

А что произошло перед тем как перестало работать?

Link to comment
Share on other sites

  • 0
1 minute ago, Илья Картавенко said:

А что произошло перед тем как перестало работать?

да собственно ничего. пропал инет, перегрузил роутер, через какое-то время линк появился, а резолвер нет. несколько раз перегружал с тех пор.

 

Link to comment
Share on other sites

  • 0
1 минуту назад, bzzztomas77 сказал:

да собственно ничего. пропал инет, перегрузил роутер, через какое-то время линк появился, а резолвер нет. несколько раз перегружал с тех пор.

 

А инет восстановился?

Link to comment
Share on other sites

  • 0
Just now, Илья Картавенко said:

Так может проблема у провайдера?

я выставляю на ноуте тот же dns, который мне докладывает роутер. и все работает.

Link to comment
Share on other sites

  • 0
2 minutes ago, Mamay said:

В 2.15 немного поломан NAT. Читать тут...

посмотрел, попробовал, не работает.

было бы странно, если бы помогло - я же с роутера тоже не могу отрезолвить. причем провайдер отдает нормальный резолвер и я успешно его использую на ноут.

 

Link to comment
Share on other sites

  • 0

на внешнем порту "работа" идет:

13:14:07.575607 IP (tos 0x0, ttl 64, id 51246, offset 0, flags [DF], proto UDP (17), length 62)
    128.72.176.24.1025 > 213.234.192.7.53: [bad udp cksum 0xc68e -> 0x4108!] 42619+ A? www.linux.org.ru. (34)
13:14:07.575845 IP (tos 0x0, ttl 64, id 51247, offset 0, flags [DF], proto UDP (17), length 62)
    128.72.176.24.1025 > 213.234.192.7.53: [bad udp cksum 0xc68e -> 0x4fb1!] 38839+ AAAA? www.linux.org.ru. (34)
13:14:07.577566 IP (tos 0x88, ttl 53, id 35088, offset 0, flags [none], proto UDP (17), length 78)
    213.234.192.7.53 > 128.72.176.24.1025: [udp sum ok] 42619 q: A? www.linux.org.ru. 1/0/0 www.linux.org.ru. [38m29s] A 178.248.233.6 (50)
13:14:07.577900 IP (tos 0x88, ttl 53, id 35092, offset 0, flags [none], proto UDP (17), length 121)
    213.234.192.7.53 > 128.72.176.24.1025: [udp sum ok] 38839 q: AAAA? www.linux.org.ru. 0/1/0 ns: linux.org.ru. [2m3s] SOA ns1.cloudns.net. support.cloudns.net. 2016022501 7200 1800 1209600 3600 (93)

 

а кинетику что-то все равно не нравится:

~ # ping www.linux.org.ru
ping: bad address 'www.linux.org.ru'

 

Link to comment
Share on other sites

  • 0

> A.Rcvd 0

А кинетик считает что ему в ответ ничего не прилетает.. На грани фантастики я бы предположил, что теряется где-то в фаерволе... iptables -n -L | grep 53  ...? По идее там должно быть только две строчки для dpt:53 с таргетом _NDM_SL_PROTECT

 

Кстати, я сейчас посмотрел у себя - у /tmp/ndnproxymain.stat вроде время изменения обновляется, но количество запросов у меня не меняется при запросе через него. Хотя у меня он сейчас только сокетом работает (opkg dns-override).

Edited by KorDen
Link to comment
Share on other sites

  • 0
2 hours ago, ankar84 said:

А если на странице Интернет фильтр прописать какой-нибудь публичный DNS сервер типа 1.1.1.1 или 8.8.8.8?

да, выставил другой DNS вручную - работает все. при этом пробовал оригинальный DNS с линуксы (которая за кинетиком):
 

$ host www.ru 85.21.192.5
Using domain server:
Name: 85.21.192.5
Address: 85.21.192.5#53
Aliases: 
www.ru has address 217.112.35.75
www.ru mail is handled by 100 mx22.valuehost.ru.

то есть 85.21.192.5 - вполне себе рабочий, но то-ли его ответы не доходят до ndnproxy (но спокойно проходят через кинетик), то-ли в ответа что-то нехорошее и ndnproxy их игнорирует. не понимаю.

 

Link to comment
Share on other sites

  • 0
8 минут назад, bzzztomas77 сказал:

да, выставил другой DNS вручную - работает все. при этом пробовал оригинальный DNS с линуксы (которая за кинетиком):
 


$ host www.ru 85.21.192.5
Using domain server:
Name: 85.21.192.5
Address: 85.21.192.5#53
Aliases: 
www.ru has address 217.112.35.75
www.ru mail is handled by 100 mx22.valuehost.ru.

то есть 85.21.192.5 - вполне себе рабочий, но то-ли его ответы не доходят до ndnproxy (но спокойно проходят через кинетик), то-ли в ответа что-то нехорошее и ndnproxy их игнорирует. не понимаю.

 

А виндовые машины как ведут себя с днс по умолчанию который?

Link to comment
Share on other sites

  • 0
31 minutes ago, Илья Картавенко said:

А виндовые машины как ведут себя с днс по умолчанию который?

через кинетик не работают, если указать тот же сервер (85.21.192.5) в win tcp/ip properties - нормально работает.

Link to comment
Share on other sites

  • 0
1 минуту назад, bzzztomas77 сказал:

через кинетик не работают, если указать тот же сервер (85.21.192.5) в win tcp/ip properties - нормально работает.

Такое ощущение, что проблема впрямь на кинетике или. что еще более вероятнее, у провайдера.

Link to comment
Share on other sites

  • 0
3 minutes ago, Илья Картавенко said:

Другой роутер есть возможность протестировать? Для того что бы локализовать проблему

пока нет такой возможности, поспрашиваю вокруг.

но, конечно, слегка смущает, что с другим DNS кинетик нормально работает. пока склоняюсь к какой-то взаимной неприязни кинетика и билайна. попробую, наверное, взять пакеты и сравнить.

Link to comment
Share on other sites

  • 0
3 минуты назад, bzzztomas77 сказал:

пока нет такой возможности, поспрашиваю вокруг.

но, конечно, слегка смущает, что с другим DNS кинетик нормально работает. пока склоняюсь к какой-то взаимной неприязни кинетика и билайна. попробую, наверное, взять пакеты и сравнить.

Да с билайном должен нормально работать.

Link to comment
Share on other sites

  • 0
7 minutes ago, Илья Картавенко said:

Да с билайном должен нормально работать.

так и работал, годами :) а сегодня утром рраз и все, сломалось..

 

Link to comment
Share on other sites

  • 0
7 минут назад, bzzztomas77 сказал:

так и работал, годами :) а сегодня утром рраз и все, сломалось..

 

Так иожет что то у билайна просто сломалось? Вы к ним обращались с этим вопросом?

Link to comment
Share on other sites

  • 0

интересная формулировка на билайновском форуме:

Quote

обновите прошивку роутера до такой, в которой уже закрыли дыру, через которую хакали DNS-сервер роутера

кто-нибудь в курсе про эту дыру?

Link to comment
Share on other sites

  • 0
5 минут назад, bzzztomas77 сказал:

интересная формулировка на билайновском форуме:

кто-нибудь в курсе про эту дыру?

А дата этого сообщения на том форуме какая?

Link to comment
Share on other sites

  • 0
1 час назад, bzzztomas77 сказал:

кто-нибудь в курсе про эту дыру?

Это другая история, не про кинетики и не про вашу ситуацию... Там через дыру тупо на роутере ставят DNS левые, но у вас-то они правильные.

Вспоминается древний баг времен этак до 2.03 (этак 2013 год), там тогда криво обрабатывались ответы с несколькими айпишниками ЕМНИП. Может тут что-то этакое

Забэкапив все, можно попробовать перейти на прошивку 2.14, пока она еще в delta (components list delta) без сброса конфигурации, поглядеть что будет там.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...