Jump to content
  • 0

Как отключить прослушивание my.keenetic.net:80


Kravenrus
 Share

Question

Хочу использовать 80 порт для иных целей, но на нем висит Nginx сервер с вебмордой, куда тыкаться, чтобы избавиться от этого? Мне достаточно и по IP с определенным портом получать доступ к настройке роутера. Удалил Мастер первоначальной настройки, но похоже это совсем не то.

  • Confused 1
Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0
5 часов назад, Kravenrus сказал:

Хочу использовать 80 порт для иных целей, но на нем висит Nginx сервер с вебмордой, куда тыкаться, чтобы избавиться от этого? Мне достаточно и по IP с определенным портом получать доступ к настройке роутера. Удалил Мастер первоначальной настройки, но похоже это совсем не то.

Эта статья поможет? https://help.keenetic.com/hc/ru/articles/360003847820-Смена-номера-порта-управления-интернет-центром

Link to comment
Share on other sites

  • 0
2 hours ago, KorDen said:

ip http no easy-access
ip http port 1234

 

Ввел первую строку в SSH - порт вроде как освободился, Apache запустился на :80

С DDNS от NOIP с :80 сервер загружается, с использованием KeenDNS с SSL *.keenetic.pro редиректит на :443 в вебморду, это можно тоже как-то отключить?

Link to comment
Share on other sites

  • 0
36 минут назад, Kravenrus сказал:

с использованием KeenDNS с SSL *.keenetic.pro редиректит на :443 в вебморду, это можно тоже как-то отключить?

Кинетиковский HTTPS прибит гвоздями к 443. Не знаю, может "ip http ssl no redirect" поможет, но в общем случае, если хочется свой вебсервер - https-морда и KeenDNS идет под снос

  • Thanks 1
Link to comment
Share on other sites

  • 0
2 hours ago, KorDen said:

Кинетиковский HTTPS прибит гвоздями к 443. Не знаю, может "ip http ssl no redirect" поможет, но в общем случае, если хочется свой вебсервер - https-морда и KeenDNS идет под снос

Ну беда. Получение KeenDNS без SSL решило ситуацию... Но как же радовал тот зеленый значок и адрес *.keenetic.pro :(
Спасибо!

Link to comment
Share on other sites

  • 0

Такс, не знаю че и как я делал что у меня отпустился :443, сбросил роутер, решил по новой все настроить, в итоге 192.168.1.1:443 ссылается на сертификат *.keenetic.io и я не понимаю что куда удалять... Как удалить "https-морду"? Как я понимаю это все связано с Keenetic Cloud (его нельзя удалить)? :(

---

Освободил KeenDNS - порт :443 освободился

Edited by Kravenrus
Link to comment
Share on other sites

  • 0
22 hours ago, Kravenrus said:

Но как же радовал тот зеленый значок и адрес *.keenetic.pro

А какой у вас, если не секрет, идеальный сценарий, если значок https "жалко"? Ваш сервис должен быть доступен по https вместо вебморды? 

Link to comment
Share on other sites

  • 0
38 minutes ago, sbat said:

Ваш сервис должен быть доступен по https вместо вебморды? 

Именно так я и хотел.

---
По итогу... как понимаю, отключил веб-морду на :80

ip http no easy-access

Перед этим сбросил роутер без заданного KeenDNS, чтобы :443 не затрагивался (вроде заметил, что если KeenDNS не освобожден до сброса, то настраивается переадресация на https://*.keenetic.io и :443 черт знает как освободить).

Сервер висит на одном из доменов без SSL: *.mykeenetic.net

Получил и без проблем установил сертификаты для HTTPS (жаль только сегодня изучил вопрос про белые/серые адреса - если повезет провайдер не даст серый адрес и сервер будет доступен)

---

В итоге пришел к выводу, что, как я хотел сделать (с использованием *.keenetic.pro), так не выйдет, или выйдет, но не знай куда чего тыкать, чего отключать...

Edited by Kravenrus
Link to comment
Share on other sites

  • 0

Недавно отключил винчестер с Apache на :80 и :443 портах, в итоге для моего роутера по адресу *.keenetic.io создался сертификат, и снова начал слушаться :443 Nginx'ом. Однако спасибо KorDen, вспомнив о командах выше, подумал и нашел документацию по CLI, почему бы не сделать это ранее... 

ip http ssl enable - Включить SSL на HTTP сервере. По умолчанию, SSL отключен. (как мне кажется включается сам если установлено доменное имя KeenDNS)

Команда с префиксом no отключает SSL.

no ip http ssl enable - И в netstat -lntup не видим строчек о том, что какая-то веб-моська висит на :443

UPD: Apache запустился, сервер работает, доступ есть... С NOIP редирект на KeenDNS, с :80 на :443. 😄 Теперь интересно работает ли такой фокус с доменами имеющими при себе сертификат типа *.keenetic.pro, жаль для проверки надо поменять конфиги Apache и получить сертификат для нового домена (или в данном случае не надо раз он с сертификатом, или вообще ничего работать так не будет). 🥴

Edited by Kravenrus
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...