Jump to content
  • 0

EBMC не может обновить дополнения и медиатеку при подключении через адаптер


Dim McAlastair
 Share

Question

На Cмарт-ТВ BBK с Android 4.4.4 стоит медиапроигрыватель Entertainment Box MC (EBMC) - сильно "порезанный" форк Kodi на нестабильном ядре Kodi 17.1, в основном используемый для просмотра видеофайлов в локальной сети. Смарт-ТВ подключён к локальной сети через Keenetic City (KN-1510) на KeeneticOS версии 3.3.10, работающий в режиме адаптера. Роутером, подключённым к интернету, работает Keenetic Viva (KN-1910) также на версии KeeneticOS 3.3.10.

В EBMC в этом режиме невозможно обновлять данные медиатеки через интернет (выскакивает сообщение "не удалось подключиться к удалённому серверу") и не получается обновить дополнения, вроде дополнений для поиска субтитров на сайте "Add7cted.com": наличие новых версий дополнений в интерфейсе EBMC показывается, но они не скачиваются и появляется сообщение "не удалось обновить дополнение". В остальном медиапроигрыватель работает нормально, например проигрывает из интернета видео, если "скормить" ему файл плейлиста ".m3u8".

Если в Смарт-ТВ отключить подключение по Ethernet и включить подключение по Wi-Fi, подключив телевизор к роутеру напрямую, то EBMC в этом случае нормально обновляет медиатеку и дополнения также обновляются без проблем.

На прошивках версий 2.14 и 2.15 таких проблем ре наблюдалось, то есть на EBMC, подключённом к роутеру через адаптер, обновление медиатеки и обновление дополнений проходило без проблем.

Подскажите, с чем это может быть связано, куда смотреть и можно ли это поправить самостоятельно путём настроек адаптера или налицо какие-то баги в прошивке и надо писать в техподдержку?

Link to comment
Share on other sites

18 answers to this question

Recommended Posts

  • 0

А зачем вы используете второй кинетик в качестве адаптера, если у вас телевизор сам может работать по wifi и в этом все работает нормально? Зачем огород городить?

Link to comment
Share on other sites

  • 0

Изначально у меня не было Смарт-ТВ, а через адаптер к локалке я подключал медиапроигрыватель WDTV Live HD, а потом, когда поменял телевизор -- за компанию подключил через адаптер и его. 

И на старых прошивках проблем с обновлением медиатеки и дополнений в EBMC через адаптер не было. Хотелось бы, чтобы не было и на новых.

Edited by Dim McAlastair
Link to comment
Share on other sites

  • 0
1 минуту назад, Dim McAlastair сказал:

Изначально у меня не было Смарт-ТВ, а через адаптер к локалке я подключал медиапроигрыватель WDTV Live HD, а потом, когда поменял телевизор -- за компанию подключил через адаптер и его.

а у проигрывателя нет wifi?

 

Link to comment
Share on other sites

  • 0

Его можно подключить к Wi-Fi только через USB-"свистки", причём строго определенных моделей и ревизий, которых в продаже давно нет, и кроме того, после пяти-шести лет использования тот "свисток", который у меня был, стал терять связь с сетью в самый неподходящий момент. Поэтому я и решил вместо свистка использовать роутер в режиме адаптера.

Edited by Dim McAlastair
Link to comment
Share on other sites

  • 0
2 минуты назад, Dim McAlastair сказал:

Его можно подключить к Wi-Fi только через USB-"свистки", причём строго определенных моделей и ревизий, которых в продаже давно нет, и кроме того, после пяти-шести лет использования тот "свисток", который у меня был, стал терять связь с сетью в самый неподходящий момент. Поэтому я и решил вместо свистка использовать роутер в режиме адаптера.

Понятно, ну а плеер в такой связке нормально работает?. Причина проблемы может быть где угодно.

Link to comment
Share on other sites

  • 0

Плеер работает нормально. Да и EBMC, вроде бы, работает нормально, только не может обновлять данные в медиатеке и дополнения. Все остальные его функции он, кажется, выполняет нормально.

Link to comment
Share on other sites

  • 0
2 минуты назад, Dim McAlastair сказал:

Плеер работает нормально. Да и EBMC, вроде бы, работает нормально, только не может обновлять данные в медиатеке и дополнения. Все остальные его функции он, кажется, выполняет нормально.

А само приложение пробовали обновить?

Link to comment
Share on other sites

  • 0
38 минут назад, Dim McAlastair сказал:

 и надо писать в техподдержку?

Ну как минимум да. Это неофициальная поддержка и тут можно встрять надолго. У официалов сие происходит намного быстрее...

Link to comment
Share on other sites

  • 0
1 минуту назад, Mamay сказал:

Ну как минимум да. Это неофициальная поддержка и тут можно встрять надолго. У официалов сие происходит намного быстрее...

Мое последнее общение с ними растянулось очень надолго, так как каждого ответа приходилось ждать по нескольку дней, включая и первый ответ

Link to comment
Share on other sites

  • 0
Только что, Илья Картавенко сказал:

Мое последнее общение с ними растянулось очень надолго, так как каждого ответа приходилось ждать по нескольку дней, включая и первый ответ

Это далеко не показатель работы саппорта имярек. Знаю массу случаев абсолютно обратных!

  • Y'r wrong 1
Link to comment
Share on other sites

  • 0
9 минут назад, Mamay сказал:

Это далеко не показатель работы саппорта имярек. Знаю массу случаев абсолютно обратных!

Так вот и именно, раньше все было быстро.

Link to comment
Share on other sites

  • 0
1 hour ago, Илья Картавенко said:

А само приложение пробовали обновить?

Приложение не обновляется. Это вообще форк, созданный, похоже, какими-то производителями тв-боксов на Android 4.4 для своих коробочек. Могу, конечно, попробовать его переустановить, или вообще заменить официальным Kodi (правда, на Android 4.4 установится только 16 версия, которая Jarvis). Но, что-то кажется мне, что не в приложении тут дело, ибо оно нормально обновляло медиатеку и дополнения, когда на адаптере стояла прошивка версии 2.15 и даже 2.14

Link to comment
Share on other sites

  • 0
2 hours ago, Mamay said:

Ну как минимум да. Это неофициальная поддержка и тут можно встрять надолго. У официалов сие происходит намного быстрее...

Написал, посмотрю, что они ответят.

Кстати, а не может моя проблема быть вызванной вот этим:

https://forum.keenetic.net/topic/8228-дублирование-устройств-в-списке-зарегистрированных-устройств-после-обновления-на-версию-3310/ ?

Link to comment
Share on other sites

  • 0
1 минуту назад, Dim McAlastair сказал:

Написал, посмотрю, что они ответят.

Кстати, а не может моя проблема быть вызванной вот этим:

https://forum.keenetic.net/topic/8228-дублирование-устройств-в-списке-зарегистрированных-устройств-после-обновления-на-версию-3310/ ?

А что у вас устройства дублируются в списке зарегистрированных?

Link to comment
Share on other sites

  • 0

Да, как раз адаптер и подключённый к нему телевизор после обновления прошивки до 3.3.10, при включении в сеть начинают дублироваться. С одинаковыми IP-адресами и MAC-адресами.

Link to comment
Share on other sites

  • 0
2 минуты назад, Dim McAlastair сказал:

Да, как раз адаптер и подключённый к нему телевизор после обновления прошивки до 3.3.10, при включении в сеть начинают дублироваться. С одинаковыми IP-адресами и MAC-адресами.

Тогда, да, может быть.

 

Link to comment
Share on other sites

  • 0

Странно, но траблы с обновлениями медиатеки и дополнений в EBMC на телевизоре, подключённом к интернету через адаптер, исчезли сами собой, когда я стал записывать файлы диагностики для техподддержки😕

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...