Jump to content
  • 0

Встроенный nginx висит на 80 порту


AndreySH
 Share

Question

Keenetic EXTRA  II  

Добрый день.  Ставлю через ENTWARE    nginx,  на 82 порту отвечает, а на 80 не запускается,  пишет занят.   вот вывод команды

  netstat -tpln | grep nginx
tcp        0      0 192.168.14.1:777        0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 10.1.30.1:777           0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 127.0.0.1:777           0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 78.47.125.180:777       0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 192.168.7.1:777         0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 127.0.0.1:79            0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 78.47.125.180:80        0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 78.47.125.180:8081      0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 0.0.0.0:82              0.0.0.0:*               LISTEN      3213/nginx: master
tcp        0      0 78.47.125.180:443       0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 192.168.7.1:443         0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 192.168.14.1:443        0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 10.1.30.1:443           0.0.0.0:*               LISTEN      472/nginx
tcp        0      0 127.0.0.1:443           0.0.0.0:*               LISTEN      472/nginx

 

как я понимаю, встроенный конфиг не поменять, что тогда делать.  Админка на 777 порту

 

Спасибо

 

 

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

80-ый порт закрыт. Открыт только в локальной сети. Как открыть? Только, если надо посылать какие-то команды, то подробно и без сленга скажите.... где писать? как вызвать окно команд? какой утилитой и пр.

P/S  Web-конфигуратор снаружи вообще не нужен. Я даже не представляю кому его надо делать снаружи??? Хакерам? Злоумышленникам? Зачем вообще постоянно заниматься мозахическими настройками??? Должно быть как у меня было с Dlink-ом — 1 раз настроил и 10 лет не заглядывал, т.к. всё работало, как часы и 80-й порт был открыт......

  • Confused 1
Link to comment
Share on other sites

  • 0

Вопрос разработчикам... Почему бы нормально не сделать. Если уж вы хотите управлять роутером снаружи, то не занимать 80-й порт..... Или почему бы корректно не сделать смену порта управления.... чтобы вместе со сменой порта 80, скажем на 777, порт 80 ОСВОБОЖДАЛСЯ и уходил на 777 ТОЖЕ.!!!!!!!!!!!!!!!!!!!!!!!!!!!

Link to comment
Share on other sites

  • 0

Продолжаем бубен......

Ввел эту команду "no ip http easy-access" в строке telnet Windows10 после подключения по локальному адресу к роутеру. Никакого сообщения после ввода команды не было. Перегрузил роутер. Порт 80 занят. Что не так?

Link to comment
Share on other sites

  • 0
3 минуты назад, Аркадий сказал:

Ввел эту команду "no ip http easy-access" в строке telnet Windows10 после подключения по локальному адресу к роутеру. Никакого сообщения после ввода команды не было. Перегрузил роутер. Порт 80 занят. Что не так?

После ввода команды no ip http easy-access надо всё сохранить командой system configuration save

Link to comment
Share on other sites

  • 0
Только что, Аркадий сказал:

Ввел дополнительно: system configuration save

затем: exit

Перезагрузил роутер....

Опять не помогло.... порт 80 занят.

Ничего не понял. Последовательность команд должна быть такой: сначала no ip http easy-access потом system configuration save и exit

Link to comment
Share on other sites

  • 0

Да.... всё верно. Всего 3 команды и перезагрузка роутера. Никакого толку. Такую вещь надо делать как положено в настройках, а не набирать команды. Порт должен освобождаться вслед за переносом порта управления роутером. Например, поменял пользователь 80 на 777. И все должно перестроится без всяких команд..... Такая ситуация говорит только о недоработанном ПО. Написал в поддержку..... молчат.

Link to comment
Share on other sites

  • 0

Роутер Giga 1010 не понимает комманду

no ip http easy-access

Лог из web cli

Цитата
ERROR: {
    "parse": {
        "prompt": "(config)",
        "status": [
            {
                "status": "error",
                "code": "7405600",
                "ident": "Command::Base",
                "source": "",
                "critical": "no",
                "message": "no such command: easy-access."
            }
        ]
    },
    "ndmErrors": {
        "parse.status.0": {
            "message": "no such command: easy-access.",
            "code": "7405600"
        }
    }
}

 

Link to comment
Share on other sites

  • 0

Начиная с верии 3.6 она не нужна, поскольку нет поддержки старого мобильного приложения. При смене порта 80 ничего держать не будет.

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...