Jump to content
  • 0

Extender Mode: IPv6: Router Advertisement still broadcasted.


rAcKShen
 Share

Question

I am in the operating mode Extender. I have installed the component IPv6. While debugging something else in Wireshark, I noticed, that my Keenetic is still sending IPv6 Router Advertisements (RAs; ICMPv6 134). Nothing much included, except the default route at medium preference. Anyway, confusing because in that mode my Keenetic is (should be) no router anymore. Is that intended?

Sorry, have not checked 3.7.4 whether that is a 3.8 only thing.

  • Need more info 2
Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

What mean the two votes ‘need more info’ exactly? First of all: More info from me or someone from Keenetic?

Steps to Reproduce:

  1. Web interface → (Management) System → Change operating mode → Extender
  2. Web interface → (Management) System → Component options → IPv6 → Install

Then, on a computer in my home network, I open Wireshark and filter for icmpv6.type == 134. After several minutes, I see IPv6 RA coming from the Keenetic. Nothing inside (no IPv6 Prefix and not DNS) but still medium default route. This is confusing because I would have expected no RA from a non-router.

Link to comment
Share on other sites

  • 0
On 4/23/2022 at 8:56 PM, rAcKShen said:

What mean the two votes ‘need more info’ exactly?

This means that you need to attach a self-test file. It is recommended to do this in a hidden message.

Link to comment
Share on other sites

  • 0

OK, attached in hidden mode. Are you not able to reproduce this issue with the steps above? Interesting. By the way, when I go for the file ‘/tmp/run/radvd.conf’, I see

interface br0 {
        AdvSendAdvert on;
        AdvOtherConfigFlag on;
        AdvManagedFlag off;
        AdvDefaultLifetime 0;
};

which matches my Router Advertisements, because the Flag Other is set indeed. However, I found no way to control that file, yet. After a restart, it is overwritten. And there seem to be no command on the CLI controlling this. The closest would be ‘no ipv6 subnet mode’. However, that did not work. Is there a trick to change/overwrite that?

Something like a ‘ipv6 subnet mode client’ would be the correct approach in future, I think. Especially, because currently, I do not see IPv6 connectivity in Extender mode at all. However, that is another topic.

Link to comment
Share on other sites

  • 0

The following settings are redundant for this mode:

ipv6 subnet Default
    bind Home
    number 0
    mode slaac
!

You need to disable ipv6 subnet to get rid of RA.

no ipv6 subnet Default

 

BTW, how did you get such a configuration?

  • Thanks 1
Link to comment
Share on other sites

  • 0

I get that subnet via:

  1. reset the system components to Minimal
  2. reset all settings
  3. exit wizard
  4. change Mode to Extender
  5. install the system component IPv6

all via the Web interface; 3.8 Beta 1. Re-tried just minutes ago.

  • Thanks 1
Link to comment
Share on other sites

  • 0

@vst were you able to reproduce the issue via my steps?

I re-tried after applying your CLI command (which did the job, thanks, by the way): After that CLI command, when I go through my steps again, that subnet re-appears again. Consequently, I do not think, it is any kind of left-over. If you were able to reproduce the issue, do you create the bug report internally or shall I via E-mail support?

Link to comment
Share on other sites

  • 0
4 hours ago, rAcKShen said:

Were you able to reproduce the issue via my steps?

Yes, I was. Ticket SYS-549 was created to resolve this issue. Thanks for the report!

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...