Jump to content
  • 0

А что случилось с entware после обновления Viva до 3.9 preview?


Santus
 Share

Question

Товарищи?

opkg list-upgradable
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency libndm for ndmq
 * pkg_hash_fetch_best_installation_candidate: Packages for ndmq found, but incompatible with the architectures configured
 

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0
7 часов назад, Santus сказал:

Товарищи?

opkg list-upgradable
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency libndm for ndmq
 * pkg_hash_fetch_best_installation_candidate: Packages for ndmq found, but incompatible with the architectures configured
 

390 которая последняя

Скрытый текст
~ # opkg update
Downloading http://bin.entware.net/mipselsf-k3.4/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/entware
Downloading http://bin.entware.net/mipselsf-k3.4/keenetic/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/keendev
~ # opkg upgrade
Upgrading dstat on root from 0.7.4-1a to 0.7.4-2...
Downloading http://bin.entware.net/mipselsf-k3.4/dstat_0.7.4-2_mipsel-3.4.ipk
Installing python3-base (3.10.5-1) to root...
Downloading http://bin.entware.net/mipselsf-k3.4/python3-base_3.10.5-1_mipsel-3.4.ipk
Upgrading rtorrent-easy-install on root from 0.2-5 to 0.2-6...
Downloading http://bin.entware.net/mipselsf-k3.4/rtorrent-easy-install_0.2-6_mipsel-3.4.ipk
Installing php8 (8.1.7-2) to root...
Collected errors:
 * check_data_file_clashes: Package python3-base wants to install file /opt/bin/python
        But that file is already provided by package  * python-base
 * check_conflicts_for: The following packages conflict with php8:
 * check_conflicts_for:         php7 * 
~ # opkg list-upgradable
dstat - 0.7.4-1a - 0.7.4-2
rtorrent-easy-install - 0.2-5 - 0.2-6
~ # 

 

 

Link to comment
Share on other sites

  • 0
3 часа назад, Santus сказал:

opkg не работает, подскажете как пофиксить?

не верю, что opkg не работает. удалите пакеты  libndm и ndmq с помощью opkg или ручками из файла /opt/lib/opkg/status

  • Thanks 1
Link to comment
Share on other sites

  • 0
1 час назад, zyxmon сказал:

не верю, что opkg не работает. удалите пакеты  libndm и ndmq с помощью opkg или ручками из файла /opt/lib/opkg/status

Спасибо, удаление второго помогло!

А чисто теоретически, откуда он там мог взяться? Вроде ну никак не более года назад на чистую Энтварь ставил. Тогда, когда появился лёгкий способ накатить её во внутреннюю память. Да и вылезла проблема только сегодня после обновления до 3.9, ещё на бете 3.9.1 всё работало, всегда на preview сидел...

Edited by Santus
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...