Jump to content
  • 0

3.9.0 Site-to-Site IPSec VPN , не подключается.


hard_alex@mail.ru
 Share

Question

Добрый день!
 

  • Модель Keenetic Extra II

Понимаю что модель не самая новая, но таки прошивка 3.9.0 на нее ставиться.
Используется для объединения сетей нескольких офисов между собой.
Оборудование Giga (KN-1010) RU, KN-3810 Hopper, Keenetic Extra II

После обновления на новую прошивку Site-to-Site IPSec VPN не запускается (В Web интерфейсе Интернет - Другие подключения - IPsec-подключения).
Получаю следующую ошибку:

[E] Dec  7 20:22:45 ndm: IpSec::Configurator: "AstartaMSK": remote peer rejects to authenticate (possibly wrong ID).

SelfTest Снял, сюда прикреплять не очень охота, так как с боевой системы. Вышлю в ЛС.

При этом на версии 3.8.5 все работает нормально в плане соединения, есть проблемы что роутер через пару дней уходит в 100% загрузку процессора и VPN отваливается и соединяется снова только после ручного переключения переключателя ON_OFF по конкретному VPN.

Сейчас откатился на 3.5.10 , т.к. стабильность в данный момент важнее новых и тоже нужных функций 3.8.

Вообще смотрю стэк IPsec 3.9 капризничает.

Прошу помощи, Хоть он и старичек, но возложенные функции выполняет.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0
3 часа назад, hellonow сказал:

@hard_alex@mail.ru к выпуску готовится новая версия 3.9 с дополнительными исправлениями для IPSec. Работу проверьте с ней.

Спасибо. Как будет обновлюсь, напишу сюда.

 

Link to comment
Share on other sites

  • 0
7 часов назад, hellonow сказал:

@hard_alex@mail.ru вышла 3.09.C.1.0-0, проверьте работу IPSec

 

Рассказываю.

После обновления система запустилась, и ничего не произошло.
Соединение не установилось, в логах [I] Dec  9 19:20:46 ipsec: 08[IKE] no IKE config found for 217.148.209.202...93.100.79.84, sending NO_PROPOSAL_CHOSEN
Ок. Зашел в сервер L2TP Выбрал режим Для устаревших клиентов(Понимаю что никак не связано, но всеже). Перетнул переключатель Site-to-Site , и запустилось.

Ок. Перезагрузил.
И снова -
[I] Dec  9 19:20:46 ipsec: 08[IKE] no IKE config found for 217.148.209.202...93.100.79.84, sending NO_PROPOSAL_CHOSEN
Skip
[C] Dec  9 19:21:07 ndm: IpSec::Vici::Socket: system failed [0xcffd0482], unload: connection 'AstartaMSK' not found.
[C] Dec  9 19:21:07 ndm: IpSec::Vici::Config: "AstartaMSK": system failed [0xcffd0176], unable to unload conn: input/output error (5).
[I] Dec  9 19:21:07 ndm: IpSec::Configurator: "AstartaMSK": crypto map shutdown started.

Обратно, переключил в L2TP  по умолчанию. Зашел в настройки Site-to-Site , поменял рандомную настройку, записал, снова зашел вернул обратно Записал.
(Как бы попросил переписать настройки через веб интерфейс)
Перезагрузился.

И пока все ОК!

Буду тестировать.
Спасибо.
 

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...