Jump to content
  • 0

Как настроить IPv6 и DHPCv6 в Keenetic Ultra 2?


doc_bravn
 Share

Question

Использую роутер Keenetic Ultra 2. Прошивка 2.07 релиз. Подключение к провайдеру по IPoE, IP от провайдера просто получаю по dhcp во vlan. IPv4 и IPv6 адреса от провайдера приходят, я их вижу в закладке ipv6. Но вот ipv6 адреса не выдаются роутером на локальные компьютеры. Компы получают только ipv6 dns адреса от провайдера и локальный ipv6 адрес типа fe80. 

Настраивал по инструкции с https://zyxel.ru/kb/3401/

Единственное чего не делал из этой инструкции: не вводил команду для включения ipv6cp, т.к. у меня не туннельный интерфейс. После того как настройки сделал сохранил конфиг и перезагрузил роутер. На вкладке ipv6 в вебконфигураторе в разделе "Префиксы" пусто и в разделе "Адреса" отображается только один ipv6 адрес на интерфейсе к которому подключен кабель от провайдера. Адресов для домашней сети нет. В разделе "Маршруты" есть два маршрута: один к ::0, а второй к 2a00:1370:8032:8420::/64 подсети. 

Уточню: интернет приходит не в синий порт 0, а в желтый порт 1 и используется не соединение ISP, а создаю еще одно соединение GigabitEthernet0/Vlan3. Соответственно когда настраивал указывал интерфейс не ISP, а GigabitEthernet0/Vlan3.

Запросил у техподдержки провайдера информацию по моей сессии. Там мне сообщили, что в текущей сессии выделена подсеть 2a00:1370:8032:8420::/64. Т.е. получается адреса мне выделены, но роутер их не использует.

Как правильно настроить роутер для использования ipv6? 

Может попробовать в настройках ipv6 subnet выбрать не mode slaac, mode dhcp? Если включить DHCPv6 будет ли роутер выдавать ip на компьютеры из полученной подсети?

 

Edited by doc_bravn
Link to comment
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Жадный пров, по стандарту вроде как должны давать /56

А роутер уже из выделенного диапазона выделяет /64 для сегмента Home

Для IPoe подключения все работает из коробки, ничего не настраивал,(Провайдер Onlime) 

Клиенты нормально получают IPv6 адреса.

PS Попробуйте поменять mode slaac на  mode dhcp может поможет, потом расскажете.

Edited by r13
Link to comment
Share on other sites

  • 0

Тут вот провайдер решил выдавать /64. Пусть даже и /64 для 5-ти моих локальных устройств этого более чем достаточно. Главное, что не работает. Т.е. вроде все приходит как нужно, но на локальные компьютеры адреса не приходят. 

Онлайм у меня тоже есть. И у него в моем районе не работает ipv6 вообще, не приходит никакой адрес, только ipv4. А вот МГТС выдает адреса. Но вот толи провайдер как-то странно выдает, толи я что-то не то настроил.

Link to comment
Share on other sites

  • 0

В течении 2-х часов буду дома и тогда смогу взять селфтест с роутера и прислать. Только один вопрос: для того чтобы обновить селфтест нужно что-то в роутере включать, запускать? Если нужно, то где. Я роутерами зуксель не так давно пользоваться начал и не все еще в них знаю, к сожалению. :-(

 

Link to comment
Share on other sites

  • 0

@doc_bravn Настроено верно, но ipv6 префикс не был получен от провайдера. Сеть

Вы случайно не за gpon терминалом сидите? Вот тема, в которой обсуждалась похожая ситуация:

GPON терминал переведён в режим бриджа? Поддерживает ли ваш провайдер ipv6 prefix delegation?

Ну и нужно разобраться с дичью:

Цитата

Jan 25 08:08:44 ndm: Network::Interface::Base: "GigabitEthernet0/Vlan3": network MTU is 9216.

Судя по всему в icmpv6 RA рассылается такая опция. Если снимите дамп wan трафика, то будет очень полезно.(запустить мониторинг, воткнуть кабель, дождаться поднятия)

Link to comment
Share on other sites

  • 0
20 часов назад, vst сказал:

@doc_bravn Настроено верно, но ipv6 префикс не был получен от провайдера. Сеть

Вы случайно не за gpon терминалом сидите? 

GPON терминал переведён в режим бриджа? Поддерживает ли ваш провайдер ipv6 prefix delegation?

Ну и нужно разобраться с дичью:

Судя по всему в icmpv6 RA рассылается такая опция. Если снимите дамп wan трафика, то будет очень полезно.(запустить мониторинг, воткнуть кабель, дождаться поднятия)

Да, я сижу за GPON терминалом Huawei HG8245T. GPON терминал переведен в режим бриджа. В терминале отключен dhcp сервер, убраны настройки для телефонии. Работает как простой преобразователь из оптики в эзернет. IP получает непосредственно зуксель, на самом терминале никаких соединений wan не создано и не поднимается. А вот поддерживает ли МГТС  ipv6 prefix delegation или нет не ясно. Я уже и сам прихожу к выводу, что не делегируется префикс. 

Попробую снять дамп трафика.

P.S. Я попытался сегодня руками прописать префикс. Прописался. IPv6 на комп сразу же пришел. Но ipv6 трафик не маршрутизируется. В интернете на test-ipv6.com он не определяется. Снова поставил в auto. Префикс исчез, но и с компьютера адрес тут же исчез. Видимо от провайдера не приходит нужное.

P.P.S. Если попробовать ввести команду  ipv6 pass through GigabitEthernet0/Vlan3 Home , то это может помочь? Если я обычным компьютером напрямую без роутера подключаюсь к хуавею(бриджу), то мой компьютер получает и ipv4 адрес и ipv6 адрес и при этом ipv6 начинает работать. Определяется на сайте test-ipv6.com и показывает, что все нормально. 

Edited by doc_bravn
Link to comment
Share on other sites

  • 0

Нельзя просто так взять и прописать префикс - выщестоящий роутер не будет про него знать и не будет маршрутизировать.

Без префикса роутер не знает какие ему адреса раздавать клиентам, поэтому когда вы прописали статический префикс - клиенты получили адреса.

Если ваш провайдер не поддерживает делегирование префикса, то поможет ipv6 pass through.

Link to comment
Share on other sites

  • 0
5 минут назад, vst сказал:

Нельзя просто так взять и прописать префикс - выщестоящий роутер не будет про него знать и не будет маршрутизировать.

Без префикса роутер не знает какие ему адреса раздавать клиентам, поэтому когда вы прописали статический префикс - клиенты получили адреса.

Если ваш провайдер не поддерживает делегирование префикса, то поможет ipv6 pass through.

Очень похоже, что провайдер не поддерживает делегирование префикса. Или он его сломал или недонастроил и делегирование не работает. Попробую ipv6 pass through. Как ipv6 pass through выключить можно, если не поможет или станет хуже?

Link to comment
Share on other sites

  • 0

Попробовал включить ipv6 pass through. Совершенно ничего не изменилось. Как не приходил на локальный комп ipv6 адрес так и не приходит. Адреса ipv6 dns приходят, а вот адрес нет. Если уже даже ipv6 pass through не помогает, то получается у провайдера вообще ipv6 не работает? И тот адрес который роутер получает бесполезен?

Link to comment
Share on other sites

  • 0
В 25.01.2017 в 10:55, r13 сказал:

Для IPoe подключения все работает из коробки, ничего не настраивал,(Провайдер Onlime) 

Если кто-нибудь будет (как и я) искать про настройку IPv6 у onlime, то не всегда все так просто. Из коробки отобразились только Ipv6 DNS серверы. Настройка по статье - https://help.keenetic.net/hc/ru/articles/213968489-Настройка-подключения-в-Интернет-по-протоколу-IPv6 сразу не помогла. После

system set net.ipv6.conf.all.accept_ra 1

и перезагрузки ipv6 "зажужжал". До этого настаивал Ipv6 на прошивке Падавана. Насколько помню и там шаманил (чуток) с RA (router advertisement). У "лимона" в разных сегментах может быть по разному Ipv6 настроен, но дает честную /56 подсеть.

Ipv6.png

Link to comment
Share on other sites

  • 0

У меня онлайм с дефолтными настройками работает. 

Но у них до сих пор ipv6 в тестовой эксплуатации. Так что видимо действительно где как...

В вашем случае видимо dhcpv6 в сети отсутствует.

Link to comment
Share on other sites

  • 0
1 минуту назад, r13 сказал:

В вашем случае видимо dhcpv6 в сети отсутствует.

Я знаю, что тестовая эксплуатация (уже пару лет или больше). На прошивке Padavan по умолчанию ipv6 так же не работал.

PS К сожалению я не спец в ipv6.....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...