Jump to content
  • 0

Keenetic Ultra (KN-1810). Проблемы с VLAN, порты работают на 100Mb.


b8ba555b
 Share

Question

Keentic Ultra (KN-1810) работает в режиме точки доступа. На другом конце провода Mikrotik CRS125-24G-1S-2HnD-IN. 

Снифф на микротике показывает, что идет только 200 тегированный VLAN.

GigabitEthernet0/0 работает только на 100Mbps и только с autoneg. Попытка выставить значения в 1000Mbps full-duplex auto приводит к падению линка.

Ниже приведен кусок diff из running-config между Keenetic Ultra (subj, слева) и Keenetic Extra II. 

interface GigabitEthernet0/0                                  | interface FastEthernet0/0
    rename 1                                                  |     rename 0
    switchport mode access                                          switchport mode access
    switchport mode trunk                                           switchport mode trunk
    switchport access vlan 1                                        switchport access vlan 1
    switchport trunk vlan 100                                       switchport trunk vlan 100
    switchport trunk vlan 200                                       switchport trunk vlan 200
    up                                                              up
!

 

Опробовано на прошивках 2.15.C.0.0-0 и 2.14.C.0.0-4.

На Keenetic Extra II с аналогичным конфигом все работает без проблем.

Почему-то на WAN порт нельзя повесить VLAN (опция switchport недоступна). 

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0
19 минут назад, b8ba555b сказал:

Почему-то на WAN порт нельзя повесить VLAN (опция switchport недоступна). 

WAN-порт в ультре (точнее в кинетиках на 7621) на отдельной сетевушке (GE1), там надо только создавать интерфейс типа interface GigabitEthernet1/Vlan10 (а access это собственно GigabitEthernet1, по аналогии с вланами в Linux) и потом его бриджевать с вланом на GE0 (который свич), если надо чтобы он ходил между WAN-LAN портами

19 минут назад, b8ba555b сказал:

GigabitEthernet0/0 работает только на 100Mbps и только с autoneg. Попытка выставить значения в 1000Mbps full-duplex auto приводит к падению линка.

Это скорее что-то аппаратное типа паршивого кабеля/коннектора/сдохшего порта

Edited by KorDen
Link to comment
Share on other sites

  • 0
25 minutes ago, KorDen said:

Это скорее что-то аппаратное типа паршивого кабеля/коннектора/сдохшего порта

Ну, конечно! .:facepalm:. Гигабит поднялся.

С VLAN по-прежнему не понятно что происходит. :(

Link to comment
Share on other sites

  • 0
1 час назад, b8ba555b сказал:

Почему-то на WAN порт нельзя повесить VLAN (опция switchport недоступна).

С VLAN по-прежнему не понятно что происходит. :(

На ExtraII (7628) имеете 6 портовый switch, физ.сетевой интерфейс eth2 на котором один порт на CPU, другой порт на WAN,  4 порта на LAN (по конфигу "interface FastEthernet0"). Для разделения WAN с LAN на общей шине используются в данном случае VLAN :

- физ.сетевой интерфейс eth2 по конфигу он "interface FastEthernet0"

- WAN порт по конфигу порт "interface FastEthernet0/0" и привязан к "switchport access vlan 2"

-LAN порты по конфигу "interface FastEthernet0/1 .... interface FastEthernet0/4" и все они привязаны к "switchport access vlan 1"

-сами VLAN по конфигу "interface FastEthernet0/Vlan2" физически он сетевой интерфейс "eth2.2" и "interface FastEthernet0/Vlan1" физически он сетевой интерфейс "eth2.1

 LAN1-LAN4
 |
 Vlan1
 |
 | eth2 
 + CPU 
 | eth2
 |
 Vlan2
 |
 WAN

[I] Jan  1 03:00:17 ndm: kernel: rtsoc_eth: MT7628 SoC, TX/RX buffers: 512/512, poll budget 32
[I] Jan  1 03:00:17 ndm: kernel: rtsoc_eth: e4:18:xx:xx:xx:xx address assigned to eth2
[I] Jan  1 03:00:17 ndm: kernel: rtsoc_eth: MT7628 switch initialized

eth2      Link encap:Ethernet  HWaddr E4:18:хх:хх:хх:2C  
eth2.1    Link encap:Ethernet  HWaddr E4:18:хх:хх:хх:2C  
eth2.2    Link encap:Ethernet  HWaddr E4:18:хх:хх:хх:2D  

 

На KN1010 (7621) в данном конкретном случае имеет настройку портов switch по другому, два порта CPU подключены к switch :

- WAN порт соединен с одним портом CPU по конфигу это "interface GigabitEthernet1/0" сидит на шине eth3 по конфигу она "interface GigabitEthernet1"

- LAN порты соединены с другим портом CPU по конфигу это "interface GigabitEthernet0/1...interface GigabitEthernet0/4" и все они привязаны "switchport access vlan 1" и сидят на физ.шине eth2 по конфигу она "interface GigabitEthernet0"

-сам VLAN1 по конфигу "interface GigabitEthernet0/Vlan1" физически это сетевой интерфейс eth2.1

 LAN1-LAN4
 |
 Vlan1
 |
 -+ eth2
  | 
CPU
  |
 -+ eth3
 |
 WAN

[I] Jan  1 03:00:11 ndm: kernel: mt7621_eth: eth2 created for GMAC1 (50:ff:20:xx:xx:xx address, 4 EPHY ports)
[I] Jan  1 03:00:11 ndm: kernel: mt7621_eth: eth3 created for GMAC2 (50:ff:20:xx:xx:xx address, 1 EPHY port)

eth2      Link encap:Ethernet  HWaddr 50:FF:20:хх:хх:94  
eth2.1    Link encap:Ethernet  HWaddr 50:FF:20:хх:хх:94  
eth3      Link encap:Ethernet  HWaddr 50:FF:20:хх:хх:95  

eth2 и eth3 - развязаны между собой, как и было сказано выше только с помощью vlan на них и потом в мост.

 

Вы можете проверить все сами -> сделав на KN1810 копию портов ExtraII подняв WAN порт на одном из LAN (interface GigabitEthernet0) с помощью WEB и на нем сделать данную настройку, т.е.

LAN1-LAN3
 |
 Vlan1
 |
 -+ eth2
  | 
CPU
  |
 -+ eth2
 |
 WAN(LAN4)

 

Edited by vasek00
Link to comment
Share on other sites

  • 0

Вот вам кусок конфига, где тегированные вланы идут между отдельным WAN и LAN портом:

Созданы вланы 100, 101, 102.

!
interface GigabitEthernet0
    up
!
interface GigabitEthernet0/0
    rename 1
    switchport mode access
    switchport access vlan 100
    up
!
interface GigabitEthernet0/1
    rename 2
    switchport mode access
    switchport access vlan 100
    up
!
interface GigabitEthernet0/2
    rename 3
    switchport mode access
    switchport access vlan 102
    up
!
interface GigabitEthernet0/3
    rename 4
    switchport mode trunk
    switchport trunk vlan 100
    switchport trunk vlan 102
    switchport trunk vlan 101
    up
!
interface GigabitEthernet0/Vlan100
    security-level public
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface GigabitEthernet0/Vlan101
    security-level public
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface GigabitEthernet0/Vlan102
    security-level public
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface GigabitEthernet1
    security-level private
    up
!
interface GigabitEthernet1/0
    rename 0
    up
!
interface GigabitEthernet1/Vlan100
    security-level public
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface GigabitEthernet1/Vlan101
    rename 101
    description 101
    security-level private
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface GigabitEthernet1/Vlan102
    security-level public
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!

И 3 бриджа

interface Bridge0
    rename Home
    description "Home network"
    inherit GigabitEthernet1/Vlan100
    include GigabitEthernet0/Vlan100
    include AccessPoint
    include AccessPoint_5G
    mac access-list type none
    security-level private
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface Bridge1
    rename Guest
    description "Guest network"
	inherit GigabitEthernet1/Vlan102
    include GigabitEthernet0/Vlan102
    include GuestWiFi
    mac access-list type none
    security-level protected
    ip dhcp client dns-routes
    ip dhcp client name-servers
    up
!
interface Bridge2
    description Vlan101-manage
    inherit 101
    include GigabitEthernet0/Vlan101
    mac address хх:хх:хх:хх:хх:хх
    mac access-list type none
    security-level private
    ip address 192.168.1.1 255.255.255.0
    ip dhcp client dns-routes
    ip dhcp client name-servers
    ip global 700
    up
!

 

Link to comment
Share on other sites

  • 0

Коллеги, всем большое спасибо за оперативные ответы и советы по конфигурации! Взял на заметку некоторые особенности конфигурации кинетиков. Проблема оказалась в микротике: начал чудить после очередного обновления.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...