Jump to content
  • 0

VPN-сервер L2TP/IPsec


ALALNIK
 Share

Question

Задача установить VPN-соединение из-под Windows 10 используя встроенный клиент к роутеру Keenetic Giga.

Настроены и работают 2-IPsec туннеля с фазами 1 и 2 до двух других роутеров, а так же реализовано подключение с мобильного телефона на Android по IPsec Xauth PSK в пулл адресов из Keenetic Giga. И все прекрасно работает. Keenetic Giga имеет белый IP-адрес.

Не удается настроить по этой инструкции

https://help.keenetic.com/hc/ru/articles/360000581969

вот что пишет роутер и винда

 

 

image.thumb.png.23d413a9c8521c5fb14acbfa91b9c55e.png

 

image.png.01128f91895c4ab7d011bf190d64fb0a.png

Помогите разобраться, у меня подозрение что соединению как-то препятствует провайдерский NAT. Потому как это IP 10.125.32.191 это то, что пишется на роутере в соединении. Но хожу я на другие устройства под роутерои из вне на 85.202.ХХХ.ХХ

VPN.thumb.JPG.375e8e2f801be6b6db09807c452d19a8.JPG

 

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

L2tp/ipsec и ipsec xauth не совместимы между собой, и вместе не заведутся. Выберите что-то одно. 

  • Y'r wrong 1
Link to comment
Share on other sites

  • 0
19 минут назад, ALALNIK сказал:

Ну даже если так. Я выключаю компонент VPN-сервер IPsec (Virtual IP). VPN-сервер L2TP/IPsec из под винды не соединяется.

Ещё на текущей 3.3 есть проблемы с crypto engine,  надо в программный режим переключить. 

ЗЫ по поводу не совместимости кажись обманул, так было раньше, сейчас подкрутили. 

Edited by r13
Link to comment
Share on other sites

  • 0

Как я понимаю это NAT провайдера виноват. Сейчас пробовали у коллеги на другом компе, у него тож белый IP, но он у него не натируется. Что в соединении пишет,  на то и коннектится. Так вот у него работает VPN-сервер L2TP/IPsec из под виндозного клиента.

Link to comment
Share on other sites

  • 0
2 минуты назад, ALALNIK сказал:

Как я понимаю это NAT провайдера виноват. Сейчас пробовали у коллеги на другом компе, у него тож белый IP, но он у него не натируется. Что в соединении пишет,  на то и коннектится. Так вот у него работает VPN-сервер L2TP/IPsec из под виндозного клиента.

Ещё знаю но сам не сталкивался, что то подкручивают в реестре видны для соединений ipsec из-за ната. Надо гуглить. 

Link to comment
Share on other sites

  • 0
3 часа назад, ALALNIK сказал:

Как я понимаю это NAT провайдера виноват. Сейчас пробовали у коллеги на другом компе, у него тож белый IP, но он у него не натируется. Что в соединении пишет,  на то и коннектится. Так вот у него работает VPN-сервер L2TP/IPsec из под виндозного клиента.

Если вы про то, что белый адрес у вас посредством NAT у провайдера, то такая конфигурация неработоспособна. Нужен нормальный адрес.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...