Jump to content
  • 0

Keenetic c модемом E3372h-320 теряет связь и не восстанавливается


Alex965
 Share

Question

Keenetic 4G (KN-1210) с модемом Е3372 теряет связь и не восстанавливается приходится каждое утро перезагружать . Обычно происходит ночью. Ping Check по умолчанию. 

log keenetic.txt

  • Upvote 1
Link to comment
Share on other sites

22 answers to this question

Recommended Posts

  • 0

Уточните модель модема или пришлите селфтест.

Проблему можно обойти командой:

Цитата

interface CdcEthernet0 usb wwan-force-connected

 

Link to comment
Share on other sites

  • 0

@Alex965 Мы уже получили много заявок в техподдержку относительно E3372h-320. Ранее мы работали только с версиями данного модема от провайдеров. Оригинальный Huawei не тестировался с прошивкой. В самое ближайшее время мы приобретем собственный экземпляр и затем последует исправление. Пока ждите.

Link to comment
Share on other sites

  • 0

Обновления все установлены, автообновления в модеме отключены (по советам на форумах), и все так же неожиданно раз в сутки отваливается только интернет. Перезагрузка из браузера или передернуть модем - и опять все полетело.

Может прошивку заменить в модеме или роутере? 

Может как-то автоперезагрузку сделать? как в 3372h-153..

Link to comment
Share on other sites

  • 0

Добрый день,

Такая же история 4G (KN-1211) + 3372h-320 hilink - версия на роутере 3.6.3. автообновления в модеме отключены, точка доступа прописана под конткретного оператора. Модем подключается к оператору, а интернета на роутере нет.

Перезагрузка модема и все опять работает.

Оператор А1 (Беларусь)

 

Link to comment
Share on other sites

  • 0
8 часов назад, Shogun сказал:

Добрый день,

Такая же история 4G (KN-1211) + 3372h-320 hilink - версия на роутере 3.6.3. автообновления в модеме отключены, точка доступа прописана под конткретного оператора. Модем подключается к оператору, а интернета на роутере нет.

Перезагрузка модема и все опять работает.

Оператор А1 (Беларусь)

 

с модемом подтвердить не могу за неимением такого, но перезагружать его же можно автоматически по пингчеку, при потере интернета. У вас настроен пингчек?

Link to comment
Share on other sites

  • 0
11 hours ago, Mikesk said:

с модемом подтвердить не могу за неимением такого, но перезагружать его же можно автоматически по пингчеку, при потере интернета. У вас настроен пингчек?

Посмотрел в настойках, Ping Check у меня отключен.
Но судя по комментам в статье https://help.keenetic.com/hc/ru/articles/360000478579-Тонкая-настройка-Ping-Check такая ситуация не у меня одного.
Буду пробовать настраивать ICMP сценарий.

Но может и нужно какое-то участие разработчиков Keenetic, и обновление прошивки поможет.

Link to comment
Share on other sites

  • 0
1 час назад, Shogun сказал:

Но может и нужно какое-то участие разработчиков Keenetic, и обновление прошивки поможет.

так-то конечно, если проблема у многих. Но конкретно вам быстрее ее решить настройкой, а потом уже ждать прошивки с исправлением. Это не всегда быстро, 3.6.3 уже давно в стабильных, а то, что в бете (3.6.4 - кстати, проверьте на ней) что-то не торопятся стабилизировать, может из-за праздников.

Link to comment
Share on other sites

  • 0
3 hours ago, Mikesk said:

так-то конечно, если проблема у многих. Но конкретно вам быстрее ее решить настройкой, а потом уже ждать прошивки с исправлением. Это не всегда быстро, 3.6.3 уже давно в стабильных, а то, что в бете (3.6.4 - кстати, проверьте на ней) что-то не торопятся стабилизировать, может из-за праздников.

Попробовал. Ping Check по ICMP включил. Будет мониторить 8.8.8.8 IP-шник
Результат расскажу.

Link to comment
Share on other sites

  • 0
В 06.05.2021 в 21:27, Mikesk сказал:

с модемом подтвердить не могу за неимением такого, но перезагружать его же можно автоматически по пингчеку, при потере интернета. У вас настроен пингчек?

Замучаетесь перегружать, проблему с потерей связи и этим модемом наблюдал еще 2-а года назад, что то у операторов связи изменилось, и теперь этот модем периодически "зависает", что на Ростелекоме, что на Мегафоне, с другими операторами не пробовал, но думаю картина будет не лучше. Вот тут я описывал про эту проблему -  https://4pda.ru/forum/index.php?showtopic=976143&view=findpost&p=98457995 , решилось как раз покупкой LTE роутера. Проблема в том, что модем то как раз сам не зависает, в нем перестает работать передача данных в радио модуле, никакие прошивки не смогли решить эту проблему, только замена на что-то более современное. Сейчас у меня стоит Keenetic HERO 4G, все проблемы как рукой сняло. Совет простой, выбрасывайте нафиг этот модем, ну или используйте для временного соединения, для постоянного подключения и раздачи интернета он больше не годится.... 

P.S. Такая же история с "зависанием" наблюдается на старом Keenetic LTE, на нем еще раньше все началось, поэтому поставил модем, а 2-а года назад начались и с ним проблемы...

Link to comment
Share on other sites

  • 0
48 минут назад, McMCC сказал:

модем периодически "зависает"

Данное замечание относится и к серии 153, и к серии 320?

Link to comment
Share on other sites

  • 0
19 часов назад, vst сказал:

Данное замечание относится и к серии 153, и к серии 320?

Описанные симптомы 320 в точности такие же как у 153, видимо нет особой разницы.

Link to comment
Share on other sites

  • 0
On 5/7/2021 at 1:36 PM, Shogun said:

Попробовал. Ping Check по ICMP включил. Будет мониторить 8.8.8.8 IP-шник
Результат расскажу.

Результат с Ping Chek следующий. Один раз был тотальный разрыв связи, но в это время было IPTV включено. 4 суток (тьфу-тьфу-тьфу) без дисконнекта. Периодичность провеки: 30 сек. Порог срабатывания:5.
Продолжаю мониторить.

Прошивка роутера 3.6.3
 

Link to comment
Share on other sites

  • 0

а при включении роутера у вас сразу есть интернет?

у меня всегда "без доступа к интернету". приходится вручную в кинетике отключать модем и запускать его заново

Link to comment
Share on other sites

  • 0

Ситуация такая: купил на дачу Keenetic 4G и модем E3372-h320. До этого в роутере был подключен симочный TP-Link двое или трое суток, за это время он ни разу не отвалился, днём выдавал скорость 20-30 мб/с, вечером 40-60 мб/с, и вообще никогда не падала до нуля. А когда подключил E3372 в роутер, он спустя сутки начал периодически отваливаться: скорость 0 мб/с, есть только отдача, уходит в перезагрузку (Ping Check я уже отключил), но при этом сигнал LTE полный. Продолжается это пару часов, помогает переключение на 3G, но у меня к тому же имеется спутниковая тарелка (направлена на БС), благодаря которой скорость утром и вечером достигает 75 мб/с, но я не для того покупал модем, чтобы сидеть в 3G. 

Link to comment
Share on other sites

  • 0

Третьи сутки модем работает исправно, ни одного отключения. Делаю вывод, что он не справляется, когда сотовая вышка перегружена. Блока питания на 1А мало, так как модем в пик нагрузки потребляет 1.5-2А, если почитать форумы 4PDA

Link to comment
Share on other sites

  • 0

1.5 ампер - это предельный ток, который может выдать порт Кинетика. Превышение ведет к резкому сбросу напряжения и отвалам модема.

@andreyalexeich Было бы интересно посмотреть, изменится ли поведение модема с указанной вышкой, но при этом при достаточном питании модема от внешнего источника.

Link to comment
Share on other sites

  • 0

Всем привет, у меня такая же история с модемом Huawei E3372-153 + подключен усилитель сигнала на чердаке. Оператор мегафон, подключен модем через роутер Keenetic 4G (KN-1211). Часто перезагружается. Помогите плиз, замучился уже и как и где отключить ping check

Link to comment
Share on other sites

  • 0

Пропадает доступ к интернет через модем E3372-153 на KN-1711 v3.7.3.
Ping-Check не помогает из-за особенности его работы.
На самом модеме уже задействовал свой скрипт поверки доступности:
#!/system/bin/busybox sh
while true; do
/system/bin/sleep 90
if ! /system/xbin/busybox wget http://captive.apple.com -q -O - | /system/xbin/busybox grep -cE "Success"; then
/system/bin/reboot
fi
done

Вижу в логах keenetic скрипт срабатывает:
kernel: usb 1-1: USB disconnect, device number 24
Далее до момента визуального обнаружения пропажи (перезагрузка модема вручную из web) перезагрузок модема не было,
т.е. на модеме был доступ к интернет (дополнительно зашел в web модема и удостоверился в его наличии), но все это время у keenetic не было доступа к интернет!
И почему Ping-Check срабатывает только после восстановления доступа к интернет?
Сберечь модем... бред, Нужно позволить решать пользователю что главнее: сберечь железку или пытаться восстанавливать соединение!

Куда копать?

Как сделать перезагрузку keenetic при отсутствии интернет,
Ping-Check НЕ предлагать, он НЕ помогает, т.к. срабатывает только после восстановления доступа к интернет!?
через Entware понятно можно, но это плюс USB-Hub и usb-flash - лишнее!

Обратился в ТП (запрос #578894) - посоветовали настроить Ping-Check и выполнить:

(config)> interface CdcEthernet0 usb power-fail 60 retry 10
(config)> system configuration save

НЕ помогает! Далее от ТП ответа нет.

self-test прилагаю ниже.

upd: на OMNI с таким же E3372-153 начиная с 2.16.D.12 такая же проблема!!! Решил временно заменой модема на MF831.

Edited by Игорь Слесаренко
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...