Jump to content

Albram

Forum Members
  • Posts

    340
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by Albram

  1. Конечно можно: используем в dnscrypt-proxy другие серверы, более быстрые, чем opennic (хоть те же яндексовские), а за доступ к нужным ресурсам отвечает указанное выше решение от Михаила, вместо доступа к их зеркалам в зоне .lib
  2. Речь, в данном случае, о возможности резолвить зону .lib серверами opennic. Приведённые выше вами сервера этого не умеют.
  3. Попользовался две недели этим решением, практически всё устраивает, кроме того, что серверы opennic иногда долго отвечают. В настройках менял стратегию dnscrypt-proxy на fastest вместо p2, но особой разницы не заметил, т.к. два самых быстрых сервера с временем отклика в районе 50ms не всегда отвечают, и вместо них начинают отзываться более дальние с временем более 300ms. Если заморочиться на "защищенности" и включить только серверы с поддержкой DNSSEC, то их количество сокращается, и в тесте dnsleaktest у меня отзывался всегда только один, что не очень хорошо. Попробовал совместно с текущим решением использовать найденное здесь (спасибо Михаилу Лукьянову за помощь в реализации): https://forum.keenetic.net/topic/3078-обход-блокировок-на-роутере/?do=findComment&comment=60919 Вот такой вариант понравился больше, т.к. в нем нет привязки только к одним dns серверам, и можно использовать любые, без потери функционала.
  4. Хорошо бы, но не взлетает. Запускается нормально: Профиль выбран rt, в файл zapret-host-user.txt добавил пару сайтов, как тут написано, но при попытке на них зайти, сначала заглушка прилетала, указал её в конфиге, прилетать перестала, но сайты всё равно не открываются: Пробовал другие профили (в том числе те, которые используют tpws, сначала выходила ошибка, т.к. adduser из Entware не поддерживает такой синтаксис, заменил ключами, пишет что неизвестная группа nogroup. С группой конечно ерунда, добавил nobody, но при запуске с профилем domru, ругается на правила: В профиле rt пробовал менять размер пакета, хотя, судя по моим результатам blockcheck, это и не должно было помочь. tcpdump по команде tcpdump -vi br0 host 195.82.146.214 | grep "HTTP, length" не ловит вообще ничего tcpdump -vi br0 host 195.82.146.214 Вот на этом пока и остановился. Нужно будет подбирать правила под свои условия, раз готовые наборы не работают.
  5. Подскажите, каким методом лучше сделать обход, если на клиентской машине получен такой результат blockcheck, там, конечно, написано по-русски про tor и vpn, но хотелось уточнить, т.к. сейчас использую dnscrypt-proxy с набором серверов opennic для резолва зоны .lib (при запуске blockcheck всё это отключал), но в ней не все нужные сайты имеются.
  6. Я перешёл на 2.13, там этой проблемы нет. Спасибо Вам за это! Когда-то у вас в техподдержке направили меня сюда за решением задачи просмотра SMART подключенного к интернет-центру диска. Так я оказался здесь и много чего почерпнул для себя.
  7. Всем спасибо! Переход на 2.13 успешно состоялся. Привыкаю к новому интерфейсу, пока впечатления сугубо положительные. Останется перевести старый Entware на новый.
  8. Спасибо! Я знал про эти команды, и именно так переходил на legacy. И смотрел changelog более старших версий и везде в них последней версией, в которой упоминался Zyxel Keenetic Ultra (Не KN-1810) была именно 2.11. Из этого я сделал вывод что на процессоры младше MT76xx эти версии не ставятся. Интересно почему тогда официальная тех. поддержка с месяц назад именно на 2.11 порекомендовала перейти...
  9. Серьёзно? Не знал, т.к. в списке устройств в темах соответствующих версий про Zyxel Keenetic Ultra нет ни слова. Тогда это в корне меняет дело ?
  10. Откуда-то же нашлись ресурсы на выпуск с неделю назад D.0.0-1. Потому и написал, с надеждой что пофиксят, т.к. на старых девайсах Zyxel Keenetic Ultra выше 2.11 не поставишь ничего. Да и переход на неё не от нечего делать произведён, а по причине описанной тут: https://forum.keenetic.net/topic/5230-zyxel-keenetic-ultra-создает-очень-много-фрагментов-mft-на-подключенном-usb-диске/
  11. Универсальный рецепт, конечно ? Но перспективы решения понятны.
  12. Keenetic Ultra, NDMS 2.11.D.0.0-1 после входа в интерфейс с планшета лог забивается сообщениями об отсутвующих файлах или каталогах. В предыдущей 2.11.D.0.0-0 было тоже самое.
  13. Тогда смысла писать действительно нет. Официальная тех.поддержка рекомендовала обновить прошивку до 2.11, в ней обновлен компонент работы с накопителями. Обновил, понаблюдаю. Ещё один важный момент не указал, похоже что основной причиной падения ФС стала не высокая фрагментация MFT (она только мешала дефрагментировать диск после восстановления), а то, что в атрибуте B0 в MFT две записи указывали на одно и то же место. Удаление одной неправильной записи вернуло диск к жизни. Вот так выглядели записи атрибутов (красным выделено то, о чем писал).
  14. sx2352, если периодически делать дефрагментацию диска в Windows, то это позволит не доводить ситуацию до критической. Но это борьба с последствиями, а не с причиной.
  15. Здравствуйте.К Интернет-Центру Zyxel Keenetic Ultra (версия NDMS: v2.06(AAGJ.0)C3) постоянно (круглосуточно) подключен внешний USB HDD Seagate Backup Plus ёмкостью 1ТБ, на который ведется архивирование штатными средствами Windows 10. Периодически (примерно раз в два-три месяца) в журнале интернет-центра появлялась ошибка от ntfs (точного текста ошибки, к сожалению не помню, и, как назло, скринов не сделал (*посыпает голову пеплом*), но в ней в том числе было написано: "... Подключите диск к компьютеру с Windows.") и после ошибки запись на диск прекращалась (например, невозможно было создать папку на диске через проводник или любой файловый менеджер), чтение при этом работало. "Лечилось" это подключением диска к компьютеру с Windows и выполнением проверки диска, при которой ошибок не находилось, но после этого запись на диск восстанавливалась и ошибок в журнале не было. Так продолжалось 3 года, пока после очередной такой ошибки и подключения диска к компьютеру с Windows файловая система диска перестала видеться, и диск виделся в формате RAW. При восстановлении диска выяснилось, что файл $MFT на диске состоит из более чем тысячи фрагментов по 256 блоков (скрин выполнения команды defrag прилагаю). Диск не имеет дефектных блоков и SMART диска в порядке. Источником проблемы (прямым или косвенным) по-видимому является драйвер ntfs в ПО роутера, который при увеличении записей в MFT создает мелкие фрагменты размером 256 блоков. Возможно как-то изменить такое поведение драйвера? Т.к. ситуация постепенно приводит к неработоспособности диска, подключенного к роутеру, на уровне файловой системы и грозит потерей всех данных на нем. Скрин
  16. На GitHub есть версия этого скрипта 1.0 в которой добавлено отображение информации о разделах и свободном месте диска. https://github.com/gSpotx2f/smarthtml Установка в принципе аналогична, только ещё fdisk нужно установить, чтобы использовать отображение сведений о разделе и указать правильный HTML_DIR: HTML_DIR="/opt/share/www"
  17. С полноценной утилитой лучше, но только наполовину) df /dev/sdb1 не работает, а по точке монтирования заработало, но в колонке Filesystem пусто. ~ # df -h /dev/sdb1 df: ‘/tmp/mnt/Seagate\\040Backup\\040Plus\\040Drive’: No such file or directory ~ # df -h /tmp/mnt/Seagate\ Backup\ Plus\ Drive/ Filesystem Size Used Avail Use% Mounted on - 932G 864G 68G 93% /tmp/mnt/Seagate Backup Plus Drive
  18. Отвечу сам себе: проблема была в метке тома. Поменял её на короткую и без пробелов, и проблема ушла. Но имхо df всё-таки должен понимать длинные имена, ls же понимает.
  19. Здравствуйте. К Keenetic Ultra с прошивкой 2.06 и Entware-Keenetic вот из этой темы: подключен внешний диск NTFS и флэшка Ext2 (с Entware) диск - /dev/sdb1, флэшка - /dev/sda1 команда df на /dev/sda1 работает: ~ # df -h /dev/sda1 Filesystem Size Used Available Use% Mounted on /dev/sda1 242.1M 22.2M 207.4M 10% /tmp/mnt/keenle на /dev/sdb1 выдает: ~ # df -h /dev/sdb1 Filesystem Size Used Available Use% Mounted on df: /tmp/mnt/Seagate\040Backup\040Plus\040Drive: No such file or directory Метка у диска такая длинная и с пробелами была изначально. df -h <точка монтирования> тоже не срабатывает: ~ # df -h /tmp/mnt/Seagate\ Backup\ Plus\ Drive/ Filesystem Size Used Available Use% Mounted on df: /tmp/mnt/Seagate\040Backup\040Plus\040Drive: No such file or directory хотя по ls содержимое диска видно: ~ # ls -l /tmp/mnt/Seagate\ Backup\ Plus\ Drive/ -rwxrwxr-x 1 root www 32 Jul 17 2012 Autorun.inf -rwxrwxr-x 2 root www 562718 Aug 15 2013 BackupPlus.ico ... В чем может быть проблема?
  20. Захотел добавить e-mail оповещение, но в Entware нет sendmail. Внес изменения в скрипт для работы с msmtp. 1. Устанавливаем msmtp: opkg install msmtp 2. Правим файл /opt/etc/msmtprc Для отправки с gmail.com у меня он выглядит так (закомментированные строки из него пропущены): account default logfile /opt/var/log/msmtp.log #эту строку можно не создавать, если не нужен логфайл host smtp.gmail.com port 587 tls on tls_certcheck off syslog LOG_MAIL auth login user e-mail@gmail.com #ваш аккаунт на gmail password ........ #пароль в аккаунт на gmail from any_words_or_address #любой адрес или слово, оно будет отправляться серверу как параметр From 3. Правим строки в файле скрипта /opt/usr/bin/smarthtml.sh USE_MAIL=1 MAIL_RECIPIENT="recipient@gmail.com" #здесь указываем на какой адрес будут отправляться уведомления Следующие строки нужно закомментировать или удалить, они не нужны, т.к. openssl не используется, и он не установлен: #OPENSSLCMD=`which openssl` #if [ $USE_MAIL -eq 1 -a $? -ne 0 ]; then # echo " Error! openssl doesn't exists..." >&2 # USE_MAIL=0 #fi Меняем MTA c MTA=`which sendmail` на: MTA=`which msmtp` Меняем MTACMD на: MTACMD="${MTA} -t $MAIL_RECIPIENT" 3. Сохраняем сделанные изменения и пробуем отправить тестовое уведомление: /opt/usr/bin/smarthtml.sh mailtest Если всё сделано правильно, то получаем тестовое уведомление на указанный адрес.
×
×
  • Create New...