Jump to content
  • 0

3.8 Alpha 1 >> DNS Access Problem after disabling "DNS servers supplied by internet connections"


tllkrmn
 Share

Question

Disabling of "DNS servers supplied by internet connections" causes a DNS access problem even though there are multiple DNS over TLS servers defined in Keenetic OS 3.8 Alpha 1 (in a KN-2111 model). After only enabling "DNS servers supplied by internet connections" and setting Filter Mode to "Enforce system DNS resolver" enabled DNS access again.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0
8 hours ago, tllkrmn said:

Disabling of "DNS servers supplied by internet connections" causes a DNS access problem even though there are multiple DNS over TLS servers defined in Keenetic OS 3.8 Alpha 1 (in a KN-2111 model). After only enabling "DNS servers supplied by internet connections" and setting Filter Mode to "Enforce system DNS resolver" enabled DNS access again.

Dsiabling "DNS server ......." means that not use ISP DNS. If you dont enter some DNS, you get an connection issue. 

Link to comment
Share on other sites

  • 0

There are already DoTs I configured previously in my system. As I do not want my router to use Turk Telekom DNS servers (which are the DNS servers supplied by my ISS), I disabled the option "DNS servers supplied by internet connections" which totally broke my access to DoTs as well.

As a note, I had both DoHs and DoTs but after upgrading to 3.8 Alpha 1, all my DoHs have gone away and left with only DoTs.

Link to comment
Share on other sites

  • 0
13 hours ago, tllkrmn said:

There are already DoTs I configured previously in my system. As I do not want my router to use Turk Telekom DNS servers (which are the DNS servers supplied by my ISS), I disabled the option "DNS servers supplied by internet connections" which totally broke my access to DoTs as well.

As a note, I had both DoHs and DoTs but after upgrading to 3.8 Alpha 1, all my DoHs have gone away and left with only DoTs.

You need to add DNS servers while switch is disabled on "DNS servers supplied by internet connections" like this https://prnt.sc/25ocphu

You need to configure your dns, dot and doh manually if you dont use any public dns or ready-to-go nextdns component. Ex: https://prnt.sc/25ocxx0 , https://prnt.sc/25od49g , https://prnt.sc/25odbu6


I used Nextdns Service. So nextdns is automatically add dns, dot and doh on my connection. nothing is broken...

https://prnt.sc/25odw1z , https://prnt.sc/25oe14d

 

 

Edited by yerebakan
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...