Jump to content
  • 0

3.8 alpha 8 KN-2410+ EM7455 в режиме QMI и DualSim M2 адаптер


VikG
 Share

Question

Вопрос касательно заявленной  функциональности в версии 3.8 alpha 3:

Цитата
  • USB: добавлен переключатель слота SIM-карты для QMI-модемов [NDM-2015]:
    • interface {name} sim slot ( 1 | 2 )

Адаптер: https://aliexpress.ru/item/1005001856128335.html

Роутер KN-1211

Модем Dw5811e aka EM7455 

Под Windows модем в адаптере работает с переключением между сим слотами посредством AT команд AT!UIMS=1 / AT!UIMS=0

В роутере же Статус SIM-карты SIM-карта не установлена

Результат такой при обеих командах

interface UsbQmi0 sim slot 1
interface UsbQmi0 sim slot 2

Реакция на down и up есть

Edited by VikG
Обновление конфигурации для тестирования
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

UIM2ENABLE Активирован - под Windows удаётся переключаться между sim картами

AT!CUSTOM="SIMLPM",1

AT!CUSTOM="UIM2ENABLE",1

AT!CUSTOM="SIMHOTSWAPDIS", 0

AT+CFUN = 1

Сим карту под кинетиком не видит во всех комбинациях с участием 2сим: и пустые слоты и со вставленными сим.

 

Есть ли возможность на кинетике вводить AT команды на QMI интерфейсе и посмотреть ответ модема?

Link to comment
Share on other sites

  • 0
3 hours ago, VikG said:

Есть ли возможность на кинетике вводить AT команды на QMI интерфейсе и посмотреть ответ модема?

Можно, но необходимо установить opkg, entware...

SIM hotplug работает?

 

Link to comment
Share on other sites

  • 0
Posted (edited)

Обновление по ситуации:

Роутер - KN2410 GIGA SE  3.8 alpha 8

Обновлён переходник на обычный, с 1сим в чёрном алюминиевом корпусе .

Модем сброшен в ноль и перенастроен повторно. На винде работает в любой конфигурации.

НО в интерфейсе  роутера всё по старому -  Статус SIM-карты SIM-карта не установлена

Установил opkg и в minicom -D /dev/ttyUSB2 получаю такое: 

Скрытый текст
AT!LTEINFO?
!LTEINFO:
Serving:   EARFCN MCC MNC   TAC      CID Bd D U SNR PCI  RSRQ   RSRP   RSSI RXLV
             1850 250  20 27006 038A3E0B  3 5 5  -10 223 -18.2 -111.8  -66.1 --

IntraFreq:                                          PCI  RSRQ   RSRP   RSSI RXLV
                                                    224 -19.3 -111.8  -77.3 --
                                                    223 -18.2 -111.8  -66.1 --

InterFreq: EARFCN ThresholdLow ThresholdHi Priority PCI  RSRQ   RSRP   RSSI RXLV
             3400            0           0        0 438 -15.5 -122.3  -95.8   0
             3400            0           0        0 224 -14.5 -121.3  -95.8   0

WCDMA:     UARFCN ThreshL ThreshH Prio PSC   RSCP  ECN0 RXLV


OK
AT!GSTATUS?
!GSTATUS:
Current Time:  649              Temperature: 30
Reset Counter: 1                Mode:        ONLINE
System mode:   LTE              PS state:    Attached
LTE band:      B3               LTE bw:      20 MHz
LTE Rx chan:   1850             LTE Tx chan: 19850
LTE CA state:  NOT ASSIGNED
EMM state:     Registered       Normal Service
RRC state:     RRC Idle
IMS reg state: No Srv

PCC RxM RSSI:  -75              RSRP (dBm):  -113
PCC RxD RSSI:  -66              RSRP (dBm):  -110
Tx Power:      --               TAC:         697E (27006)
RSRQ (dB):     -18.7            Cell ID:     038A3E0B (59391499)
SINR (dB):     -15.8

AT+CGREG?
+CGREG: 0,1

OK
AT+CPIN?
+CPIN: READY

OK
AT+COPS?
+COPS: 0,0,"Tele2",7

OK
AT+CSQ
+CSQ: 24,99

OK
aAT
OK
AT!LTECA?
Hardware:
LTEB1: B8,
LTEB2: B2, B5, B12, B13, B29,
LTEB3: B7, B20,
LTEB4: B4, B5, B12, B13, B29,
LTEB5: B2, B4, B30,
LTEB7: B3, B7, B20,
LTEB8: B1,
LTEB12: B2, B4, B30,
LTEB13: B2, B4,
LTEB20: B3, B7,
LTEB25:
LTEB26:
LTEB29:
LTEB30: B5, B12,
LTEB41: B41,

Permitted Bands:
LTEB1: B8,
LTEB2: B2, B5, B12, B13, B29,
LTEB3: B7, B20,
LTEB4: B4, B5, B12, B13, B29,
LTEB5: B2, B4,
LTEB7: B3, B7, B20,
LTEB8: B1,
LTEB12: B2, B4,
LTEB13: B2, B4,
LTEB20: B3, B7,
LTEB25:
LTEB26:
LTEB29:
LTEB41: B41,

 

Т.е. таки модем видит симку и активен, но в тоже время роутер не видит, что модем готов.

Edited by VikG
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...