Jump to content
  • 0

Quectel EM12-G разрывает соединение на версии 3.9.8 и 3.8.5 и 3.8.4. А на 3.7.1 работает стабильно.


FM

Question

Приветствую вас!

Являюсь обладателем Keenetic Ultra II пару лет назад перешел на прошивки канала обновлений delta. Интернет подключался только через мобильную сеть с модемом Quectel EM12-G Примерно год-полтора назад с этим модемом невозможно стало работать он постоянно разрывал соединения с разной периодичностью аптайма от 5 секунд до минуты.  В логах было у него это:

Скрытый текст

[E] Dec  9 21:42:39 ndm: UsbQmi::Device: "UsbQmi0": operation timeout.
[C] Dec  9 21:42:39 ndm: UsbQmi::Device: "UsbQmi0": system failed [0xcffd0eed].
[I] Dec  9 21:42:39 ndm: UsbQmi::Interface: "UsbQmi0": connection lost.
[I] Dec  9 21:42:41 kernel: usb 1-2: USB disconnect, device number 8
[I] Dec  9 21:42:41 kernel: option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[I] Dec  9 21:42:41 kernel: option 1-2:1.0: device disconnected
[I] Dec  9 21:42:41 kernel: option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[I] Dec  9 21:42:41 kernel: option 1-2:1.1: device disconnected
[I] Dec  9 21:42:41 kernel: option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
[I] Dec  9 21:42:41 kernel: option 1-2:1.2: device disconnected
[I] Dec  9 21:42:41 kernel: option1 ttyUSB3: GSM modem (1-port) converter now disconnected from ttyUSB3
[I] Dec  9 21:42:41 kernel: option 1-2:1.3: device disconnected
[I] Dec  9 21:42:41 kernel: qmi_wwan 1-2:1.4 wwan0: unregister 'qmi_wwan' usb-xhci-mtk-2, WWAN/QMI device
[E] Dec  9 21:42:42 ndm: UsbQmi::Device: unable to read data: no such device.
[C] Dec  9 21:42:42 ndm: UsbQmi::Device: "UsbQmi0": system failed [0xcffd0262], unable to read response header: operation failed.
[C] Dec  9 21:42:42 ndm: UsbQmi::Device: "UsbQmi0": system failed [0xcffd130e].
[C] Dec  9 21:42:42 ndm: UsbQmi::Device: "UsbQmi0": system failed [0xcffd0232], unable to write request: operation failed.
[C] Dec  9 21:42:42 ndm: UsbQmi::Device: "UsbQmi0": system failed [0xcffd0e77].
[I] Dec  9 21:42:42 ndm: Network::Interface::Usb: "UsbQmi0": interface "UsbQmi0" is unplugged.
[I] Dec  9 21:42:42 ndm: Network::Interface::Ip: "UsbQmi0": IP address cleared.
[I] Dec  9 21:42:42 ndm: Network::InternetChecker: Internet access lost (status: 0x0000).
[I] Dec  9 21:42:45 ndm: Http::Nginx: loaded SSL certificate for "xxxxxxxxxxxx.keenetic.io".
[I] Dec  9 21:42:45 ndm: Http::Nginx: loaded SSL certificate for "xxxxxx.keenetic.pro".
[I] Dec  9 21:42:46 ndm: Core::Server: started Session /var/run/ndm.core.socket.
[I] Dec  9 21:42:46 ndm: Core::Session: client disconnected.
[I] Dec  9 21:42:46 ndm: Http::Manager: updated configuration.
[I] Dec  9 21:42:46 ndm: Core::Server: started Session /var/run/ndm.core.socket.
[I] Dec  9 21:42:46 ndm: Core::Session: client disconnected.
[I] Dec  9 21:42:49 kernel: usb 1-2: new high-speed USB device number 9 using xhci-mtk
[I] Dec  9 21:42:49 kernel: usb 1-2: New USB device found, idVendor=2c7c, idProduct=0512, bcdDevice= 3.18
[I] Dec  9 21:42:49 kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[I] Dec  9 21:42:49 kernel: usb 1-2: Product: EM12-G
[I] Dec  9 21:42:49 kernel: usb 1-2: Manufacturer: Quectel
[I] Dec  9 21:42:49 kernel: usb 1-2: SerialNumber: 0123456789ABCDEF
[I] Dec  9 21:42:49 kernel: option 1-2:1.0: GSM modem (1-port) converter detected
[I] Dec  9 21:42:49 kernel: usb 1-2: GSM modem (1-port) converter now attached to ttyUSB0
[I] Dec  9 21:42:49 kernel: option 1-2:1.1: GSM modem (1-port) converter detected
[I] Dec  9 21:42:49 kernel: usb 1-2: GSM modem (1-port) converter now attached to ttyUSB1
[I] Dec  9 21:42:49 kernel: option 1-2:1.2: GSM modem (1-port) converter detected
[I] Dec  9 21:42:49 kernel: usb 1-2: GSM modem (1-port) converter now attached to ttyUSB2
[I] Dec  9 21:42:49 kernel: option 1-2:1.3: GSM modem (1-port) converter detected
[I] Dec  9 21:42:49 kernel: usb 1-2: GSM modem (1-port) converter now attached to ttyUSB3
[I] Dec  9 21:42:49 kernel: qmi_wwan 1-2:1.4: cdc-wdm0: USB WDM device
[I] Dec  9 21:42:49 kernel: qmi_wwan 1-2:1.4 wwan0: register 'qmi_wwan' at usb-xhci-mtk-2, WWAN/QMI device, 8a:10:xx:xx:xx:xx
[I] Dec  9 21:42:49 ndm: Network::Interface::Usb: "UsbQmi0": interface "UsbQmi0" is plugged (port 1).
[I] Dec  9 21:43:23 ndm: Mobile::Mvno: "UsbQmi0": matched 25002, APN: "internet".
[I] Dec  9 21:43:23 ndm: UsbQmi::Interface: "UsbQmi0": device initialized.
[I] Dec  9 21:43:28 ndm: UsbQmi::Interface: "UsbQmi0": network ready.
[I] Dec  9 21:43:28 ndm: UsbQmi::Interface: "UsbQmi0": connection initialized.
[I] Dec  9 21:43:29 ndm: UsbQmi::Interface: "UsbQmi0": connection established.

 

Я тогда вместо него подключил обычный Huawei 8372 и он стабильно работал все время.

На днях решил разобраться с Quectel EM12-G стал откатывать на доступные мне версии прошивок Keenetic OS и выяснил, что на версии прошивки 3.7.1 модем работает стабильно без разрывов. Вероятно я ранее не связал обновление прошивки роутера с начавшимися проблемами в виде разрыва интернета.

Готов помочь в поиске проблем на более свежих версиях прошивок Keenetic OS. На тематических форумах есть много пользователей с аналогичными проблемами

 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0
1 час назад, FM сказал:

EM12-G

Какая версия прошивки у вашего EM12-G? Очень спорный модуль получился у Quectel, много жалоб на нестабильную работу. Я в итоге перешёл на EM160R-GL.

Edited by drugold
Link to comment
Share on other sites

  • 0
15 минут назад, drugold сказал:

Какая версия прошивки у вашего EM12-G? Очень спорный модуль получился у Quectel, много жалоб на нестабильную работу. Я в итоге перешёл на EM160R-GL.

на прошивке 3.9.8 проверял разные версии прошивки модема и 18 и 19 и 21 нескольких подверсий. потом вернулся на изначальную с покупки EM12GPAR01A20M4G_01.001.01.001 сделал сброс всех настроек модема и стал менять версии на Keenetic-e и он стабильно заработал лишь на KeeneticOS 3.7.1.

Забыл сказать, что модем настроен в режиме только 4G, только band 7. Аггрегация b7+b7.  Ping Check отключен

Link to comment
Share on other sites

  • 0

Просмотрел на различия между 3.7.1 и 3.9, в том числе произведена сверка согласно предоставленному логу. Пока не удалось понять, какие именно запросы приводят к тому, что модем перестаёт отвечать на совершенно стандартный запрос информации об активной несущей. По мере получения диагностики в виде логов перед и во время потери связи буду проводить проверки.
 

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...