Jump to content
  • 0

Ошибка при попытке подключиться по ssh


tumaykin

Question

Добрый день. Давно не могу использовать подключение по ssh к роутеру. Поиском ничего не смог найти. 

Может кто-то сталкивался и знает решение

ssh admin@192.168.0.1
admin@192.168.0.1's password:
Command::Base error[7405600]: no such command: export.
Connection to 192.168.0.1 closed.

Такое поведение получаю на 3-х роутерах: KN-1011, KN-2310 и KN-1611

Прошивка 4.0.7 на всех роутерах, но проблема началась с более ранних версий и давно с ней мирюсь, поэтому уже не припомнить с чего она началась.

Через telnet подключение работает, а вот по ssh получаю ошибку.

Edited by tumaykin
Link to comment
Share on other sites

13 answers to this question

Recommended Posts

  • 1
16 часов назад, tumaykin сказал:

Добрый день. Давно не могу использовать подключение по ssh к роутеру. Поиском ничего не смог найти. 

Может кто-то сталкивался и знает решение

ssh admin@192.168.0.1
admin@192.168.0.1's password:
Command::Base error[7405600]: no such command: export.
Connection to 192.168.0.1 closed.

Такое поведение получаю на 3-х роутерах: KN-1011, KN-2310 и KN-1611

Прошивка 4.0.7 на всех роутерах, но проблема началась с более ранних версий и давно с ней мирюсь, поэтому уже не припомнить с чего она началась.

Через telnet подключение работает, а вот по ssh получаю ошибку.

Это терминал на MacOS отправляет автоматически команду

export

о которой кинетик ничего не знает

  • Upvote 2
Link to comment
Share on other sites

  • 0
1 час назад, tumaykin сказал:

Может кто-то сталкивался и знает решение

ЕМНИП, а она мне редко изменяет, но компонент ssh server не идёт по умолчанию в стандартной прошивке. Его надо "доустановить".

Link to comment
Share on other sites

  • 0

Установлен на всех 3-х роутерах


image.thumb.png.378d7ec6ad8a216d3ed09338482f728a.png

 

Когда-то, очень давно, ssh работал. А спустя какое-то время перестал работать. Так как редко им пользуюсь, то история умалчивает, что изменилось между этими событиями.

 

KN-1011 пришел на замену KN-1010 с восстановлением настроек из файла. Поэтому, можно сказать, что он сразу же после восстановления настроек не работает с ssh

Link to comment
Share on other sites

  • 0
9 часов назад, tumaykin сказал:

KN-1011 пришел на замену KN-1010 с восстановлением настроек из файла. Поэтому, можно сказать, что он сразу же после восстановления настроек не работает с ssh

Вот с этой информацией и проследуйте к официалам ибо тут нет телепатов.

Link to comment
Share on other sites

  • 0

Просканируйте на факт открытых портов.... бородатая бага была, когда съезжали порты... что то типа ssh съехал на 21 порт или т.п.

Link to comment
Share on other sites

  • 0
1 час назад, MDP сказал:

Просканируйте на факт открытых портов.... бородатая бага была, когда съезжали порты... что то типа ssh съехал на 21 порт или т.п.

Да не. На 22 порту отвечает демон. Трабла с "экспортом". За каким органом яблоко посылает внезапно лишнюю команду - вопрос явно мимо кассы!

  • Upvote 1
Link to comment
Share on other sites

  • 0
1 час назад, Denis P сказал:

Это терминал на MacOS отправляет автоматически команду

export

о которой кинетик ничего не знает

Спасибо. Вы правы.

Проверил через другой терминал, подключение удалось. Я все не мог понять откуда этот export берется ))

Link to comment
Share on other sites

  • 0
2 часа назад, Denis P сказал:

Это терминал на MacOS отправляет автоматически команду

export

о которой кинетик ничего не знает

Век живи - век учись. Просто не имею под рукой яблок и в жизни бы никогда и не узнал такое.

Link to comment
Share on other sites

  • 0
1 час назад, Mamay сказал:

Век живи - век учись. Просто не имею под рукой яблок и в жизни бы никогда и не узнал такое.

это терминал Warp, если включен ssh wrapper

Link to comment
Share on other sites

  • 0
59 минут назад, tumaykin сказал:

это терминал Warp, если включен ssh wrapper

Да просто , как говорите, давно страдаете с этой проблемой, и ни разу не пытались локализовать проблему, и попробовать другой инструмент? ... как то я в недоумении. 

Edited by MDP
Link to comment
Share on other sites

  • 0
56 минут назад, MDP сказал:

Да просто , как говорите, давно страдаете с этой проблемой, и ни разу не пытались локализовать проблему, и попробовать другой инструмент? ... как то я в недоумении. 

Все так, и в мыслях не было попробовать другой терминал. Думал что-то с настройками роутеров связано )

  • Confused 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...