Jump to content
  • 0

Странное поведение dhcpd


tmr
 Share

Question

Keenetic LTE v2.08(AATF.0)C2

Клиент подключен по wifi и ethernet одновременно. Похоже на то, что dhcpd выдал клиенту один ip адрес на оба интерфейса?

Это баг или фича(агрегация портов? на клиенте или кинетике)?

dp.jpg.d2f954d235ec27c19d881a1e97906f86.jpg

Link to comment
Share on other sites

18 answers to this question

Recommended Posts

  • 0
Только что, zyxmon сказал:

Похоже на то, что нужно проверять на клиенте, а потом уже делать выводы.

Нечего на клиенте проверять - никаких специальных параметров для интерфейсов не прописано, только iface inet dhcp

Еще раз посмотрел - Кинетик явно путает интерфейсы, вместо проводного показывает беспроводной, проводной сейчас якобы отключен, хотя это совсем не так:if.thumb.jpg.019f6aed800cee9413677a80f3f90128.jpg

Только что, Mamay сказал:

А зачем вы так делаете? 

Нужна была скорость и я подключил беспроводного клиента проводом

Link to comment
Share on other sites

  • 0

Зарегистрировал интерфейсы клиента с фиксированным адресом (.60 и .70), перезагрузил - ситуация не менятся, админка путает адреса:

fc.thumb.png.747ce3f572b33871f13ed3234b8cf2a2.png

Edited by tmr
адрес
Link to comment
Share on other sites

  • 0
57 минут назад, tmr сказал:

Нечего на клиенте проверять

Да мало ли, что морда показывает, может ересь. Что реально происходит, то и нужно проверять.

Одновременное подключение 2х сетевых адаптеров в одну сеть - петля, с вытекающими отсюда. Вы можете использовать wi-fi и ethernet одновременно, но подключив их к разным сетям.

Link to comment
Share on other sites

  • 0
Только что, zyxmon сказал:

Да мало kb? что морда показывает, может ересь. Что реально происходит, то и нужно проверять.

Реально - все нормально, адреса назначаются как прописано. Морда врет, может быть из-за одинакового имени клиента, других не вижу причин.

 

Хотя нет, в логи Кинетика сыпется ругань:

Цитата
May 08 21:26:17ndm
Hotspot::Discovery::Explorer: network conflict: hosts e8:03:9a:9f:a6:64 and a4:17:31:57:d7:65 have the same IPv4 address 192.168.1.60.
May 08 21:26:35ndm
Hotspot::Discovery::Explorer: network conflict: hosts e8:03:9a:9f:a6:64 and a4:17:31:57:d7:65 have the same IPv4 address 192.168.1.70.

 

 
На самом клиенте все нормально - адреса назначены без проблем.
 
А, ну вот аналогичная проблема была уже.
Edited by tmr
upd
Link to comment
Share on other sites

  • 0

Все как то забыли принцип работы DHCP и использование в его работе MAC адрес устройства которому выдан IP - может предложить новый или тот который был ранее в аренде у данного устройства если он свободен.

Разберитесь с регистрацией данного устройства (его интерфейсами потому что wi-fi и LAN имеют разные MAC)

Link to comment
Share on other sites

  • 0
Только что, vasek00 сказал:

Все как то забыли принцип работы DHCP и использование в его работе MAC адрес устройства которому выдан IP - может предложить новый или тот который был ранее в аренде у данного устройства если он свободен.

Разберитесь с регистрацией данного устройства (его интерфейсами потому что wi-fi и LAN имеют разные MAC)

С dhcp все нормально, демон отработал штатно и выдал адреса согласно настройкам (на последней картинке видно). Проблема в отображении инф-и админкой и ошибками в логах.

Я эту тему удалил с пометкой "проблема решена бондигом интерфейсов", не знаю зачем ее восстановили - аналогичный вопрос уже был задан ранее.

10 часов назад, zyxmon сказал:

Одновременное подключение 2х сетевых адаптеров в одну сеть - петля, с вытекающими отсюда...

Это не петля в смысле L2. Это может вызвать определенные проблемы на клиенте, но не должно на коммутаторе.

Link to comment
Share on other sites

  • 0

Как видно на картинке ниже c клиентом Acer, DHCP отработал штатно выдав на два разных MAC разные IP согласно регистрации устройств. Далее клиент согласно своих настроек сетевых карт - приоритет у него по LAN сбросит свое второе соединение по Wi-fi => в результате подключений останется только одно на LAN.

Без имени-2.jpg

Link to comment
Share on other sites

  • 0
Только что, vasek00 сказал:

Как видно на картинке...

У вас сети vlan'оми поделены? Прошивка 2.08? В логах не ругается?

Link to comment
Share on other sites

  • 0
53 минуты назад, tmr сказал:

... Я эту тему удалил с пометкой "проблема решена бондигом интерфейсов", не знаю зачем ее восстановили...

;) по рукам за такое бить надо. Что будет с форумом, если все, решив вопрос, начнут скрывать темы?

  • Upvote 1
Link to comment
Share on other sites

  • 0
Только что, TheBB сказал:

;) по рукам за такое бить надо. Что будет с форумом, если все, решив вопрос, начнут скрывать темы?

Тема уже поднималась раньше и вроде бы в 2.09 проблему пофиксили, т.ч. я решил подождать до релиза и перепроверить уже на нем.

Link to comment
Share on other sites

  • 0
2 часа назад, tmr сказал:

У вас сети vlan'оми поделены? Прошивка 2.08? В логах не ругается?

Стандартный набор настроек LAN портв и wi-fi, по "home.bridges" странице где в данном случае основной IP и его имя "Home" описание "Home VLAN" и DHCP включен.

Скрытый текст

interface FastEthernet0/Vlan1
    description "Home VLAN"

...

interface WifiMaster0/AccessPoint0
    rename AccessPoint
    description "Wi-Fi access point"

...

interface Bridge0
    rename Home
    description "Home VLAN"
    inherit FastEthernet0/Vlan1
    include AccessPoint

Прошивка 2.09, по логам каких либо замечаний нет.

 

Link to comment
Share on other sites

  • 0

Столкнулся со схожей проблемой: у меня в логах ошибка вида

`Hotspot::Discovery::Explorer: "Bridge0": network conflict: hosts xx:xx:xx:xx:xx:xx and yy:yy:yy:yy:yy:yy have the same IPv4 address dd.dd.dd.dd`

Сотрудник поддержки ответил, что причиной может быть так называемый `ARP Flux`, возникающий, если одно и то же устройство под управлением *nix подключено к одной сети через два интерфейса и отвечает на входящие ARP-запросы со всех подключенных интерфейсов.

Подробнее тут: https://netbeez.net/blog/avoiding-arp-flux-in-multi-interface-linux-hosts/

По указанной ссылке предлагается решение через задание настроек:

 

sysctl -w net.ipv4.conf.all.arp_announce=1
sysctl -w net.ipv4.conf.all.arp_ignore=2

 

Если необходимо, чтобы данные настройки работали после перезагрузки, 

нужно добавить следующие строки в `/etc/sysctl.conf` и выполнить `sudo sysctl --system` для обновления состояния системы согласно внесенным правкам:
 

net.ipv4.conf.all.arp_announce=1
net.ipv4.conf.all.arp_ignore=2

 

Link to comment
Share on other sites

  • 0

А реакция на ARP Flux со стороны самого роутера регулируется ? Пока применил аналогичные твики

echo '1'>/proc/sys/net/ipv4/conf/all/arp_announce
echo '2'>/proc/sys/net/ipv4/conf/all/arp_ignore

что были предложены выше и флуд из syslog'a при использовании вирт.машины с несколькими интерфейсами ушёл

Link to comment
Share on other sites

  • 0

Столкнулся так же с подобным поведением. Благо одно из устройств действительно *nix
Raspberry pi с двумя интерфейсами. Периодически падает вайфай(живет своей жизнью не ясно почему) ну я и подключаю кабель.

Второе же устройство это смарт ТВ LG с прошивкой netcast. 
Буду на нем пробовать оставлять только кабель.

Link to comment
Share on other sites

  • 0

А у меня есть пять компов с объединенными в team сетевыми платами. То есть айпишник один, а маки разные. В журнале зеленым-зелено от ошибок вида `Hotspot::Discovery::Explorer: "Bridge0": network conflict: hosts xx:xx:xx:xx:xx:xx and yy:yy:yy:yy:yy:yy have the same IPv4 address dd.dd.dd.dd` На компах набор Windows Server, от 2003 до 2016.

Всё ясно как божий день, но как решить проблему, не знаю.

Edited by sas_72
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...