Jump to content

Неправильная индикация основного или резервного канала


Recommended Posts

Неправильная индикация основного или резервного канала в приложении.

Если с основного на резерв переключает пинг чек по пропаданию пинга - то в приложении отображается основное соединение якобы как активное, но жёлтым цветом.

Если с основного на резерв переключение произошло при выдёргивании провайдерского кабеля - то в приложении правильно отображается активный резервный канал зелёным. 

  • Thanks 1
Link to comment
Share on other sites

Андрей,

Это при подключении к роутеру через облако вы проверяете?
Просто, когда вы в первый раз писали об ошибке отображения текущего WAN, я проверял этот момент, и проблема проявлялась и при выдергивании кабеля, но только при ЛОКАЛЬНОМ ПОДКЛЮЧЕНИИ к роутеру.
Ошибку эту мы еще не правили, но сейчас вы описываете другое поведение - при выдергивании кабеля ошибки нет, при пинг-чеке есть.

Link to comment
Share on other sites

17 минут назад, Alex Sh. сказал:

Андрей,

Это при подключении к роутеру через облако вы проверяете?
Просто, когда вы в первый раз писали об ошибке отображения текущего WAN, я проверял этот момент, и проблема проявлялась и при выдергивании кабеля, но только при ЛОКАЛЬНОМ ПОДКЛЮЧЕНИИ к роутеру.
Ошибку эту мы еще не правили, но сейчас вы описываете другое поведение - при выдергивании кабеля ошибки нет, при пинг-чеке есть.

Я просто даже не ожидал, что приложение может по-разному выводить индикацию при переходе на резерв по разным условиям. 

К сожалению, уже проверить в ближайшее время не получится.

Но 100% что приложение показывает НЕПРАВИЛЬНО - желтым основное соединение в главном меню при том, что активно резервное (переключенное пинг чеком) - при дистанционном подключении. Должно показывать зеленым резервное. 

И вчера я 100% словил правильную индикацию резервного зеленым при выдергивании кабеля - а вот локальное соединение было или дистанционное - не уверен. Скорее локальное.

И я почти уверен, что при дистанционном подключении и выдернутый кабель показывает основное соединение желтым - что неправильно, а должно показывать резервное зеленым. 

Link to comment
Share on other sites

Может выводить по-разному, потому что при удаленном подключении при смене WAN неизбежно происходит разрыв соединения, а при локальном разрыва нет.
Энивэй, я проверил тут, получается следующее:

При локальном подключении:
1) Link down отрабатывается корректно.

2) Ping Check - нет: вместо нового активного канала показывает старый желтым. Обратный переход отрабатывается корректно.

При удаленном подключении:

1) Link down - в принципе, корректно. После падения линка первого WAN приложение теряет связь с роутером. На дашборде при этом я видел разные варианты: WAN пропадает вообще; выдернутый WAN становится желтым. Оба варианта я считаю приемлемыми для ситуации падения WAN. Спустя некоторе время, необходимое для закрытия сессии по таймауту, дашборд начинает корректно отображать текущий (второй) WAN зеленым цветом.

2) Ping Check - аналогично локальному подключению. Даже после восстановления соединения с роутером, на дашборде показывается старый WAN желтым цветом.

Вывод: надо чинить индикацию при пинг-чеке.

Примечание: При предыдущем тестировании я видел неверную индикацию на локальном подключении при смене WAN по Link Down, сейчас же при этом сценарии пролем нет. Где-то что-то починили, видимо.

  • Thanks 1
Link to comment
Share on other sites

7 часов назад, Alex Sh. сказал:

Где-то что-то починили, видимо.

Мне кажется, наоборот сломали. У меня теперь 4G модем в резерве скатывается на 2G. Так иногда было и раньше. Но раньше при переключении на него он тут же переходил на 4G, а теперь висит на  2G до тех пор, пока его пинг чек не передёрнет по питанию, потому что через 2G не тянет вообще ничего. 

Ничего кроме прошивки ультры не менялось за это время. Делаю вывод, что сломали. 

  • Confused 1
Link to comment
Share on other sites

1 час назад, Andrew Voronkov сказал:

Мне кажется, наоборот сломали. У меня теперь 4G модем в резерве скатывается на 2G. Так иногда было и раньше. Но раньше при переключении на него он тут же переходил на 4G, а теперь висит на  2G до тех пор, пока его пинг чек не передёрнет по питанию, потому что через 2G не тянет вообще ничего. 

Ничего кроме прошивки ультры не менялось за это время. Делаю вывод, что сломали. 

Вы точно про индикацию пишите? Резерв 4G/3G/2G и что куда скатывается несколько иное. Лучше не смешивать и отделить отдельной темой.

Link to comment
Share on other sites

Только что, Leksey118 сказал:

Вы точно про индикацию пишите? Резерв 4G/3G/2G и что куда скатывается несколько иное. Лучше не смешивать и отделить отдельной темой.

Все, что я хотел про индикацию написать - я написал. По работе с модемами мной создана отдельная тема. Здесь я отметил, что, может, индикацию частично и поправили, а работу с модемами испортили. Полагаю, это связанные моменты. 

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...