Jump to content

установка Entware - молча не ставится


Recommended Posts

делаю по инструкции 
Жду 15 минут - ничего не произошло. Ни новых записей в логе, ни в файловой системе выбранного диска ничего не добавилось-изменилось.
Вот лог:
 
 
Май 27 18:16:13
 
ndm
Core::Authenticator: user "admin" tagged with "opt".
Май 27 18:16:13
 
ndm
Opkg::Manager: disk is set to: 246f5a84-9b59-418c-b96e-db3b8b3e5a3e.
Май 27 18:16:13
 
ndm
Opkg::Manager: init script reset to default: /opt/etc/initrc.
Май 27 18:16:13
 
ndm
Core::ConfigurationSaver: saving configuration...
Май 27 18:16:15
 
ndm
Http::Manager: new Web server configuration was applied.
Май 27 18:16:18
 
ndm
Core::ConfigurationSaver: configuration saved.
Link to comment
Share on other sites

>> Делаю всё по инструкции....

 

Инструкцию в студию. Их много разных... И опишите пошагово своими словами (не по инструкции, что делаете).

Link to comment
Share on other sites

57 минут назад, zyxmon сказал:

Инструкцию в студию. Их много разных... И опишите пошагово своими словами (не по инструкции, что делаете).

видимо в мобильных версиях форума всё отображаемое режется :)

в первом посте я дал ссылку на инструкцию, вот она: forum.keenetic.net/topic/4299-entware/

что делаю:

1. на диске с ext3 создал папку install (через проводник виндоус по адресу \\192.168.1.1\router )

2. скачал и положил в эту папку файл mipsel-installer.tar.gz

3. в админке роутера во вкладке OPKG указываю этот диск, жму кнопку "сохранить"

 

может, этому файлу нужно исполняемые права как-то задать, либо ещё что подобное?

Link to comment
Share on other sites

1. да, в скриншоте это видно.

2. разумеется да.

3. попровал - результат такой же:

(config)> opkg disk router
Opkg::Manager: Disk is set to: router.
(config)> system configuration save
Core::ConfigurationSaver: Saving configuration...
(config)>

 

И в логе после этого пусто.

Link to comment
Share on other sites

понял в чём дело. 

в инструкции не хватает 4 пункта - после всех настроек, "извлечь" диск через админку, физически вытащить его и опять вставить.

навела на мысль инфа от zyxmon: "Once the opkg disk is configured and the storage is attached"

оставалось создать событие "storage is attached", чего я и сделал.

Edited by Илдар
  • Thanks 1
  • Upvote 1
Link to comment
Share on other sites

Вам "жирнейшая" благодарность, сам сегодня с аналогичной проблемой просидел кучу времени, а надо-то было всего лишь перевоткнуть флешку.

Link to comment
Share on other sites

  • 1 month later...

Подтверждаю проблему, оно еще и не всегда стартует после ребута.

приходится переподключать хард.

p.s. keenetik giga III, v2.12(1)C0

Edited by Hidalgo
Link to comment
Share on other sites

  • 1 year later...

Такая же проблема была и данное решение не помогало, пока не распаковал содержимое архива в корень флешки, все 5 каталогов. Только после этого запустилась установка.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...