Jump to content
  • 0

Постоянно скачет канал при включенном WISP 2,4GHz


4e.Guevara
 Share

Question

В общем, перешел со старой Giga II на Viva и после полной настройки поймал очень странный глюк, которого при аналогичных настройках не было на гиге. Суть такова - если включить WISP в диапазоне 2,4ГГц (часто беру инет с телефона) то роутер произвольно начинает по кругу скакать по всем 2,4 ГГц каналам с интервалом в 20-30 сек (точно не замерял) и в результате, все устройства, что висят на 2,4ГГц, начинают тупо постоянно переподключаться, что ессно вызывает постоянные отвалы инета. Отрубаем WISP - порядок. При этом - если поднять 5ГГц WISP - такого вообще не наблюдается. Роутер постоянно висит на одном канале. Повторюсь еще - на второй гиге при аналогичных настройках такого цирка не было.

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0

4e.Guevara

При поднятии AP-Client форсируется флаг авто-подключения, который разрешает исполнять site-survey, чтобы искать корневую AP. Видимо у вас она не доступна и клиент делает попытки найти кандидата и перебирает каналы. Это нужно ради гарантированной работы MWS (backhaul STA).

В качестве оптимизации могу предложить форсировать это только для backhaul STA, для WISP не делать. Но в любом случае, если на WifiMaster канал задан как Авто, клиент всегда будет исполнять site-survey, чтобы искать корневую AP.   

  • Thanks 1
Link to comment
Share on other sites

  • 0
23 минуты назад, Padavan сказал:

Но в любом случае, если на WifiMaster канал задан как Авто, клиент всегда будет исполнять site-survey, чтобы искать корневую AP. 

Нет, стоит 6й (я знаю, что на этом канале у меня тел раздает), но как только я включаю 2,4WISP - строка в конфиге "channel 6" тупо слетает в авто и начинается вот этот перебор каналов, пока я не включу AP на телефоне и роутер ее не найдет.

Я понимаю, что роутер ищет AP, когда она отключена на телефоне методом перебора, но почему тогда такого же нету в 5ГГц диапазоне? Почему такого не было на гиге 2й??? Где можно отключить эту приблуду с перебором каналов и принудительно заставить сидеть на том канале, котором я хочу и при этом не отключать 2,4ГГц WISP?

 

Edited by 4e.Guevara
Link to comment
Share on other sites

  • 0

4e.Guevara

Можно
 

11 час назад, Padavan сказал:

В качестве оптимизации могу предложить форсировать это только для backhaul STA, для WISP не делать.

 

Link to comment
Share on other sites

  • 0
53 минуты назад, Padavan сказал:

4e.Guevara

Можно
 

 

Извините, если можно - поподробнее. Что и как форсировать? Или где можно почитать?

Link to comment
Share on other sites

  • 0

Было бы чудно, что то придумать, что бы не было этого перебора. А то такое, хоть возвращай назад гигу)))) Там на последней 2,16 такого прикола не было. Канал WISP можно было жестко зафиксировать. Вот как на скрине с Omni на 2,11 (стоит у меня в другом месте)

245811425_01.jpg.54b0f7330809c506a8589db76d541531.jpg

Ну или я не против сделать эту настройку как то через CLI, а то я не очень понял насчет backhaul STA, если честно) Но все равно - спасибо! Жду реализации, а то очень часто приходится пользоваться мобильной точкой доступа

Edited by 4e.Guevara
Link to comment
Share on other sites

  • 0

4e.Guevara

На всех устройствах уже давно такое поведение, а 2.11/2.16 это слишком старые ветки, там только уязвимости и критические исправления.

В любом случае вы ничего сами не сделаете. Только ждать следующий релиз 3.07 или 3.08, где будет поправлен ваш кейз.

  • Thanks 1
Link to comment
Share on other sites

  • 0

Padavan

Спасибо! Жду следующей прошивки! А пока нашел такой метод - включаем 2,4 WISP, заходим в cli и в wifimaster0 прописываем channel 6. Профит - стопорится на 6м канале! Но работает до следующей перезагрузки. Понятно, что делаем copy running-config startup-config и в конфиге строка с 6м каналом остается, но после перезагрузки уже не работает. И как только что то в роутере меняешь - она оттуда испаряется. Ну пока хоть так)

Link to comment
Share on other sites

  • 0

Padavan

Хотел спросить - когда планируется фикс? Сейчас перелез на 3.8, там аналогична ситуация в обеих диапазонах - при включенной WISP каналы скачут, в результате все устройства на Wi-Fi периодически переподключаются

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...