Jump to content
  • 1

Configurable delay before fallback on Main WAN


Axo92
 Share

Question

Hi guys,

I start by saying your firmware and your products are amazing.

Unfortunately, however, I noticed a small lack in the management of the Fallback between Main WAN and Backup WAN, in Failover mode.

The switch between Main and Backup, works wonderfully, but if the main connection backs only for a few minutes, the router will continuously switch between the two networks.

 

So I ask you, if it is possible, to ensure that the fallback on Main WAN occurs only after X minutes (possibly user-configurable) that this connection is online.

Some of your competitors have already foreseen this, but without the possibility of configuring the interval in which to act.

 

PS: in my case the Main WAN is wired and the Backup WAN is connected to a 4G USB modem.

PS2: sorry for my bad English

 

Thank you in advance, and happy new year! 

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Hi, 

You could fine tune ping-check via cli. Please refer to cli manual for reference.

Ping-check contains parameters related to how much success checks should be done before treating inteface as alive.

 

  • Thanks 1
Link to comment
Share on other sites

  • 0
32 minutes ago, r13 said:

Hi, 

You could fine tune ping-check via cli. Please refer to cli manual for reference.

Ping-check contains parameters related to how much success checks should be done before treating inteface as alive.

 

Thanks!

Ok, I had a look at the documentation for the CLI.

In the "ping-check" the parameter to add to do this should be "min-success".

"Ping-check" It's currently only set to "max-fails" which is why I believe it does the "ping/pong" effect between the two WAN. Correct?

Thank you in advance!

 

Link to comment
Share on other sites

  • 0
21 час назад, Axo92 сказал:

Thanks!

Ok, I had a look at the documentation for the CLI.

In the "ping-check" the parameter to add to do this should be "min-success".

"Ping-check" It's currently only set to "max-fails" which is why I believe it does the "ping/pong" effect between the two WAN. Correct?

Thank you in advance!

 

Yes, correct, ping check is used to determine state of interfaces. Playing around with min-success/max-fails you can fine tune its sensitivity

Edited by r13
  • Thanks 1
Link to comment
Share on other sites

  • 0
1 hour ago, r13 said:

Yes, correct, ping check is used to determine state of interfaces. Playing around with min-success/max-fails you can fine tune its sensitivity

Thank you very much for your availability. 

Unfortunately it doesn't work as it should, the min-success option isn't saved.

Initial situation, without any ping check

IMG_20221231_141439.thumb.jpg.be191775a44e0f50440cbba4a9e6ec57.jpg

Profile creation, without errors

IMG_20221231_141550.thumb.jpg.18f548f24262368dcce1bad0b59c1538.jpg

Viewing the created profile, unfortunately missing the min-success option

IMG_20221231_141743.thumb.jpg.8818ca8cd13bf66edaffd265f25d273e.jpg

Association of the profile to the interface

IMG_20221231_141814.thumb.jpg.d4c183e912a9ea5a9dba4e748823a363.jpg

I don't know if it's my mistake, or if there's a bug at the firmware level. 

In any case without the min-success option nothing works.

 

Thanks again and happy new year!

Link to comment
Share on other sites

  • 0
30 минут назад, Axo92 сказал:

Unfortunately it doesn't work as it should, the min-success option isn't saved.

It may be counterintuitive, but the show ping-check command show the status of the ping-check profile. I don't know why it doesn't show the configured min-success value, but you can verify that it is stored in the configuration by executing show rc ping-check :

(config)> show rc ping-check
(config)> ping-check profile test
PingCheck::Client: Profile "test" has been created.
(config-pchk)> min

      min-success - set the min success count

(config-pchk)> min-success 8
PingCheck::Profile: "test": uses 8 success count for enabling interface.
(config-pchk)> max-

        max-fails - set the maximum fail count

(config-pchk)> max-fails 3
PingCheck::Profile: "test": uses 3 fail count for disabling interface.
(config-pchk)> mode icmp
PingCheck::Profile: "test": uses icmp mode.
(config-pchk)> host 1.2.3.4
PingCheck::Profile: "test": add host "1.2.3.4" for testing.
(config-pchk)> exit
Core::Configurator: Done.
(config)> show rc ping-check

           config, name = ping-check:
               config, name = profile:
                     name: test

                   config, name = host:
                         host: 1.2.3.4

                   config, name = mode:
                         mode: icmp

                   config, name = min-success:
                        count: 8

                   config, name = max-fails:
                        count: 3

(config)> show ping-check

        pingcheck:
              profile: default

        pingcheck:
              profile: test

                hosts: 1.2.3.4

            max-fails: 3
                 mode: icmp


Generally, the show rc <...> command will print out a part of the current configuration (running-config) related to <...> (e.g. show rc interface Home)

  • Thanks 2
Link to comment
Share on other sites

  • 0
58 минут назад, Axo92 сказал:

Unfortunately it doesn't work as it should, the min-success option isn't saved.

You should explicitly save configured state by synchronous

copy running-config startup-config

or asynchronous

system configuration save

command.

"show ..." commands always return current active status, not configured values (but active values may be equal to configured ones).

To revise configured state use

show running-config

and to view a configuration saved to a persistent storage

more startup-config

 

  • Thanks 2
Link to comment
Share on other sites

  • 0

Thank you all, sorry I'm still a beginner with the cli...😅

I didn't know the "rc" option and how to make the configuration persistent.

Maybe it would be better to add the "min-success" field (like "max-fails" already there) in the WebUI to make the option more usable even for those who don't have read the entire cli manual 😁

Now I have to wait for a down of the ISP to understand if it works, since if I disconnect and reconnect the cable, the connection goes back to the Primary WAN without waiting for the set delay (equal to the multiplication between "min-success" and "update-interval")... perhaps no delay is expected when there is a physical break in the link.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...