Jump to content
  • 2

Настройка РРРоЕ и MTU


Sfut
 Share

Question

Сегодня провайдер без предупреждения перевел с IPoE на PPPoE. Настроил, но что то не нравится мне как оно работает. В связи с этим возникли вопросы, надеюсь на Вашу помощь.

1. Какое значение MTU ставить на PPPoE, достаточно того что устанавливается автоматом или лучше узнать у провайдера. Посмотрел в CLI установленное значение  -1200, не маловато ли? Значение MTU на PPPoE устанавливать в CLI?. В Вэб-конфигураторе вроде бы настроек нет.

2. Насколько меньше скорость при PPPoE по сравнению с IPoE, теоретически вроде бы совсем немного. А меня по результатам сегодняшнего вечера получается меньше процентов на 20, что как то совсем не радует.

Link to comment
Share on other sites

Recommended Posts

  • 0

Провайдеры Ростелеком и МТС. Подключение РРРоЕ. Сколько себя помню у меня MTU всегда было выставлено 1500. Лучше конечно выяснить у ТП провайдера.

По второму вопросу мне сказать нечего, так как с  IPoE  дела не имел никогда.

Edited by Fandor
Link to comment
Share on other sites

  • 0
3 минуты назад, Fandor сказал:

MTU всегда было выставлено 1500

Это то я так понимаю было выставлено на интерфейсе ISP, там на вкладке и поле соответствующее есть. А MTU на интерфейсе  РРРоЕ посмотреть можно только в  CLI, на вкладке PPPoE/VPN поля MTU нет.

Link to comment
Share on other sites

  • 0
1 минуту назад, Sfut сказал:

Это то я так понимаю было выставлено на интерфейсе ISP, там на вкладке и поле соответствующее есть.

Да.

 

1 минуту назад, Sfut сказал:

А MTU на интерфейсе  РРРоЕ посмотреть можно только в  CLI, на вкладке PPPoE/VPN поля MTU нет.

Всё правильно.

Link to comment
Share on other sites

  • 0
1 минуту назад, Fandor сказал:

на вкладке PPPoE/VPN поля MTU нет

Почему его разработчики не вынесли в Вэб, это значение настраивается автоматически?

Link to comment
Share on other sites

  • 0
4 минуты назад, Sfut сказал:

Почему его разработчики не вынесли в Вэб, это значение настраивается автоматически?

Видимо да, по крайней мере у меня они одни и те же.

Link to comment
Share on other sites

  • 0

Поднимайте mtu на ppoe интерфейсе на максимум и пингом с флагом запрета фрагментации ищите оптимальное значение раз автоматом так мало выставилось. Вообще должно настраиваться автоматом на 1492 насколько я помню при основном линке на 1500. Попробуйте для начала с этим значением. 

  • Thanks 1
  • Upvote 1
Link to comment
Share on other sites

  • 0
17 часов назад, r13 сказал:

Поднимайте mtu на ppoe интерфейсе на максимум и пингом с флагом запрета фрагментации ищите оптимальное значение

До этого пока руки не дошли, выберу время и сделаю. Но пока обратил внимание вот на что. Фрагмент startup-config, ip mtu 1492:

interface PPPoE0
    description "Internet хххххххххх"
    no ipv6cp
    lcp echo 30 3
    ipcp default-route
    ipcp name-servers
    ipcp dns-routes
    no ccp
    security-level public
    authentication identity хххххххххх
    authentication password ns3 ххххххххххххххххuW7Folfi2+
    ip mtu 1492
    ip global 1000
    ip tcp adjust-mss pmtu
    ip dhcp client dns-routes
    ip dhcp client name-servers
    connect via ISP
    up
Вывод команды show interface PPPoE0,  mtu: 1200

(config)> show interface PPPoE0

               id: PPPoE0
            index: 0
             type: PPPoE
      description: Internet хххххххххххх
   interface-name: PPPoE0
             link: up
        connected: yes
            state: up
              mtu: 1200
         tx-queue: 1000
          address: хх.ххх.ххх.ххх
             mask: 255.255.255.255
           global: yes
        defaultgw: yes
         priority: 1000
   security-level: public
        auth-type: none
           remote: ххх.ххх.х.х
           uptime: 939
       session-id: 61
             fail: no
              via: GigabitEthernet1
      last-change: 938.880118

Так и должно быть, это работает  "Автоподстройка TCP-MSS"?

Link to comment
Share on other sites

  • 0

Значит у вас все ок, и выставлено 1492

А в выводе какойто глюк.

Mss и Mtu в это разные вещи, так что авто подстройка mss не должна влиять на mtu

ЗЫ Просто проверьте пингом сколько реально пролезает

Edited by r13
Link to comment
Share on other sites

  • 0
29 минут назад, r13 сказал:

А в выводе какойто глюк

Похоже что нет.

Обмен пакетами с www.yandex.ru [77.88.55.55] с 1172 байтами данных:
Ответ от 77.88.55.55: число байт=1172 время=18мс TTL=53
Ответ от 77.88.55.55: число байт=1172 время=18мс TTL=53
Ответ от 77.88.55.55: число байт=1172 время=18мс TTL=53
Ответ от 77.88.55.55: число байт=1172 время=18мс TTL=53

Статистика Ping для 77.88.55.55:
    Пакетов: отправлено = 4, получено = 4, потеряно = 0
    (0% потерь)
Приблизительное время приема-передачи в мс:
    Минимальное = 18мсек, Максимальное = 18 мсек, Среднее = 18 мсек

C:\Users\User>ping www.yandex.ru -f -l 1173

Обмен пакетами с www.yandex.ru [77.88.55.55] с 1173 байтами данных:
Ответ от 192.168.1.1: Требуется фрагментация пакета, но установлен запрещающий флаг.
Требуется фрагментация пакета, но установлен запрещающий флаг.
Требуется фрагментация пакета, но установлен запрещающий флаг.
Требуется фрагментация пакета, но установлен запрещающий флаг.

Статистика Ping для 77.88.55.55:
    Пакетов: отправлено = 4, получено = 1, потеряно = 3
    (75% потерь)

Link to comment
Share on other sites

  • 0

Keenetic Ultra II v2.09(AAUX.2)A1 подключение по PPPoE. У провайдера mtu=1492.
 

interface PPPoE0

     ip mtu 1492
(config)> show interface PPPoE0

mtu: 1480
C:\Windows\System32>ping -t -f ya.ru -l 1480

Обмен пакетами с ya.ru [93.158.134.3] с 1480 байтами данных:
Требуется фрагментация пакета, но установлен запрещающий флаг.
Требуется фрагментация пакета, но установлен запрещающий флаг.
C:\Windows\System32>ping -t -f ya.ru -l 1452

Обмен пакетами с ya.ru [93.158.134.3] с 1452 байтами данных:
Ответ от 93.158.134.3: число байт=1452 время=8мс TTL=56
Ответ от 93.158.134.3: число байт=1452 время=8мс TTL=56

 

Link to comment
Share on other sites

  • 0

А это для IPoE подключения. mtu=1500

interface GigabitEthernet0/Vlan2

     ip mtu 1500
show interface GigabitEthernet0/Vlan2

mtu: 1500

Реально имеем:

C:\Windows\System32>ping -t -f 172.x.x.x -l 1472

Обмен пакетами с 172.x.x.x по с 1472 байтами данных:
Ответ от 172.x.x.x: число байт=1472 время=10мс TTL=252
Ответ от 172.x.x.x: число байт=1472 время=9мс TTL=252

 

Link to comment
Share on other sites

  • 0

Странность в том что судя по документации если укзано конкретное значение mtu для интерфейса, то оно и используется. А тут получается несмотря на явное указание mtu срабатывает автонастройка. 

Link to comment
Share on other sites

  • 0

Явно указать значение mtu для PPPoE можно указать только в CLI и я его не задавал. Получается что значение в конфиге либо задано по умолчанию, либо вычисляется по значению mtu GigabitEthernet1.

Edited by Sfut
Link to comment
Share on other sites

  • 0
5 минут назад, r13 сказал:

А если чере cli задать поменяется значение для текущей сессии или нет? 

Проверил, значение изменяется.

Link to comment
Share on other sites

  • 0

А теперь проверяем пингом, если не проходит значит такое mtu на стороне провайдера. 

Зы смущает что вы сказали что у вас в start-up конфиге mtu указано, следовательно mtu для интерфейса указан явно, но почему то не применяется. 

Edited by r13
Link to comment
Share on other sites

  • 0

Установил  mtu 1492 и вот результат :-D

C:\Users\User>ping www.yandex.ru -f -l 1464

Обмен пакетами с www.yandex.ru [77.88.55.66] с 1464 байтами данных:
Ответ от 77.88.55.66: число байт=1464 время=19мс TTL=53
Ответ от 77.88.55.66: число байт=1464 время=19мс TTL=53
Ответ от 77.88.55.66: число байт=1464 время=21мс TTL=53
Ответ от 77.88.55.66: число байт=1464 время=19мс TTL=53

Статистика Ping для 77.88.55.66:
    Пакетов: отправлено = 4, получено = 4, потеряно = 0
    (0% потерь)
Приблизительное время приема-передачи в мс:
    Минимальное = 19мсек, Максимальное = 21 мсек, Среднее = 19 мсек

C:\Users\User>ping www.yandex.ru -f -l 1465

Обмен пакетами с www.yandex.ru [77.88.55.66] с 1465 байтами данных:
Ответ от 192.168.1.1: Требуется фрагментация пакета, но установлен запрещающий флаг.
Требуется фрагментация пакета, но установлен запрещающий флаг.
Требуется фрагментация пакета, но установлен запрещающий флаг.
Требуется фрагментация пакета, но установлен запрещающий флаг.

Статистика Ping для 77.88.55.66:
    Пакетов: отправлено = 4, получено = 1, потеряно = 3
    (75% потерь)

Link to comment
Share on other sites

  • 0
1 минуту назад, r13 сказал:

Значит победа, хадкодим на интерфейсе и радуемся

А чему радоваться, причина не найдена. По замыслу разработчиков, если настройка не вынесена в Вэб, то настраиваться правильно должно автоматически, а это в моем случае не так. У большинства же настраивается правильно. К тому же что настроено у провайдера неизвестно.

 

7 минут назад, Fandor сказал:

Работать лучше стало или проблемы всё равно присутствуют?

На уровне погрешности даже хуже, максимальная скорость упала на 0,1 Мбит :-D

Link to comment
Share on other sites

  • 0

Ога. Получается из startup-config значения не подтягиваются?

(config)> interface PPPoE0
(config-if)> ip mtu 1492
Network::Interface::Base: "PPPoE0": static MTU is 1492.
C:\Windows\System32>ping -t -f ya.ru -l 1464

Обмен пакетами с ya.ru [93.158.134.3] с 1464 байтами данных:
Ответ от 93.158.134.3: число байт=1464 время=7мс TTL=56
Ответ от 93.158.134.3: число байт=1464 время=8мс TTL=56

 

Link to comment
Share on other sites

  • 0
(config-if)> show interface PPPoE0

               id: PPPoE0
             type: PPPoE
...
   interface-name: PPPoE0
             link: up
        connected: yes
            state: up
              mtu: 1492
...

На ПК
Обмен пакетами с ya.ru [213.180.193.3] с 1464 байтами данных:
Ответ от 213.180.193.3: число байт=1464 время=17мс TTL=56
Ответ от 213.180.193.3: число байт=1464 время=17мс TTL=56

config
interface PPPoE0
...
    ip mtu 1492
...
    ip tcp adjust-mss pmtu
...
    connect via ISP
    up

v2.09(AAFG.2)A1 , для информации в config возможно остатки от старой конфигурации, так как включено "adjust-mss pmtu" в WEB для данного соединения.

MTU=1464+28=1492

В догонку

32	5.918183	хх.хх.хх.18	213.180.193.3	ICMP	1514	Echo (ping) request  id=0x0001, seq=26/6656, ttl=63 (reply in 33)

Frame 32: 1514 bytes on wire (12112 bits), 1514 bytes captured (12112 bits)
Ethernet II, Src: ZyxelCom_хх:хх:хх (хх:хх:хх:хх:хх:хх), Dst: HuaweiTe_хх:хх:хх (хх:хх:хх:хх:хх:хх)
PPP-over-Ethernet Session
    0001 .... = Version: 1
    .... 0001 = Type: 1
    Code: Session Data (0x00)
    Session ID: 0x2336
    Payload Length: 1494
Point-to-Point Protocol
Internet Protocol Version 4, Src: хх.хх.хх.18, Dst: 213.180.193.3
Internet Control Message Protocol

33	5.934868	213.180.193.3	хх.хх.хх.18	ICMP	1514	Echo (ping) reply    id=0x0001, seq=26/6656, ttl=57 (request in 32)

Frame 33: 1514 bytes on wire (12112 bits), 1514 bytes captured (12112 bits)
Ethernet II, Src: HuaweiTe_хх:хх:хх (хх:хх:хх:хх:хх:хх), Dst: ZyxelCom_хх:хх:хх (хх:хх:хх:хх:хх:хх)
PPP-over-Ethernet Session
    0001 .... = Version: 1
    .... 0001 = Type: 1
    Code: Session Data (0x00)
    Session ID: 0x2336
    Payload Length: 1494
Point-to-Point Protocol
Internet Protocol Version 4, Src: 213.180.193.3, Dst: хх.хх.хх.18
Internet Control Message Protocol

 

Edited by vasek00
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...