Jump to content
  • 5

Wireguard Server & Client


El Ruso
 Share

Question

Recommended Posts

  • 0
2 часа назад, Mamay сказал:

Пользуйте entware и будет Вам счастье. Тут уже писалось об этом...

На прошивке 3.1 это возможно, там ядро 4.9. Остальным нужен Entware.

Link to comment
Share on other sites

  • 0
3 минуты назад, Kiborg_Man сказал:

На прошивке 3.1 это возможно, там ядро 4.9. Остальным нужен Entware.

Ядро 4.9 обязательное условие независимо entware или нет.

Link to comment
Share on other sites

  • 0

@Le ecureuil Клиентский вариант, кинетик соединяется с vps  у меня завелся.

А вот серверный вариант не хочет, пытаюсь соединить 2 кинетика по wg, не соединяются(телефон тоже не соединяется)

Судя по дампу трафика оба друг друга видят, но соединения тем ни менее нет.

Далее селфтесты.

 

Link to comment
Share on other sites

  • 0

И еще @eralde @Le ecureuil сейчас нет информации о рабочем порте wireguard назначенном для интерфейса на кинетике.

Это можно узнать только через утилиту wg в entware.

Не плохо бы вывести эту информацию в cli/web

  • Upvote 2
Link to comment
Share on other sites

  • 0
В 13.10.2019 в 18:43, r13 сказал:

И еще @eralde @Le ecureuil сейчас нет информации о рабочем порте wireguard назначенном для интерфейса на кинетике.

Это можно узнать только через утилиту wg в entware.

Не плохо бы вывести эту информацию в cli/web

Вывод сделали, появится в следующей сборке.

  • Thanks 2
Link to comment
Share on other sites

  • 0
В 13.10.2019 в 18:29, r13 сказал:

@Le ecureuil Клиентский вариант, кинетик соединяется с vps  у меня завелся.

А вот серверный вариант не хочет, пытаюсь соединить 2 кинетика по wg, не соединяются(телефон тоже не соединяется)

Судя по дампу трафика оба друг друга видят, но соединения тем ни менее нет.

Далее селфтесты.

 

Все из-за нестандартного порта сервера.

Теперь он виден в cli и в web, и все нормально работает.

  • Thanks 3
Link to comment
Share on other sites

  • 0
7 hours ago, Le ecureuil said:

Вроде все готово, проверяйте еще разок :)

у меня не хочет в тоннель проборасываться локалка за роутером, сам роутер по локальному адресу я вижу, а дальше - нет

делаю как это описано для wireguard - добавлением внутренней сети в allowed ips, но вэб-интерфейс ругается и не даёт добавить вторую запись

 

wg.PNG.b023a15b87f7e719283e9ae178ed5161.PNG

обнаружил кнопку add address )

добавил туда свою сеть, но всё равно не работает

Edited by koshak
Link to comment
Share on other sites

  • 0
5 минут назад, koshak сказал:

у меня не хочет в тоннель проборасываться локалка за роутером, сам роутер по локальному адресу я вижу, а дальше - нет

делаю как это описано для wireguard - добавлением внутренней сети в allowed ips, но вэб-интерфейс ругается и не даёт добавить вторую запись

 

wg.PNG

Надо нажать на синюю надпись справа от поля и ввести туда вторую подсеть

Link to comment
Share on other sites

  • 0
1 minute ago, eralde said:

Надо нажать на синюю надпись справа от поля и ввести туда вторую подсеть

ага, спасибо, я уже увидел )))

но доступа всё равно нет, что-то ещё надо сделать?

Link to comment
Share on other sites

  • 0

при подключении к интернету по wireguard через удалённый сервер не работает половина сайтов, этот же конфиг с телефона или компьютера проблем с сайтами не вызывает, подключение через л2тп на сервере у того же хостера тоже работает без проблем(ну кроме того что рвётся периодически)

мту от 1280 до 1500 испробованы

Edited by koshak
Link to comment
Share on other sites

  • 0
В 18.10.2019 в 19:58, koshak сказал:

при подключении к интернету по wireguard через удалённый сервер не работает половина сайтов, этот же конфиг с телефона или компьютера проблем с сайтами не вызывает, подключение через л2тп на сервере у того же хостера тоже работает без проблем(ну кроме того что рвётся периодически)

мту от 1280 до 1500 испробованы

Попробуйте включить adjust mss.

Link to comment
Share on other sites

  • 0
1 минуту назад, koshak сказал:

как?

interface WireguardX ip tcp adjust-mss {pmtu|mss-value}

Link to comment
Share on other sites

  • 0

@Le ecureuil

Серверный вариант еще не обкатывали?

у меня он не работает и ведет себя как то странно.

Соединяю сервер 1910 и клиент 1710

На обоих включаю захват пакетов на wg интерфейсе для контроля

Запускаю пинг с сервера на клиента.

Все хорошо, пинг бегает.

Как только инициирую активность с клиента (в тесте запускаю скоростемерку из intelliquos) так сервер судя по захвату перестает видеть ответы на пинги, на клиенте пинги и ответы тем временем все на месте.

Селфтесты/захваты в следом

 

Link to comment
Share on other sites

  • 0
5 минут назад, koshak сказал:

pmtu тоже не работает

По технике, работает, соответсвующие правила в iptables появляются, и если смотреть пакеты в захвате, то mss выставляется. А вот почему не работает вопрос...

Link to comment
Share on other sites

  • 0

у меня серверный вариант работает, подключаюсь снаружи к роутеру - интернет и локалка без проблем, 1810

у друзей 2 ультры2 через всю москву подключены по вг, канал выдаёт тарифные 100 мегабит

  • Thanks 1
Link to comment
Share on other sites

  • 0
В 21.10.2019 в 19:19, Le ecureuil сказал:

Попробуйте включить adjust mss.

А сразу реализовать в веб-интерфейсе нельзя было? Это ведь весьма полезная функция.

Когда будет поддержка IPv6 в клиенте Wireguard?

Link to comment
Share on other sites

  • 0
5 часов назад, Leeman сказал:

А сразу реализовать в веб-интерфейсе нельзя было? Это ведь весьма полезная функция.

Это ведь альфа. Сперва допилить функционал, а уже потом рюшечки... 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...