Jump to content
  • 0

IPTV OTT и Extra II


hellonow
 Share

Question

@ndm в последнее время стала отваливаться трансляция full hd каналов, такое ощущение, что есть потеря unicast пакетов. Со стороны провайдера, со стороны оператора iptv ott - говорят, что все хорошо, проблем нет. Следующие этап проверка роутера. Снял self-testы в момент отвалов (ниже).

Не подскажите, есть что подозрительное в селфе? Или лучше диагностику делать при помощи захвата сетевых пакетов?

Extra II 2.09.A.6.0-0 - конфиг настроен с нуля.

 

 

Edited by enpa
  • Thanks 1
Link to comment
Share on other sites

20 answers to this question

Recommended Posts

  • 0
23 минуты назад, enpa сказал:

в последнее время стала отваливаться трансляция full hd каналов, такое ощущение, что есть потеря мультикаст пакетов

На 2.09.A.5 проблема была? В версии A.6 действительно исправляли обработку multicast в режиме ppe software.

Link to comment
Share on other sites

  • 0
33 минуты назад, enpa сказал:

@ndm не замечал, в А.6 стала проявляться. 

А нагрузка на проц во время просмотра?

Оно отваливается (пока не переподключишь канал) или подсыпается просто?

Link to comment
Share on other sites

  • 0

@ndm загрузка ЦП разная, от 2% до 50% (бывает до 100%, если что-то качаю через Transmission), скорость загрузки 31.82 Мбит/с во время переключения каналов Full HD (сам канал до 100 мбит). 

Подсыпается, появляется черный экран во время трансляции, потом картинка сама восстанавливается - совершенно рандомно. Даже когда ЦП не очень загружен.

Link to comment
Share on other sites

  • 0

@ndm замечу, что проверял и с другими IPTV OTT - такая же проблема и у других поставщиков. При этом интернет работает стабильно, потерь нет до ресурсов. ТВ перепрошил, перенастроил навсякий (чтобы исключить ТВ). 

Edited by enpa
Link to comment
Share on other sites

  • 0

Это тогда у вас не мультикаст, и по своей природе нет гарантированной полосы пропускания, пакеты вполне могут теряться на любом участке.

  • Thanks 2
Link to comment
Share on other sites

  • 0

@r13 совершенно верно. Видимо так совпало, с выходом А.6, начались проблемы на стороне одного из провайдеров - поставщиков.Я решил не проходить мимо и описать проблему, тем более в посл версиях вносились изменения в ядро.

Edited by enpa
Link to comment
Share on other sites

  • 0

enpa

Multicast у нас на стенде прошел проверку целостности пайлоада после передачи с сервера на клиента (если говорить о А.6), поэтому сначала не разглядели что речь идет о OTT источнике (unicast).

Все текущие изменения по ядру приняты в ветку stable для 3.2 (маинтайнер Ben Hutchings) и вошли в LongTerm Debian. Это не 100% гарантия, иногда бывают осечки.

Чтобы исключить смену условий и окружения, не могли бы вы прошить предыдущую сборку и не меняя настроек, попробовать воспроизвести эту проблему на месте? Спасибо.

 

  • Thanks 1
Link to comment
Share on other sites

  • 0

@Padavan Установил Extra II 2.09.A.5.0-2, поймал self-testом моменты, когда картинка сыпалась, зависала картинка. В офисе, с другим провайдером, поднял OTT, только уже с роутером Lite III rev.A с А.6 + приставка Dune 102 - ловил фризы на Full HD каналах.

Ниже прикрепляю self-test от EII.

Link to comment
Share on other sites

  • 0

если больше фризит, чем сыпет, то скорее tcp пересобирает/ретрансмитит .. сэлф тут ничего не покажет в этом плане. дамп нужен. и весь ppe вырезать в повторном тесте.

Link to comment
Share on other sites

  • 0

Спасибо.

Нужно было выяснить что нет регрессии, поскольку тестировать OTT из глобальной сети в других условиях просто нереально, трасса будет совсем иной, как и результаты. Да и у провайдеров приоритеты на разный тип трафика (а также параметры DPI) разные.

Link to comment
Share on other sites

  • 0

Понял Вас, тогда буду копать в сторону OTT поставщика и провайдера, хоть те и заявили, что с их стороны все ок. Мне главное было понять и услышать со стороны команды разработчиков прошивки, что проблема не в микропрограмме. Тем более так все совпало, что проблемы начались с выходом А.6, где были внесены изменения в ядро. Лучше лишний раз перестраховаться, т.к. версия отладочная. Спасибо!

Отправлено с моего thl 5000 через Tapatalk

Link to comment
Share on other sites

  • 0

enpa у вас хоть

в последнее время стала отваливаться трансляция full hd каналов, такое ощущение, что есть потеря unicast пакетов. Со стороны провайдера, со стороны оператора iptv ott - говорят, что все хорошо, проблем нет.

У меня было замирание и рассыпание картинки на ТВ (просмотр кабельного канала) когда на двух роутерах (один из них ExtII) было включено IGMP proxy, ТВ просто подключен к LAN сети на ExtII. "Пакетики по сети" приводили в ступор ПО телевизора от этого, при отключении на ExtII - IGMP proxy все приходило в норму. Схема была, при том что в момент проверки на ExtII WAN был отключен вообще (режим основной) :  Инет ------- KII (LAN) ---- (LAN)ExtII ------- Инет

Edited by vasek00
  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...