Jump to content

Recommended Posts

2 часа назад, exeigor сказал:

Пробовал ставить данную версию на Keenetic Viva (KN-1910), но Adguard Home не стартует. Эта версия вообще рабочая 0.106.3-1 ? 

 

https://bin.entware.net/mipselsf-k3.4/keenetic/archive/adguardhome-go_v0.106.3-1_mipsel-3.4.ipk

 

 

А к чему эта некрофилия? 107.37 уже давным давно доступна для установки, 107.44 на подходе

Link to comment
Share on other sites

17 часов назад, Denis P сказал:

А к чему эта некрофилия? 107.37 уже давным давно доступна для установки, 107.44 на подходе

Да дело в том, что при каждой настройки конфигурации с веб-интерфейса цп упирается в полотом и DNS сервер ломается. Может сутки поработать и сломаться. Поэтому я хотел понизить версию как это ранее писали. Только вот что-то не запускается 

Link to comment
Share on other sites

3 часа назад, exeigor сказал:

Да дело в том, что при каждой настройки конфигурации с веб-интерфейса цп упирается в полотом и DNS сервер ломается. Может сутки поработать и сломаться. Поэтому я хотел понизить версию как это ранее писали. Только вот что-то не запускается 

Стоит начать с изучения журнала, лежит в /opt/var/log/AdGuardHome.log

Есть предположение что у вас просто заканчивается озу, agh в этом плане довольно прожорлив. Выключайте zram, включайте swap и проверяйте

Link to comment
Share on other sites

Всех приветствую! С недавних пор, на ПК ютуб начал выбивать баннер о том, что якобы "нельзя использовать блокировщики рекламы". добавление списка "Adblock Warning Removal List" не решило проблему.

Есть варианты или смириться?

Link to comment
Share on other sites

  • 2 weeks later...

Всем привет. Форумчане, кто использует для просмотра кино Lampa, справляется ли AdGuardHome c рекламой?

  • Upvote 1
Link to comment
Share on other sites

  • 2 weeks later...
В 28.02.2024 в 08:31, SP1R1T сказал:

Всем привет. Форумчане, кто использует для просмотра кино Lampa, справляется ли AdGuardHome c рекламой?

С какой рекламой? Это ж п/р/тский сервис (я пользуюсь).

Link to comment
Share on other sites

  • 2 weeks later...

Keenetic 2710

После обновления на прошивку версии Версия ОС4.1.2

Перестал работать AGH

 

Скрытый текст

BusyBox v1.36.1 (2023-09-01 19:09:45 UTC) built-in shell (ash)

~ # /opt/etc/init.d/S99adguardhome start
 Starting AdGuardHome...              done.
~ # opkg update
Downloading http://bin.entware.net/aarch64-k3.10/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/entware
Downloading http://bin.entware.net/aarch64-k3.10/keenetic/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/keendev
~ # opkg install adguardhome-go
Upgrading adguardhome-go on root from v0.107.37-1 to v0.107.44-1...
Downloading http://bin.entware.net/aarch64-k3.10/adguardhome-go_v0.107.44-1_aarc                   h64-3.10.ipk
Configuring adguardhome-go.
Collected errors:
 * resolve_conffiles: Existing conffile /opt/etc/hosts is different from the con                   ffile in the new package. The new conffile will be placed at /opt/etc/hosts-opkg                   .
~ # /opt/etc/init.d/S99adguardhome stop
 Checking AdGuardHome...              dead.
~ # opkg install adguardhome-go
Package adguardhome-go (v0.107.44-1) installed in root is up to date.
~ # opkg install adguardhome-go
Package adguardhome-go (v0.107.44-1) installed in root is up to date.
~ # /opt/etc/init.d/S99adguardhome start
 Starting AdGuardHome...              done.
~ #
 

Обновил до последней версии его, но вот, всё равно.

Если дать команду на запуск, оно стартует, но потом сразу падает.

Link to comment
Share on other sites

13 часа назад, Saymer сказал:

Перестал работать AGH

Посмотрите как запускается AGH в стартовом скрипте и аналогично запустите в консоли, чтобы увидеть вывод об ошибке. В случае AGH:

AdGuardHome -w /opt/etc/AdGuardHome -l /opt/var/log/AdGuardHome.log --pidfile /opt/var/run/AdGuardHome.pid --no-check-update

Чаще всего AGH жалуется на изменившуюся схему конфигурационного файла. Она там часто меняется от версии к версии.

  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...

Не знаю в какой момент, но как-то в списке клиентов AGH появились адреса клиентов в формате ipv6. Подозреваю, что из-за этого не работают исключения для постоянных клиентов, раньше в качестве идентификатора клиента использовал его IP и особые настройки для него работали, сейчас, даже если в качестве идентификатора указываю этот IPv6 то клиент все равно фильтруется согласно глобальных настроек. Как исправить или как вернуть клиентов в формате обычного IP?

AdGuard v0.107.44

 

Скрытый текст

screenshot 2024-03-31 15-15-12 001.png

 

Edited by saqwe
Link to comment
Share on other sites

1 час назад, saqwe сказал:

Не знаю в какой момент, но как-то в списке клиентов AGH появились адреса клиентов в формате ipv6. Подозреваю, что из-за этого не работают исключения для постоянных клиентов, раньше в качестве идентификатора клиента использовал его IP и особые настройки для него работали, сейчас, даже если в качестве идентификатора указываю этот IPv6 то клиент все равно фильтруется согласно глобальных настроек. Как исправить или как вернуть клиентов в формате обычного IP?

AdGuard v0.107.44

 

  Показать содержимое

screenshot 2024-03-31 15-15-12 001.png

 

удалил netfilter и поддержку ipv6 из компонентов keenetic и в списке клиентов стало как раньше, но вот почему при идентификации клиента по ipv6 не работают для него особые настройки не понятно

Link to comment
Share on other sites

Логин и пароль от администратора меняется в yaml, а также и порт с последующей перезагрузкой адгуард, так?

Link to comment
Share on other sites

7 часов назад, Kazantsev сказал:

Логин и пароль от администратора меняется в yaml, а также и порт с последующей перезагрузкой адгуард, так?

Порт да, пароль врядли

Link to comment
Share on other sites

23 минуты назад, Kazantsev сказал:

а пароль как менять?

Переименовать конф файл AdGuardHome.yaml например в AdGuardHome.yaml.orig

Далее просто запустить ./AdGuardHome он посчитает что первый раз и будет на порту IP:3000. Повторите первичную настройку (вам важен только пароль). Далее дело техники как из двух конфигов нового AdGuardHome.yaml и AdGuardHome.yaml.orig сделать один текущий.

  • Upvote 1
Link to comment
Share on other sites

17 часов назад, vasek00 сказал:

Переименовать конф файл AdGuardHome.yaml например в AdGuardHome.yaml.orig

Далее просто запустить ./AdGuardHome он посчитает что первый раз и будет на порту IP:3000. Повторите первичную настройку (вам важен только пароль). Далее дело техники как из двух конфигов нового AdGuardHome.yaml и AdGuardHome.yaml.orig сделать один текущий.

понял, а нужно ли прописывать в интернет фильтре  адрес моего роутера 192.168.10.1 и порт 53 для того чтобы днс шли?
Некоторые пишут нужно, а некоторые не нужно, как лучше?

Link to comment
Share on other sites

Народ, подскажите пожалуйста:

имеется Кинетик Гига III (черный) старенький но работает без нареканий, версия KeeneticOS: 3.5.10

Поставил на NAS Synology AdguardHome, macvlan, адрес в сети 192.168.1.250

Прописал DNS в проводных подключениях провайдера: адрес 192.168.1.250

Отметил галочкой Игнорировать DNS

Все вроде нормально, но в статистике ADguard все запросы идут только с адреса роутера 192.168.1.1

Что я делаю не так, ведь от каждого устройства должен идти запрос!!!

Снимок экрана 2024-04-09 в 14.33.04.png

Снимок экрана 2024-04-09 в 14.33.30.png

Link to comment
Share on other sites

Posted (edited)
46 минут назад, Kazantsev сказал:

Некоторые пишут нужно, а некоторые не нужно, как лучше?

Вопрос :

- для чего вы поставили AGH или чего хотели получить

- зачем в прошивке используют фильтры

После этого думаю вопрос сам отпадет

Edited by vasek00
Link to comment
Share on other sites

8 минут назад, vasek00 сказал:

Вопрос :

- для чего вы поставили AGH или чего хотели получить

- зачем в прошивке используют фильтры

После этого думаю вопрос сам отпадет

Ради интереса, ну и в журнал записывается ресурсы которые посещают с устройств)

Ради этого и DOT/DOH сервера adguard

Edited by Kazantsev
Link to comment
Share on other sites

  • 2 weeks later...

привет ребят, такой вопрос к вам, может кто-то делал...

задача перенести adguardhome на homeassistant OS на proxmox

настройки обсолютно идентичные, что и на роутере, но не работает

как я понял, он не может подключиться к DNS (это если настройки как тут описано)

но если убрать галочку игнорировать DNS, все начинает работать, но естественно не все запросы идут через адгуард (половина через провайдера, половина через адгуард)

вопрос вот в чем, как мне заставить adguard на HAOS сразу выходить в инет? (повторяю настройки аналогичны, что описаны тут, на роутере все работает(на данный момент стоит на роутере))

 

 

Link to comment
Share on other sites

50 минут назад, BYNC сказал:

Добрый день! Подскажите как обновить AGH вручную? на entware лижет старая версия и никто ее не хочет обновлять.

Идем на https://github.com/AdguardTeam/AdGuardHome/releases находим или выбираем то что вам надо AdGuard Home v0.108.0-b.54 Pre или AdGuard Home v0.107.48 Latest. Копируем к себе куда угодно, из данного архива вам нужен один единственный файл AdGuardHome (распаковать на Win можно rar). Далее его помещаем в то место где у вас находится установленный AdGuardHome (путем замены на новый, предварительно если хотите можете сохранить старый файл). Ставим права на cскопированный если нужно "chmod 755 AdGuardHome".

Из пакета Entware :

- сам файл AdGuardHome находится в /opt/bin, меняем его файл на новый AdGuardHome

- файл скрипта на запуск /opt/etc/init.d/S99adguardhome

- файл конф. /opt/etc/AdGuardHome/adguardhome

После всего перезапуск сервиса "S99adguardhome restart" или "S99adguardhome stop" а потом "S99adguardhome start"

Для ARM проца - AdGuardHome_linux_arm64.tar.gz  или для mipsle cвой ******mipsle***.

Edited by vasek00
Link to comment
Share on other sites

3 часа назад, ops244 сказал:

задача перенести adguardhome на homeassistant OS на proxmox

настройки обсолютно идентичные, что и на роутере, но не работает

как я понял, он не может подключиться к DNS (это если настройки как тут описано)

но если убрать галочку игнорировать DNS, все начинает работать, но естественно не все запросы идут через адгуард (половина через провайдера, половина через адгуард)

вопрос вот в чем, как мне заставить adguard на HAOS сразу выходить в инет? (повторяю настройки аналогичны, что описаны тут, на роутере все работает(на данный момент стоит на роутере))

 

Сервис_AGH----LAN-----Роутер-----Интернет-----

На роутере зарег.устройство на котором развернут AGH, на нем указываем шлюзом IP роутера, т.е. default маршрут на роутер. В настройках AGH раздел DNS указываем нужные "Upstream DNS-серверы", в поле "Bootstrap DNS-серверы" указать например IP - 208.67.222.222.

В настройках DHCP сервера для клиентов указать "IP_Сервис_AGH".

Подправить конф файл

http:
...
   address: IP_Cервис_AGH:8080
...
dns:
  bind_hosts:
    - IP_сервис_AGH
    - 127.0.0.1
  port: 53
...

Клиент делает запрос на "IP_Cервис_AGH:53", далее уже сам AGH на указанные "Upstream DNS-серверы" за счет своего default маршрута на роутер и далее в интернет.

  • Confused 1
Link to comment
Share on other sites

3 минуты назад, MDP сказал:

А как можно добавить в AGH  srv запись?

например type=srv _vlmcs._tcp.server.local

Это не то - https://github.com/AdguardTeam/AdGuardHome/issues/2533 смотрим на dnsrewrite и

https://github.com/AdguardTeam/AdGuardHome/wiki/Hosts-Blocklists#dnsrewrite посмотреть весь раздел про применение dnsrewrite

Цитата

Доступно начиная с v0.105.0.

В. dnsrewriteмодификатор ответа позволяет заменить содержание ответа к DNS-запросу для соответствующих хостов. Правила с dnsrewrite модификатор ответа имеют более высокий приоритет, чем другие правила в AdGuard Home.

Кратковой синтаксис - это:

$dnsrewrite=1.2.3.4
$dnsrewrite=abcd::1234
$dnsrewrite=example.net
$dnsrewrite=REFUSED
Ключевые слова должны быть во всех кепках (например. NOERROR). Ключевое слово переписывает принимать приоритет над другим и приведет к пустому ответу с соответствующий код ответа.
 
и так далее ....
 

В правилах

Цитата

Go to AdGuardHome > Filters > Custom Filtering Rules and add appropriate entries

  • ||subdomain.domain.ext^$dnsrewrite=NOERROR;A;W.X.Y.Z (private IP is acceptable)5
  • ||_acme-challenge.subdomain.domain.ext^$dnsrewrite=NOERROR;TXT;challenge-txt, where challenge-txt is from the output of certbot command above.

 

  • Thanks 1
Link to comment
Share on other sites

Спустя некоторое время использования заметил такую проблему, не добавляются умные устройства из умного дома из-за функции opkg dns-override, как только я ввожу команду no opkg dns-override, так сразу умные устройства с 0 подключаются.

В итоге чтобы подключить умное устройство, мне приходится набирать no opkg dns  override и только после этого новое устройство для умного дома добавляется, в чём проблема, можно ли добавлять умные устройства без no opkg dns override ?

Link to comment
Share on other sites

1 час назад, Kazantsev сказал:

Спустя некоторое время использования заметил такую проблему, не добавляются умные устройства из умного дома из-за функции opkg dns-override, как только я ввожу команду no opkg dns-override, так сразу умные устройства с 0 подключаются.

В итоге чтобы подключить умное устройство, мне приходится набирать no opkg dns  override и только после этого новое устройство для умного дома добавляется, в чём проблема, можно ли добавлять умные устройства без no opkg dns override ?

Не вижу ни каких проблем или что то подобное если мы речь ведем об AGH. Доп сегмент 2.4 для умных устройст. Для подключения нового беру планшет подкючаю его к этому сегменту, беру устройство и подкючаю его через моб.пгиложение на планшете. Далее на роутере регистрирую его мас- IP для данного сегмента. В настройках на роутере на данном сегменте указан адрес роутера основного сегмента на котором весит AGH.

Link to comment
Share on other sites

6 минут назад, vasek00 сказал:

Не вижу ни каких проблем или что то подобное если мы речь ведем об AGH. Доп сегмент 2.4 для умных устройст. Для подключения нового беру планшет подкючаю его к этому сегменту, беру устройство и подкючаю его через моб.пгиложение на планшете. Далее на роутере регистрирую его мас- IP для данного сегмента. В настройках на роутере на данном сегменте указан адрес роутера основного сегмента на котором весит AGH.

не понял, то есть в веб интерфейсе нужно перекинуть умный дом в приоритет подключений, так?

Link to comment
Share on other sites

6 часов назад, vasek00 сказал:
Сервис_AGH----LAN-----Роутер-----Интернет-----

На роутере зарег.устройство на котором развернут AGH, на нем указываем шлюзом IP роутера, т.е. default маршрут на роутер. В настройках AGH раздел DNS указываем нужные "Upstream DNS-серверы", в поле "Bootstrap DNS-серверы" указать например IP - 208.67.222.222.

В настройках DHCP сервера для клиентов указать "IP_Сервис_AGH".

Подправить конф файл

http:
...
   address: IP_Cервис_AGH:8080
...
dns:
  bind_hosts:
    - IP_сервис_AGH
    - 127.0.0.1
  port: 53
...

Клиент делает запрос на "IP_Cервис_AGH:53", далее уже сам AGH на указанные "Upstream DNS-серверы" за счет своего default маршрута на роутер и далее в интернет.

привет, а где шлзом, тут? он и так указан (скрин 1)

upstream стоят

а где conf файл аддона лежит в homeassistant, там помоему нет доступа по умолчанию, но люди как-то ставят-же...

2024-04-23_21-22-14.png

Link to comment
Share on other sites

в общем, чего удалось добиться, поправил dns серверы где выше скрин на 192.168.1.2, теперь home assistant выходит в инет, все обновляет че ему надо, adguard работает, я думал проблема только в этом... но теперь роутер в инет не выходит xD при этом пишет подключен, скорость 10mbit откудато

кто-что думает?))

2024-04-23_22-19-23.png

2024-04-23_21-44-43.png

2024-04-23_21-57-44.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...