Jump to content
  • 0

802.11ac 160MHz - падение скорости


Dkray
 Share

Question

коллеги, поясните за нюансы работы 802.11ас . а именно - при выборе частот 20/40/80/160 в 5GHz диапазоне смартфон Huawei P30 pro подключается на 160MHz с заявленной скоростью 1560Mbps.  при  этом любые измерители скорости на устройстве меряют не больше 150 мегабит (100 вниз и 50 вверх, или поровну - по разному)

если установить частоты 20/40 - подключается на 866 мегабит и измерители их и показывают (450 вниз и 420 вверх)

как так?

 

спасибо!

UltraP30Speed.thumb.png.76d9cc70bbc692a56d68108a4140488c.png

Link to comment
Share on other sites

16 answers to this question

Recommended Posts

  • 1
Цитата

при создании WiFi-сети из 3х роутеров - есть возможность явным образом назначить подключение определенных клиентов к конкретным роутерам

Клиент сам выбирает лучший вариант, причем если поддерживает FT, то будет переключаться бесшовно. Нельзя прибить клиента к конкретной AP, потому что именно сам клиент выбирает кандидата в качестве AP. Единственный механизм со стороны AP - это WNM, но он лишь просит перейти, клиент все равно сам решает.

Link to comment
Share on other sites

  • 1

Huawei/Honor отличался тем, что если он по какой-то причине (например региональная блокировка) не подключается на максимальной ширине канала, то никак не извещает об этом точку доступа. Т.е. точка может считать что он подключен на 160, а на самом деле он половину этого диапазона не слушает. При подключении можно зайти в настройки самого телефона и там посмотреть на какой скорости он подключился. Если там явно скорость соответствующая 80 МГц - скорее всего это оно. В вашем случае можно также попробовать в настройках кинетика выбрать Украину и например 100 канал, у вас они разрешены и там может быть более свободно чем на двузначных каналах.

Link to comment
Share on other sites

  • 0
21 минуту назад, Dkray сказал:

коллеги, поясните за нюансы работы 802.11ас . а именно - при выборе частот 20/40/80/160 в 5GHz диапазоне смартфон Huawei P30 pro подключается на 160MHz с заявленной скоростью 1560Mbps.  при  этом любые измерители скорости на устройстве меряют не больше 150 мегабит (100 вниз и 50 вверх, или поровну - по разному)

если установить частоты 20/40 - подключается на 866 мегабит и измерители их и показывают (450 вниз и 420 вверх)

как так?

 

спасибо!

UltraP30Speed.thumb.png.76d9cc70bbc692a56d68108a4140488c.png

У меня на 2.4 Гц, при подключении смартфона samsung j4 при скорости подключения к роутеру 72 Мбит/с и тарифной скорости 100 Мбит/с замеры со смартфона показывают, что то около 50 Мбит/с. Другие андроид устройства показывают такой же результат. Такая проблема есть и на роутерах других производителей. Кстати, подобная тема на форуме уже обсуждалась.

Link to comment
Share on other sites

  • 0
15 minutes ago, Илья Картавенко said:

У меня на 2.4 Гц, при подключении смартфона samsung j4 при скорости подключения к роутеру 72 Мбит/с и тарифной скорости 100 Мбит/с замеры со смартфона показывают, что то около 50 Мбит/с. Другие андроид устройства показывают такой же результат. Такая проблема есть и на роутерах других производителей. Кстати, подобная тема на форуме уже обсуждалась.

у меня нет такой проблемы. в т.ч. на других роутерах. указанная скорость подключения к роутеру при выборе частот 20/40 (866 мегабит) соответствует результатам замеров. несоответствие наступает при подключении на 160 мегагерц. соответственно, пытаюсь выяснить - это можно исправить, или вернуться на 866 и забыть. тарифная скорость от провайдера - гигабит. 

Link to comment
Share on other sites

  • 0
7 минут назад, Dkray сказал:

у меня нет такой проблемы. в т.ч. на других роутерах. указанная скорость подключения к роутеру при выборе частот 20/40 (866 мегабит) соответствует результатам замеров. несоответствие наступает при подключении на 160 мегагерц. соответственно, пытаюсь выяснить - это можно исправить, или вернуться на 866 и забыть. тарифная скорость от провайдера - гигабит. 

У вас KN-1910?

Link to comment
Share on other sites

  • 0
1 minute ago, Илья Картавенко said:

У вас KN-1910?

KN-1910 - основное устройство. описанная проблема наблюдается на KN-1810 (Ultra)

Link to comment
Share on other sites

  • 0

Dkray

При установке полосы 160МГц выбираете канал под сплошной кусок спектра? Если сплошной кусок недоступен, web выставляет 80+80, это видно в running-config.

Под рукой два разных Intel 9260AC крайне плохо работают в 80+80. При этом хорошо работают в сплошном 160. Cкоро должны подойти Intel AX200, надо будет их глянуть. 

Наводящий вопрос - у вас ранее работал данный клиент на 160МГц с нормальными скоростями? Текущий микрокод, который управляет подстройкой rate_ctl чипа радио неизменный с 2.15. Если ранее были другие результаты, сообщите.

  • Upvote 1
Link to comment
Share on other sites

  • 0
1 minute ago, Padavan said:

При установке полосы 160МГц выбираете канал под сплошной кусок спектра? Если сплошной кусок недоступен, web выставляет 80+80, это видно в running-config.

Под рукой два разных Intel 9260AC крайне плохо работают в 80+80. Cкоро должны подойти Intel AX200, надо будет их глянуть. 

Наводящий вопрос - у вас ранее работал данный клиент на 160МГц с нормальными скоростями? Текущий микрокод, который управляет подстройкой rate_ctl чипа радио неизменный с 2.15. Если ранее были другие результаты, сообщите.

канал выбирается на авто. 

про ранее не могу сказать, т.к. предыдущее оборудование не позволяло выбрать 160МГц.

Link to comment
Share on other sites

  • 0
3 minutes ago, Илья Картавенко said:

настроено wifi системой?

общие реквизиты (название точки доступа, защита и т.п.) - да. частоты - на Ультре отдельно настроены.

Link to comment
Share on other sites

  • 0
8 minutes ago, Padavan said:

Поставьте ручной канал 36 и проверьте

поставил. не подключается на 160MHz - только на 40 и не больше, чем 170 мегабит. 

на 160 и 1500+ подключается при выборе канала 56. и скорость "в мир" соответствует той, что на входе в квартиру около 900 мегабит. спасибо!

(упреждая вопрос "куда тебе такие скорости в квартире" - для просмотра видео внутри сети)

доп. вопрос, чтобы лишнюю тему не создавать - при создании WiFi-сети из 3х роутеров - есть возможность явным образом назначить подключение определенных клиентов к конкретным роутерам?

Спасибо-2

 

Screenshot_20200218_192605_com.nperf.tester.jpg

  • Upvote 1
Link to comment
Share on other sites

  • 0

В диапазоне 5ГГц всего два сплошных блока по 160МГц

36..64
100..128

причем, они могут быть недоступны для определенных регионов. Выбирая конкретный 20МГц канал внутри блока 160, вы по сути задаете только центральный канал VHT. Реальные данные передаются по всему блоку спектра.

Странно что смартфон ведет себя подобным образом, по идее вообще нет разницы, какой центральный канал VHT выбирать внутри блока 160. Возможно какие-то ошибки в драйвере.

Link to comment
Share on other sites

  • 0

На смартфонах полоса 160 все же избыточна, это в основном удел для десктопов и ноутов, чтобы получать до 900mbps в пике (например копирование с NAS). Под рукой Galaxy S10 на exynos, он не поддерживает 160, однако на 80 прекрасно выдает до 650mbps даже со Speedster KN-3010.

  • Upvote 2
Link to comment
Share on other sites

  • 0
12 minutes ago, Padavan said:

Странно что смартфон ведет себя подобным образом, по идее вообще нет разницы, какой канал для несущей выбирать внутри блока 160. Возможно какие-то ошибки в драйвере.

скорее всего. 

Link to comment
Share on other sites

  • 0
37 minutes ago, agb said:

Huawei/Honor отличался тем, что если он по какой-то причине (например региональная блокировка) не подключается на максимальной ширине канала, то никак не извещает об этом точку доступа. Т.е. точка может считать что он подключен на 160, а на самом деле он половину этого диапазона не слушает. При подключении можно зайти в настройки самого телефона и там посмотреть на какой скорости он подключился. Если там явно скорость соответствующая 80 МГц - скорее всего это оно. В вашем случае можно также попробовать в настройках кинетика выбрать Украину и например 100 канал, у вас они разрешены и там может быть более свободно чем на двузначных каналах.

Спасибо! на полную скорость смартфон вышел после указания в настройках 56 канала (вместо "Авто")

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...