Jump to content

4G модем Huawei E3372h на прошивке 2.16.D.1.0-1


yuoras
 Share

Recommended Posts

Всем ,доброго дня.

Словил проблему после обновления на прошивку 2.16.D.1.0-1 ,с модемом Huawei E3372h.

Не присваивается IP адрес.

До обновления ,все работало стабильно.

В логах модем виден , а связь не поднимается.

Модем вынут и проверен на компьютере, связь поднимается без проблем.

Screenshot_1.jpg

  • Upvote 1
  • Need more info 1
Link to comment
Share on other sites

Да, HiLink.

Посмотрю , думаю что включен.

До обновления все работало + на компьютере и сейчас работает.

Строго , только обновился и сразу отвалился модем.

Вечером посмотрю на настройки модема более детально.

Спасибо за ответ

Link to comment
Share on other sites

6 часов назад, Albram сказал:

Модем в HiLink? Если да, то DHCP на модеме включён?

Посмотрел, DHCP на модеме включён

Лог

 

Фев 27 17:00:27
kernel
usb 1-2.4: new high-speed USB device number 8 using ehci-platform
Фев 27 17:00:27
kernel
usb 1-2.4: New USB device found, idVendor=12d1, idProduct=1f01
Фев 27 17:00:27
kernel
usb 1-2.4: Product: HUAWEI_MOBILE
Фев 27 17:00:27
kernel
usb 1-2.4: Manufacturer: HUAWEI_MOBILE
Фев 27 17:00:27
kernel
usb 1-2.4: SerialNumber: 0123456789ABCDEF
Фев 27 17:00:27
kernel
scsi2 : usb-storage 1-2.4:1.0
Фев 27 17:00:30
kernel
scsi 2:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
Фев 27 17:00:30
kernel
sr0: scsi-1 drive
Фев 27 17:00:30
kernel
cdrom: Uniform CD-ROM driver Revision: 3.20
Фев 27 17:00:30
kernel
sr 2:0:0:0: Attached scsi CD-ROM sr0
Фев 27 17:00:30
kernel
sr 2:0:0:0: Attached scsi generic sg2 type 5
Фев 27 17:00:30
kernel
scsi 2:0:0:1: Direct-Access HUAWEI TF CARD Storage 2.31 PQ: 0 ANSI: 2
Фев 27 17:00:30
kernel
sd 2:0:0:1: Attached scsi generic sg3 type 0
Фев 27 17:00:30
kernel
sd 2:0:0:1: [sdc] Attached SCSI removable disk
Фев 27 17:00:34
kernel
usb 1-2.4: USB disconnect, device number 8
Фев 27 17:00:34
kernel
usb 1-2.4: new high-speed USB device number 9 using ehci-platform
Фев 27 17:00:34
kernel
usb 1-2.4: New USB device found, idVendor=12d1, idProduct=14dc
Фев 27 17:00:34
kernel
usb 1-2.4: Product: HUAWEI_MOBILE
Фев 27 17:00:34
kernel
usb 1-2.4: Manufacturer: HUAWEI_MOBILE
Фев 27 17:00:34
kernel
cdc_ether 1-2.4:1.0: eth0: register 'cdc_ether' at usb-ehci-platform-2.4, CDC Ethernet Device, 0c:5b:8f:27:9a:64
Фев 27 17:00:36
ndm
Network::Interface::Usb: "CdcEthernet0": interface "CdcEthernet0" is plugged (port 2).
Фев 27 17:00:36
ndm
Network::Interface::UsbEthernet: "CdcEthernet0": link up.

 

 

Screenshot_1.jpg

  • Upvote 1
Link to comment
Share on other sites

Откатился на 2.16.D.1.0-0 .

Вуаля , все работает

Прикрепляю self-test из версии 2.16.D.1.0-1

Screenshot_3.jpg

Edited by yuoras
  • Upvote 1
Link to comment
Share on other sites

При установке Клиент динамической службы DNS (DDNS) на прошивке 2.16.D.1.0-0, которую мне пришлось понизить из за не работоспособности модема на последней прошивке, обновляется автоматом на прошивку 2.16.D.1.0-1

Соответственно на 2.16.D.1.0-1 не работает gsm модем

 

Оф. техподдержка не помогла, отправила сюда. 
Тут прикладывал self test, тоже горят помочь уже неделю. 

Повторюсь, на прошивке 2.16.D.1.0-0 , модем работает
Воз и ныне там!

Edited by yuoras
Link to comment
Share on other sites

Эта версия поддерживается 1м человеком в свободное время, так что "воз" может оставаться на месте неограниченно долго. 

Как wa можно выставить статический адрес на интерфейсе модема через консоль 

  • Upvote 1
Link to comment
Share on other sites

2 часа назад, r13 сказал:

Как wa можно выставить статический адрес на интерфейсе модема через консоль

Не понял. 

Можно подробнее?

 

Спасибо за ответ
 

  • Upvote 1
Link to comment
Share on other sites

2 часа назад, yuoras сказал:

Воз и ныне там!

Посоветую немного умерить свой пыл и тщательнее подбирать слова. Ваша GigaII имеет последнюю официальную последнюю версию 2.06, со всеми вытекающими!

  • Upvote 1
  • Y'r wrong 2
Link to comment
Share on other sites

Вы по теме можете что то сказать или только глупые советы давать?

Персонально для Вас, все что по проблеме просили, я все предоставлял. 

Так , что вы угомоните свои страсти в поучении!

Форум для того и создан, что бы выявлять и латать выявленные проблемы

Edited by yuoras
  • Thanks 1
Link to comment
Share on other sites

19 минут назад, yuoras сказал:

Не понял. 

Можно подробнее?

 

Спасибо за ответ
 

Зайти в cli

Ввести команду

interface CdcEthernet0 ip address 192.168.8.100/24

Далее уже в вебе на вкладке интернет-фильтр добавить днс или модема или альтернативные(типа гугла) и на вкладке маршрутизация добавит default route через интерфейс модема. Должен заработать. 

 

  • Upvote 1
Link to comment
Share on other sites

9 часов назад, yuoras сказал:

Оф. техподдержка не помогла, отправила сюда. 
Тут прикладывал self test, тоже горят помочь уже неделю. 

Повторюсь, на прошивке 2.16.D.1.0-0 , модем работает
Воз и ныне там!

Да, и он там будет еще долго - у меня нет под рукой такого модема и симки с интернетом, чтобы проверять.

Link to comment
Share on other sites

44 минуты назад, Le ecureuil сказал:

Да, и он там будет еще долго - у меня нет под рукой такого модема и симки с интернетом, чтобы проверять.

Возможно, что дело не в конкретном модеме, а в режиме hi-link ?

Link to comment
Share on other sites

35 минут назад, krass сказал:

Возможно, что дело не в конкретном модеме, а в режиме hi-link ?

Я как раз , пробую метод r13

Цитата

Зайти в cli

Ввести команду

interface CdcEthernet0 ip address 192.168.8.100/24

Далее уже в вебе на вкладке интернет-фильтр добавить днс или модема или альтернативные(типа гугла) и на вкладке маршрутизация добавит default route через интерфейс модема.

 

Link to comment
Share on other sites

@yuoras Почему-то в вашем конфиге не включен dhcp клиент. Выполните:

Цитата

interface CdcEthernet0 ip address dhcp

Или вытащите модем, удалите через Web соединение CdcEthernet0 (4G Киевстар) и вставьте обратно.

  • Thanks 1
Link to comment
Share on other sites

19 минут назад, vst сказал:

Или вытащите модем, удалите через Web соединение CdcEthernet0 (4G Киевстар) и вставьте обратно.

Да, вытащил модем ,удалил соединение и вставил обратно.

Соединение появилось, IP присвоился

Теперь , все как прежне.

 

Кстати , при обновлении на прошивку  2.16.D.1.0-1, пропал и проводной интернет.

В WEB на "Проводные подключения" в параметре "Параметры IP и DNS" слетает " Настройка IP "  на "Без IP адреса"

 

Link to comment
Share on other sites

31 минуту назад, yuoras сказал:

Кстати , при обновлении на прошивку  2.16.D.1.0-1, пропал и проводной интернет.

В WEB на "Проводные подключения" в параметре "Параметры IP и DNS" слетает " Настройка IP "  на "Без IP адреса"

имеется большое  кол-во kn-1710 extra  все на 2.16 и  проблем с проводным интернетом нет.

на kn-1810 ultra на 2.16 проблем также нет.

Предположу, что и в этом случае дело не в 2.16...

  • Thanks 1
Link to comment
Share on other sites

45 минут назад, krass сказал:

Предположу, что и в этом случае дело не в 2.16...

Я не претендую на правильный ответ, но два раза обновлялся и потом откатывался и два раза правил на "Автоматическая DHCP" , потому , что слетало, возможно какой пакет мешает.

Link to comment
Share on other sites

1 час назад, yuoras сказал:

но два раза обновлялся и потом откатывался и два раза правил на "Автоматическая DHCP" , потому , что слетало, возможно какой пакет мешает.

А сейчас у вас такой проблемы нет? 

Link to comment
Share on other sites

34 минуты назад, krass сказал:

А сейчас у вас такой проблемы нет? 

Когда обновлялся на последнюю версию 2.16.D.1.0-1 с версии 2.16.D.1.0-0 , проводной интернет обратно пропал .

Я вернул "Автоматическая DHCP"  в проводных подключениях , установил  Клиент динамической службы DNS (DDNS) , потом по рекомендации vst

"Вытащил модем, удалил через Web соединение CdcEthernet0 (4G Киевстар) и вставил обратно"

Теперь все работает , как надо.

Раньше при обновлении , никогда интернет не пропадал

 

Edited by yuoras
Link to comment
Share on other sites

8 минут назад, yuoras сказал:

Теперь все работает , как надо.

Ну значит всё хорошо. 

Вообще, когда произвожу обновление keenos вытаскиваю всё из usb-портов (  4г модем, диск)  , но это скорее по привычке... 

https://help.keenetic.com/hc/ru/articles/360001321080-Часто-задаваемые-вопросы-по-установке-компонентов-и-обновлению-KeeneticOS

Вопрос: После обновления версии ПО в веб-интерфейсе Keenetic не загружаются некоторые страницы интерфейса или возникают ошибки. Как быть?
Ответ: В компонентах системы KeeneticOS различных версий могут отличаться предустановленные настройки. При обновлении операционной системы некоторые настройки устройства могут не обновляться. Это может привести к отображению ошибок при действиях в веб-интерфейсе. Если вы столкнулись с такой ситуацией, рекомендуем сохранить резервную копию текущих настроек (файл конфигирации), затем выполнить сброс пользовательских настроек на заводские установки и заново настроить интернет-центр.

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...