Jump to content
  • 0

Фейл с апдейтом через веб-фейс до бета-версий.


OmegaTron
 Share

Question

Собственно сабж - пытаюсь обновить девайс через веб-интерфейс до бета-релиза, выбрав оный в поле "Использовать" и получаю отлуп



Не удалось подключиться к серверу обновлений. Пожалуйста, проверьте подключение к Интернету.




В поле "Доступная версия:" вылезает "Обновлений нет", а в логе вылезает следующее





Jan 31 19:18:00ndmCore::Ndss: HTTP error: 404 (Not found).


Jan 31 19:19:49ndmCore::Ndss: HTTP error: 404 (Not found).


Интернет работает. При использовании "Релиза" проблем нет.




Это такой баг или это такая фича :D и бета-прошивки надо ставить руками ? Не связана ли случаем эта проблема с этой https://forum.keenetic.net/topic/3523-автообновление-прошивки-на-zyxelях/ ? Edited by OmegaTron
Link to comment
Share on other sites

Recommended Posts

  • 0
31 минуту назад, OmegaTron сказал:

Не удалось подключиться к серверу обновлений. Пожалуйста, проверьте подключение к Интернету.

Иногда сервер обновлений бывает просто недоступен, это через какое-то время проходит. А по поводу доступности прошивок @enpa выше правильно написал. Если хотите перейти на beta выбирайте draft. Это теперь для Вас и будет beta. 

  • Upvote 1
Link to comment
Share on other sites

  • 0
20 минут назад, enpa сказал:

@OmegaTron sandbox beta - сейчас нет для Omni II, поэтому и вылезает данная ошибка. Можно перейти на stable, delta, draft.

Была доступна версия 2.08.B.0.0-0, а она ниже stable версии.

В таких нюансах не разбираюсь (пока), просто подскажите, где найти прошивку, с данными модулями https://forum.keenetic.net/topic/3756-нужны-допмодули-ядра-для-netfilter-продвинутый-iptables/?do=findComment&comment=44916

нужен человеческий iptables

 

Edited by OmegaTron
Link to comment
Share on other sites

  • 0
19 минут назад, enpa сказал:

@OmegaTron можно попробовать собрать версию 2.08 с opkg, но это будет проблематично из-за маленького размера флеш-памяти. Какие основные компоненты Вам нужны, кроме opkg?

Самый минимум - служба pppoe, клиент pppoe, сетевой ускоритель, управление пропускной полосой, модуль захвата пакетов, ftp, smb, udpxy, ping checker, fat32

Прежде чем что-то устанавливать всё же хочу уточнить - интересующий функционал iptables с возможностью установки доп.модулей там будет ? Или его может и не быть ?

Edited by OmegaTron
Link to comment
Share on other sites

  • 0

@OmegaTron проверьте пожалуйста. Список компонентов:

acl
base
cifs
cloud
cloudcontrol
components
corewireless
dhcpd
easyconfig
fat
ftp
hfsplus
igmp
interface-extras
kabinet
monitor
nathelper-ftp
ntfs
opkg
opkg-kmod-audio
opkg-kmod-fs
opkg-kmod-netfilter
opkg-kmod-tc
opkg-kmod-usbip
opkg-kmod-video
pingcheck
ppe
ppp
pppoe
storage
trafficcontrol
udpxy
usb

Скачать:

Keenetic Omni II_stable_2.08.C.2.0-4

Edited by enpa
Link to comment
Share on other sites

  • 0

@OmegaTron команды:

(config)> components

             list - show an available component list
          install - install or remove a component
           remove - remove the component from this system
           preset - select a predefined set of components
          preview - show firmware info
           commit - apply selected component set
  validity-period - set a validity period of a local component list
      auto-update - manage firmware components auto-update settings

далее:

(config)> components remove kabinet
Components::Manager: Component "kabinet" is queued for removal.
(config)> components commit

только убирать компоненты надо "с умом", не все подряд.

установите opkg, получите доступ к shell и там сможете настроить iptables.

Edited by enpa
Link to comment
Share on other sites

  • 0
2 часа назад, OmegaTron сказал:

Самый минимум - служба pppoe, клиент pppoe, сетевой ускоритель, управление пропускной полосой, модуль захвата пакетов, ftp, smb, udpxy, ping checker, fat32

Прежде чем что-то устанавливать всё же хочу уточнить - интересующий функционал iptables с возможностью установки доп.модулей там будет ? Или его может и не быть ?

Вы точно ознакомились со списком отсюда?

В версии 2.08 точно есть все необходимое?

opkg-kmod-netfilter-addons появился только в 2.09, в 2.08 никто его не переносил.

Плюс в самой прошивке утилиты iptables нет - нужно ставить Entware/Debian.

Link to comment
Share on other sites

  • 0
3 часа назад, enpa сказал:

только убирать компоненты надо "с умом", не все подряд.

Я в курсе. Просто я "выпилом" занимался через веб-интерфейс. Оттуда же список компонентов, что юзаю взял. Лень было в мануал по cli и в консоль залезать.

3 часа назад, enpa сказал:

установите opkg, получите доступ к shell и там сможете настроить iptables.

Я в курсе, только текущий iptables чересчур "ограниченный".

3 часа назад, enpa сказал:

enpa, эту прошивку вы собрали или вы просто выложили прошивку (я это к тому, для чего был задан вопрос касательно набора компонентов) ?

1 час назад, Le ecureuil сказал:

Вы точно ознакомились со списком отсюда?

Нет, иначе не задавал бы подобные вопросы ))) Я пока плохо представляю, что там к чему. Где бы почитать про sandbox беты / draft / дельта прошивки и т.д. ?

1 час назад, Le ecureuil сказал:

opkg-kmod-netfilter-addons появился только в 2.09, в 2.08 никто его не переносил.

Т.е. можно даже не дёргаться ?

1 час назад, Le ecureuil сказал:

Плюс в самой прошивке утилиты iptables нет - нужно ставить Entware/Debian.

На stable - релизе ситуация идентичная.

***

Короче говоря, если я всё верно понял, то, что советовал Zyxmon в этой теме https://forum.keenetic.net/topic/3756-нужны-допмодули-ядра-для-netfilter-продвинутый-iptables/?do=findComment&comment=44916 в качестве решения проблемы для Omni II на данный момент не подходит и нужно ждать следующего stable-билда ?

Edited by OmegaTron
Link to comment
Share on other sites

  • 0
9 минут назад, OmegaTron сказал:

Короче говоря, если я всё верно понял, то, что советовал Zyxmon в этой теме https://forum.keenetic.net/topic/3756-нужны-допмодули-ядра-для-netfilter-продвинутый-iptables/?do=findComment&comment=44916 в качестве решения проблемы для Omni II на данный момент не подходит и нужно ждать следующего stable-билда ?

Нет, следующего stable для Omni2 не будет

Для этих хотелок надо переходить на delta канал, будет версия 2.10

Link to comment
Share on other sites

  • 0
10 минут назад, OmegaTron сказал:

Я в курсе. Просто я "выпилом" занимался через веб-интерфейс. Оттуда же список компонентов, что юзаю взял. Лень было в мануал по cli и в консоль залезать.

Я в курсе, только текущий iptables чересчур "ограниченный".

enpa, эту прошивку вы собрали или вы просто выложили прошивку (я это к тому, для чего был задан вопрос касательно набора компонентов) ?

Нет, иначе не задавал бы подобные вопросы ))) Я пока плохо представляю, что там к чему. Где бы почитать про sandbox беты / draft / дельта прошивки и т.д. ?

Т.е. можно даже не дёргаться ?

На stable - релизе ситуация идентичная.

***

Короче говоря, если я всё верно понял, то, что советовал Zyxmon в этой теме https://forum.keenetic.net/topic/3756-нужны-допмодули-ядра-для-netfilter-продвинутый-iptables/?do=findComment&comment=44916 в качестве решения проблемы для Omni II на данный момент не подходит и нужно ждать следующего stable-билда ?

Следующего stable-билда не будет никогда (точнее будут, но все версии 2.08).

Потому ставьте delta через
> components list delta
> components commit

И настраивайте как вам угодно.

Link to comment
Share on other sites

  • 0
8 часов назад, r13 сказал:

Для этих хотелок надо переходить на delta канал, будет версия 2.10

ОК, как ?

8 часов назад, Le ecureuil сказал:

Потому ставьте delta через
> components list delta
> components commit

И настраивайте как вам угодно.

Я бы с радостью, но мне пока так никто и не растолковал, что к чему :/

9 часов назад, OmegaTron сказал:

Я пока плохо представляю, что там к чему. Где бы почитать про sandbox беты / draft / дельта прошивки и т.д. ?

Дайте линки для ознакомления.

Link to comment
Share on other sites

  • 0
4 часа назад, OmegaTron сказал:

ОК, как ?

Я бы с радостью, но мне пока так никто и не растолковал, что к чему :/

Дайте линки для ознакомления.

Читайте форум. Тут есть всё. 

Link to comment
Share on other sites

  • 0
16 минут назад, Mamay сказал:

Читайте форум. Тут есть всё. 

Я не "живу" на данном ресурсе и лишь изредка заглядываю, когда возникают проблемы. Поэтому на поиск интересующей информации может уйти много времени, поэтому продуктивнее будет, если меня ткнут носом в нужную информацию.

Edited by OmegaTron
Link to comment
Share on other sites

  • 0
1 минуту назад, OmegaTron сказал:

Я не "живу" на данном ресурсе и лишь изредка заглядываю, когда возникают проблемы. Поэтому на поиск интересующей информации может уйти много времени, поэтому продуктивнее будет, если меня ткнут носом в нужную информацию.

Ога, все ломанулись, волосы назад искать вам на форуме ваши ответы. Потребительское отношение особо не приветствуется и позиция, мне лень искать явно не в вашу пользу. 

Если бы вы пришли и сказали, ребят, делал так, так и вот так. Но не работает повсеместно, уверен помогли бы. А типа дайте мне решение - вряд-ли..

Всё сказанное выше лишь ИМХО... 

Link to comment
Share on other sites

  • 0

Тем более разработчик вам чёрным по английски написал что делать. Каких ещё вам пояснений требуется? 

Потому ставьте delta через
> components list delta
> components commit

Link to comment
Share on other sites

  • 0
3 часа назад, Mamay сказал:

Ога, все ломанулись, волосы назад искать вам на форуме ваши ответы. Потребительское отношение особо не приветствуется и позиция, мне лень искать явно не в вашу пользу. 

На тех форумах, где я "обитаю", не вижу проблемы с другими юзерами делиться информацией.

3 часа назад, Mamay сказал:

А типа дайте мне решение - вряд-ли..

А я не прошу дать мне решение, я прошу дать инфо по данному вопросу, где можно узнать, в чём отличия прошивок и от чего мне отталкиваться.

3 часа назад, Mamay сказал:

Тем более разработчик вам чёрным по английски написал что делать. Каких ещё вам пояснений требуется? 

Потому ставьте delta через
> components list delta
> components commit

Первую команду я не видел в мануале и не в курсе насколько она применима к моему девайсу с последней stable-прошивкой и даст ли необходимый эффект. Потому я просил дать линки на темы, где об этом можно почитать.

Edited by OmegaTron
Link to comment
Share on other sites

  • 0
3 часа назад, OmegaTron сказал:

А я не прошу дать мне решение, я прошу дать инфо по данному вопросу, где можно узнать, в чём отличия прошивок и от чего мне отталкиваться.

Вы вступили в ненужную ни кому, кроме вас, полемику. Все ваши ответы лежат на поверхности. И это не просто, а очень просто 2.102.112.12...

Link to comment
Share on other sites

  • 0
9 минут назад, Mamay сказал:

Вы вступили в ненужную ни кому, кроме вас, полемику. Все ваши ответы лежат на поверхности. И это не просто, а очень просто 2.102.112.12...

Спасибо, буду изучать ;) Суть в том что когда голова забита пачкой вопросов, которые нужно решить, даже то, что лежит на поверхности проходит мимо меня :/ Потому я и прошу помощи.

Edited by OmegaTron
опечатки
Link to comment
Share on other sites

  • 0
1 минуту назад, OmegaTron сказал:

...даже то, что лежит на поверхности проходит мимо меня :/

Ассоциативное мышление подсказало мне, что Вы похожи на однозадачный DOS... :mrgreen:

Link to comment
Share on other sites

  • 0
3 часа назад, OmegaTron сказал:

Спасибо, буду изучать ;) Суть в том что когда голова забита пачкой вопросов, которые нужно решить, даже то, что лежит на поверхности проходит мимо меня :/ Потому я и прошу помощи.

Понимаете, тут нет людей на зарплате, которые должны вам отвечать. Все чисто на энтузиазме каждого.

У меня тоже голова постоянно забита, я даже могу неделю не заходить на форум из-за загрузки.

Поэтому если не хотите думать - купите новый роутер с поддерживаемой прошивкой 2.09 (или выше), и обращайтесь в техподдержку - они вам все подробно расскажут, ведь вы за это заплатили.

  • Upvote 3
Link to comment
Share on other sites

  • 0
В 02.02.2018 в 00:39, Le ecureuil сказал:

Понимаете, тут нет людей на зарплате, которые должны вам отвечать. Все чисто на энтузиазме каждого.

Я всё понимаю, но можно было просто ткнуть в эту тему https://forum.keenetic.net/announcement/5-где-взять-тестовые-прошивки/ и все вопросы сразу бы отпали :) Там разжёвано что есть draft, что есть delta (о чём я и интересовался).

В 02.02.2018 в 00:39, Le ecureuil сказал:

Поэтому если не хотите думать - купите новый роутер с поддерживаемой прошивкой 2.09 (или выше), и обращайтесь в техподдержку - они вам все подробно расскажут, ведь вы за это заплатили.

Да я не против подумать ))) Просто если есть возможность решить вопрос быстро, я стараюсь это сделать, нет - иду "долгим" путём.

***

Итак, вернулся я к данному вопросу, вбил в cli

components list delta
	components commit

увидел, что пошло обновление (до этого никогда данной командой не пользовался), дождался, пока пройдёт апдейт (прошивка теперь 2.10.C.2.0-4), заглянул в мануал, потом снова в cli и набрал команды

components list delta
components remove fat
components install opkg-kmod-netfilter
components install opkg-kmod-netfilter-addons
components commit

только вот вместо

FileSystem::Repository: Firmware update started.

что было в прошлый раз, в консоли вылезло

Components::Manager error[24249130]: request failed (404).

WTF ? В списке запрашиваемые и удаляемые компоненты были :/

Link to comment
Share on other sites

  • 0
1 час назад, OmegaTron сказал:

Я всё понимаю, но можно было просто ткнуть в эту тему https://forum.keenetic.net/announcement/5-где-взять-тестовые-прошивки/ и все вопросы сразу бы отпали :) Там разжёвано что есть draft, что есть delta (о чём я и интересовался).

Да я не против подумать ))) Просто если есть возможность решить вопрос быстро, я стараюсь это сделать, нет - иду "долгим" путём.

***

Итак, вернулся я к данному вопросу, вбил в cli


components list delta
	components commit

увидел, что пошло обновление (до этого никогда данной командой не пользовался), дождался, пока пройдёт апдейт (прошивка теперь 2.10.C.2.0-4), заглянул в мануал, потом снова в cli и набрал команды


components list delta
components remove fat
components install opkg-kmod-netfilter
components install opkg-kmod-netfilter-addons
components commit

только вот вместо


FileSystem::Repository: Firmware update started.

что было в прошлый раз, в консоли вылезло


Components::Manager error[24249130]: request failed (404).

 

WTF ? В списке запрашиваемые и удаляемые компоненты были :/

После смены канала обновлений удалять/ добавлять компоненты можете через веб как обычно. 

Link to comment
Share on other sites

  • 0
3 часа назад, r13 сказал:

После смены канала обновлений удалять/ добавлять компоненты можете через веб как обычно. 

Я так и сделал поначалу - зашёл в веб-фейс и проверил список элементов, только затребованных элементов не было. После попытки установки через cli они появились со статусом "будет установлен". Попробую запустить апдейт оттуда.

Link to comment
Share on other sites

  • 0
46 минут назад, OmegaTron сказал:

Я так и сделал поначалу - зашёл в веб-фейс и проверил список элементов, только затребованных элементов не было. После попытки установки через cli они появились со статусом "будет установлен". Попробую запустить апдейт оттуда.

Можно было просто обновиться на 2.10, и они бы появились. Потом еще бы раз обновились с установкой.

Link to comment
Share on other sites

  • 0
1 час назад, Le ecureuil сказал:

Можно было просто обновиться на 2.10, и они бы появились. Потом еще бы раз обновились с установкой.

Запустил апдейт из веб-фейса и всё прошло как по маслу (тьфу-тьфу-тьфу) :)

Link to comment
Share on other sites

  • 0
8 минут назад, OmegaTron сказал:

Запустил апдейт из веб-фейса и всё прошло как по маслу (тьфу-тьфу-тьфу) :)

Главное нарежте себе прошивок с нужными компонентами в закрома, а то скоро в этом канале уже 2.11 будет.

Link to comment
Share on other sites

  • 0
26 минут назад, r13 сказал:

Главное нарежте себе прошивок с нужными компонентами в закрома, а то скоро в этом канале уже 2.11 будет.

А как ? Путём слива блока верез cat или запросом к серверу, где генерятся прошивки ? Если второе, то я даже не занимался этим вопросом (ткните если обсуждалось) :| Если первое, укажите, какие блоки дампить.

upd: Вспомнил, там же прошивку можно через веб-фейс в разделе "файлы" слить

p.s. А что не так с 2.11 относительно 2.10 ?

Edited by OmegaTron
Link to comment
Share on other sites

  • 0
6 минут назад, OmegaTron сказал:

upd: Вспомнил, там же прошивку можно через веб-фейс в разделе "файлы" слить

Про это и говорили.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...