Jump to content
  • 0

Странно и постоянно отваливается Wifi


Wertos
 Share

Question

Очень странное поведение сети. Как давно это началось, не знаю, но очень давно, просто сейчас это уже достало.

Подключен по Wifi. Роутер в 2х метрах. На ноуте Arch Linux. Отваливается ненадолго wifi. При этом значок соединения в трее показывает соединение.

64 bytes from 192.168.1.1: icmp_seq=1357 ttl=64 time=0.932 ms
64 bytes from 192.168.1.1: icmp_seq=1358 ttl=64 time=5.31 ms
64 bytes from 192.168.1.1: icmp_seq=1359 ttl=64 time=0.929 ms
64 bytes from 192.168.1.1: icmp_seq=1360 ttl=64 time=0.787 ms
64 bytes from 192.168.1.1: icmp_seq=1361 ttl=64 time=0.840 ms
64 bytes from 192.168.1.1: icmp_seq=1362 ttl=64 time=0.873 ms
64 bytes from 192.168.1.1: icmp_seq=1363 ttl=64 time=0.981 ms
64 bytes from 192.168.1.1: icmp_seq=1364 ttl=64 time=0.927 ms
From 192.168.1.3 icmp_seq=1378 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1379 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1380 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1381 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1382 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1383 Destination Host Unreachable
64 bytes from 192.168.1.1: icmp_seq=1384 ttl=64 time=0.991 ms
64 bytes from 192.168.1.1: icmp_seq=1385 ttl=64 time=1.46 ms

Вывод dmesg в этот момент

[124377.867831] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=30 aid=16383)
[124377.867842] wlan0: e4:18:6b:3f:0c:f2 rejected association temporarily; comeback duration 1024 TU (1048 ms)
[124378.936949] wlan0: associate with e4:18:6b:3f:0c:f2 (try 2/3)
[124379.040285] wlan0: associate with e4:18:6b:3f:0c:f2 (try 3/3)
[124379.143607] wlan0: association with e4:18:6b:3f:0c:f2 timed out
[124384.200615] wlan0: authenticate with e4:18:6b:3f:0c:f2
[124384.232061] wlan0: send auth to e4:18:6b:3f:0c:f2 (try 1/3)
[124384.232781] wlan0: authenticated
[124384.236637] wlan0: associate with e4:18:6b:3f:0c:f2 (try 1/3)
[124384.237844] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=0 aid=1)
[124384.240358] wlan0: associated
[124837.567215] wlan0: authenticate with e4:18:6b:3f:0c:f2
[124837.596995] wlan0: send auth to e4:18:6b:3f:0c:f2 (try 1/3)
[124837.598261] wlan0: authenticated
[124837.598987] wlan0: associate with e4:18:6b:3f:0c:f2 (try 1/3)
[124837.600198] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=30 aid=1)
[124837.600208] wlan0: e4:18:6b:3f:0c:f2 rejected association temporarily; comeback duration 1024 TU (1048 ms)
[124837.702388] wlan0: associate with e4:18:6b:3f:0c:f2 (try 2/3)
[124837.703521] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=30 aid=1)
[124837.703531] wlan0: e4:18:6b:3f:0c:f2 rejected association temporarily; comeback duration 1024 TU (1048 ms)
[124838.772255] wlan0: associate with e4:18:6b:3f:0c:f2 (try 3/3)
[124838.875552] wlan0: association with e4:18:6b:3f:0c:f2 timed out
[124843.938421] wlan0: authenticate with e4:18:6b:3f:0c:f2
[124843.969330] wlan0: send auth to e4:18:6b:3f:0c:f2 (try 1/3)
[124843.970134] wlan0: authenticated
[124843.972173] wlan0: associate with e4:18:6b:3f:0c:f2 (try 1/3)
[124843.973431] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=0 aid=1)
[124843.976029] wlan0: associated

И вот хотелось бы понять, что это за глюк и вообще может быть это вообще в ноуте проблема ?

self-test (1).txt

Link to comment
Share on other sites

26 answers to this question

Recommended Posts

  • 0
7 минут назад, Wertos сказал:

Очень странное поведение сети. Как давно это началось, не знаю, но очень давно, просто сейчас это уже достало.

Подключен по Wifi. Роутер в 2х метрах. На ноуте Arch Linux. Отваливается ненадолго wifi. При этом значок соединения в трее показывает соединение.


64 bytes from 192.168.1.1: icmp_seq=1357 ttl=64 time=0.932 ms
64 bytes from 192.168.1.1: icmp_seq=1358 ttl=64 time=5.31 ms
64 bytes from 192.168.1.1: icmp_seq=1359 ttl=64 time=0.929 ms
64 bytes from 192.168.1.1: icmp_seq=1360 ttl=64 time=0.787 ms
64 bytes from 192.168.1.1: icmp_seq=1361 ttl=64 time=0.840 ms
64 bytes from 192.168.1.1: icmp_seq=1362 ttl=64 time=0.873 ms
64 bytes from 192.168.1.1: icmp_seq=1363 ttl=64 time=0.981 ms
64 bytes from 192.168.1.1: icmp_seq=1364 ttl=64 time=0.927 ms
From 192.168.1.3 icmp_seq=1378 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1379 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1380 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1381 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1382 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1383 Destination Host Unreachable
64 bytes from 192.168.1.1: icmp_seq=1384 ttl=64 time=0.991 ms
64 bytes from 192.168.1.1: icmp_seq=1385 ttl=64 time=1.46 ms

Вывод dmesg в этот момент


[124377.867831] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=30 aid=16383)
[124377.867842] wlan0: e4:18:6b:3f:0c:f2 rejected association temporarily; comeback duration 1024 TU (1048 ms)
[124378.936949] wlan0: associate with e4:18:6b:3f:0c:f2 (try 2/3)
[124379.040285] wlan0: associate with e4:18:6b:3f:0c:f2 (try 3/3)
[124379.143607] wlan0: association with e4:18:6b:3f:0c:f2 timed out
[124384.200615] wlan0: authenticate with e4:18:6b:3f:0c:f2
[124384.232061] wlan0: send auth to e4:18:6b:3f:0c:f2 (try 1/3)
[124384.232781] wlan0: authenticated
[124384.236637] wlan0: associate with e4:18:6b:3f:0c:f2 (try 1/3)
[124384.237844] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=0 aid=1)
[124384.240358] wlan0: associated
[124837.567215] wlan0: authenticate with e4:18:6b:3f:0c:f2
[124837.596995] wlan0: send auth to e4:18:6b:3f:0c:f2 (try 1/3)
[124837.598261] wlan0: authenticated
[124837.598987] wlan0: associate with e4:18:6b:3f:0c:f2 (try 1/3)
[124837.600198] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=30 aid=1)
[124837.600208] wlan0: e4:18:6b:3f:0c:f2 rejected association temporarily; comeback duration 1024 TU (1048 ms)
[124837.702388] wlan0: associate with e4:18:6b:3f:0c:f2 (try 2/3)
[124837.703521] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=30 aid=1)
[124837.703531] wlan0: e4:18:6b:3f:0c:f2 rejected association temporarily; comeback duration 1024 TU (1048 ms)
[124838.772255] wlan0: associate with e4:18:6b:3f:0c:f2 (try 3/3)
[124838.875552] wlan0: association with e4:18:6b:3f:0c:f2 timed out
[124843.938421] wlan0: authenticate with e4:18:6b:3f:0c:f2
[124843.969330] wlan0: send auth to e4:18:6b:3f:0c:f2 (try 1/3)
[124843.970134] wlan0: authenticated
[124843.972173] wlan0: associate with e4:18:6b:3f:0c:f2 (try 1/3)
[124843.973431] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=0 aid=1)
[124843.976029] wlan0: associated

И вот хотелось бы понять, что это за глюк и вообще может быть это вообще в ноуте проблема ?

self-test (1).txt 664 \u041a\u0431 · 1 download

Другие устройства, подключенные к сети как себя ведут?, какой wifi адаптер на ноуте? Пробовали ли в других ОС, как Linux так и Windows?

Link to comment
Share on other sites

  • 0
10 минут назад, Wertos сказал:

Очень странное поведение сети. Как давно это началось, не знаю, но очень давно, просто сейчас это уже достало.

Подключен по Wifi. Роутер в 2х метрах. На ноуте Arch Linux. Отваливается ненадолго wifi. При этом значок соединения в трее показывает соединение.

Очень мало данных, вкладку с селф-тестом надо бы скрыть! В соответствии с :
https://forum.keenetic.net/announcement/4-как-правильно-добавить-self-test-и-прочую-отладку-в-тему/

Версия прошивки роутера.

Проблема с wifi только у ноута? Версия линукса?

В роутере lease time сколько?

  • Upvote 1
Link to comment
Share on other sites

  • 0
5 минут назад, Илья Картавенко сказал:

Другие устройства, подключенные к сети как себя ведут?, какой wifi адаптер на ноуте? Пробовали ли в других ОС, как Linux так и Windows?

Про другие устройства не могу сказать. Как на мобильниках проверить, не знаю...

Адаптер на ноуте Qualcom Atheros QCA9377

На других осях не пробовал, по причине их отсутствия ((

6 минут назад, krass сказал:

Очень мало данных, вкладку с селф-тестом надо бы скрыть! В соответствии с :
https://forum.keenetic.net/announcement/4-как-правильно-добавить-self-test-и-прочую-отладку-в-тему/

Версия прошивки роутера.

Проблема с wifi только у ноута? Версия линукса?

В роутере lease time сколько?

Не могу найти как отредактировать пост ((

Прошивка роутера 3.4 Beta 0

[wertos@acer ~]$ uname -a
Linux acer.lan 5.6.5-arch1-1 #1 SMP PREEMPT Fri, 17 Apr 2020 18:37:44 +0000 x86_64 GNU/Linux

Время работы 3 дн. 13:29:53

Link to comment
Share on other sites

  • 0
22 минуты назад, Wertos сказал:

Про другие устройства не могу сказать. Как на мобильниках проверить, не знаю...

Адаптер на ноуте Qualcom Atheros QCA9377

На других осях не пробовал, по причине их отсутствия ((

Не могу найти как отредактировать пост ((

Прошивка роутера 3.4 Beta 0


[wertos@acer ~]$ uname -a
Linux acer.lan 5.6.5-arch1-1 #1 SMP PREEMPT Fri, 17 Apr 2020 18:37:44 +0000 x86_64 GNU/Linux

Время работы 3 дн. 13:29:53

Пост редактируется при нажатии ссылки изменить под постом. Ну на мобильниках вы такое поведение замечали? 

Link to comment
Share on other sites

  • 0
9 минут назад, Илья Картавенко сказал:

Пост редактируется при нажатии ссылки изменить под постом. Ну на мобильниках вы такое поведение замечали? 

У меня нет кнопки "изменить" под постом, есть только "цитата" и всё.

На мобильниках не замечал, но по причине того что дома на мобильнике в нет не хожу и вафай включаю редко

Link to comment
Share on other sites

  • 0
20 минут назад, Wertos сказал:

У меня нет кнопки "изменить" под постом, есть только "цитата" и всё.

На мобильниках не замечал, но по причине того что дома на мобильнике в нет не хожу и вафай включаю редко

А другого ноута нет?

Link to comment
Share on other sites

  • 0
1 час назад, Wertos сказал:

Прошивка роутера 3.4 Beta 0

А на стабильной версии прошивки пробовали? Посмотрите драйвера для адаптера в репозиториях или в AUR.

  • Upvote 1
Link to comment
Share on other sites

  • 0

Может сделать доступ к альфа-прошивкам только через консоль? А то что-то слишком часто люди ставят альфа-версию до конца не осознавая последствия....

И да, у Вас не бета:
 

Версия 3.4 Beta 0 (пре-бета):

  • Printer: добавлена команда отключения опроса состояния:
    • printer {name} no status-polling
  • Web: выведено поле асимметричного ограничения скорости для хостов
  • Web: выведены выключатели отдельных сервисов на плитку "Private cloud"
  • Upvote 1
Link to comment
Share on other sites

  • 0
5 минут назад, krass сказал:

Может сделать доступ к альфа-прошивкам только через консоль? А то что-то слишком часто люди ставят альфа-версию до конца не осознавая последствия....

Смысла нет. Там вроде и так русским языком написано всё при выборе канала обновления.

А ошибки подобного типа возникают и на бета канале и на канале стабильных версий. Так что..

Edited by keenet07
Link to comment
Share on other sites

  • 0
8 часов назад, Илья Картавенко сказал:

Пост редактируется при нажатии ссылки изменить под постом. 

 

8 часов назад, Wertos сказал:

У меня нет кнопки "изменить" под постом, есть только "цитата" и всё.

Пост можно отредактировать в течении минут 10 - 15(примерно) после опубликования.

Link to comment
Share on other sites

  • 0
8 часов назад, Илья Картавенко сказал:

А на стабильной версии прошивки пробовали? Посмотрите драйвера для адаптера в репозиториях или в AUR.

Драйвер в ядре, можно конечно попробовать собрать модуль отдельно, но думаю проблемы это не решит. Если бы была проблема в драйвере, то сейчас бы форумы арча были завалены постами с таким багом.

7 часов назад, KorDen сказал:

Для начала отключите на роутере BandSteering, и, возможно, WPA3

Отключил, проверю в течении дня.

И ещё у меня подозрение что этот баг/фича возникает только вечером ! Но это предположение, сегодня точно скажу.

Edited by Wertos
Link to comment
Share on other sites

  • 0
9 часов назад, Илья Картавенко сказал:

Значит линуксовые драйвера не поддерживают эту функцию.

Ну и не должны, этот как бы роутер должен поддерживать.

Link to comment
Share on other sites

  • 0
4 минуты назад, Wertos сказал:

Ну и не должны, этот как бы роутер должен поддерживать.

Роутер, как раз, держит спеку, в отличии от...

  • Upvote 1
Link to comment
Share on other sites

  • 0

@Wertos, не поленился и нашёл на форуме ответ разработчика:

Потому что роутер в таком режиме в маяке выставляет все поддерживаемые им режимы безопасности. И если тупой/кривой/косой клиент видит что-то неподдерживаемое, он должен это просто аккуратно пропустить, а он видимо пытается либо интерпретировать по-своему, или вообще падает в ужасе. Такое поведение невозможно исправить со стороны роутера, только выключив WPA3.

Аналогичное дерьмо кстати происходит если включить 11r FT, или WPA-Enterprise. Весь форум забит сообщениями о косых клиентах, которые не умеют корректно видеть что-то отличное от Open или WPA2-PSK. При чем здесь роутер-то?
P.S. пруф

  • Thanks 1
Link to comment
Share on other sites

  • 0
2 часа назад, Wertos сказал:

Ну и не должны, этот как бы роутер должен поддерживать.

Драйвера адаптера и адаптер тоже должны это поддерживать, так как иначе работать не будет. 

Link to comment
Share on other sites

  • 0
В 22.04.2020 в 07:52, Mamay сказал:

@Wertos, не поленился и нашёл на форуме ответ разработчика:

Потому что роутер в таком режиме в маяке выставляет все поддерживаемые им режимы безопасности. И если тупой/кривой/косой клиент видит что-то неподдерживаемое, он должен это просто аккуратно пропустить, а он видимо пытается либо интерпретировать по-своему, или вообще падает в ужасе. Такое поведение невозможно исправить со стороны роутера, только выключив WPA3.

Аналогичное дерьмо кстати происходит если включить 11r FT, или WPA-Enterprise. Весь форум забит сообщениями о косых клиентах, которые не умеют корректно видеть что-то отличное от Open или WPA2-PSK. При чем здесь роутер-то?
P.S. пруф

Ну а причём тут WPA ? Вот сейчас у меня WPA3 спокойно работает !  Я кстати из списка все перепробовал, со всеми работает одинаков.

Link to comment
Share on other sites

  • 0

У моего Giga 2 тоже проблема с пропаданием wifi. При этом сигнал 100%, клиенты в пределах от 1 до 5 метров от роутера: телефон, тв-приставка. Проблема очень давняя. Решилась ручным выбором 13 канала. Если выбрать любой другой канал 1-12, то по неизвестной причине сигнал wifi превращается в пилу (увидел с помощью программы InSSIDer), т.е. сигнал то есть, то нет. Зубцы не всегда одной ширины, иногда длятся несколько секунд и снова сигнал пропадает чтобы появиться вновь.
Но после выбора 13 канала сигнал не исчезает, идет плавная линия, изредка пропадая возобновляется. Клиенты заработали стабильно и быстро, раньше часто затыкались.
Изменение прошивки с 2.04 на 2.06, затем на 2.16 ситуацию не меняют.

Link to comment
Share on other sites

  • 0
В 20.04.2020 в 20:41, Wertos сказал:

Очень странное поведение сети. Как давно это началось, не знаю, но очень давно, просто сейчас это уже достало.

Подключен по Wifi. Роутер в 2х метрах. На ноуте Arch Linux. Отваливается ненадолго wifi. При этом значок соединения в трее показывает соединение.

64 bytes from 192.168.1.1: icmp_seq=1357 ttl=64 time=0.932 ms
64 bytes from 192.168.1.1: icmp_seq=1358 ttl=64 time=5.31 ms
64 bytes from 192.168.1.1: icmp_seq=1359 ttl=64 time=0.929 ms
64 bytes from 192.168.1.1: icmp_seq=1360 ttl=64 time=0.787 ms
64 bytes from 192.168.1.1: icmp_seq=1361 ttl=64 time=0.840 ms
64 bytes from 192.168.1.1: icmp_seq=1362 ttl=64 time=0.873 ms
64 bytes from 192.168.1.1: icmp_seq=1363 ttl=64 time=0.981 ms
64 bytes from 192.168.1.1: icmp_seq=1364 ttl=64 time=0.927 ms
From 192.168.1.3 icmp_seq=1378 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1379 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1380 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1381 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1382 Destination Host Unreachable
From 192.168.1.3 icmp_seq=1383 Destination Host Unreachable
64 bytes from 192.168.1.1: icmp_seq=1384 ttl=64 time=0.991 ms
64 bytes from 192.168.1.1: icmp_seq=1385 ttl=64 time=1.46 ms

Вывод dmesg в этот момент

[124377.867831] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=30 aid=16383)
[124377.867842] wlan0: e4:18:6b:3f:0c:f2 rejected association temporarily; comeback duration 1024 TU (1048 ms)
[124378.936949] wlan0: associate with e4:18:6b:3f:0c:f2 (try 2/3)
[124379.040285] wlan0: associate with e4:18:6b:3f:0c:f2 (try 3/3)
[124379.143607] wlan0: association with e4:18:6b:3f:0c:f2 timed out
[124384.200615] wlan0: authenticate with e4:18:6b:3f:0c:f2
[124384.232061] wlan0: send auth to e4:18:6b:3f:0c:f2 (try 1/3)
[124384.232781] wlan0: authenticated
[124384.236637] wlan0: associate with e4:18:6b:3f:0c:f2 (try 1/3)
[124384.237844] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=0 aid=1)
[124384.240358] wlan0: associated
[124837.567215] wlan0: authenticate with e4:18:6b:3f:0c:f2
[124837.596995] wlan0: send auth to e4:18:6b:3f:0c:f2 (try 1/3)
[124837.598261] wlan0: authenticated
[124837.598987] wlan0: associate with e4:18:6b:3f:0c:f2 (try 1/3)
[124837.600198] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=30 aid=1)
[124837.600208] wlan0: e4:18:6b:3f:0c:f2 rejected association temporarily; comeback duration 1024 TU (1048 ms)
[124837.702388] wlan0: associate with e4:18:6b:3f:0c:f2 (try 2/3)
[124837.703521] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=30 aid=1)
[124837.703531] wlan0: e4:18:6b:3f:0c:f2 rejected association temporarily; comeback duration 1024 TU (1048 ms)
[124838.772255] wlan0: associate with e4:18:6b:3f:0c:f2 (try 3/3)
[124838.875552] wlan0: association with e4:18:6b:3f:0c:f2 timed out
[124843.938421] wlan0: authenticate with e4:18:6b:3f:0c:f2
[124843.969330] wlan0: send auth to e4:18:6b:3f:0c:f2 (try 1/3)
[124843.970134] wlan0: authenticated
[124843.972173] wlan0: associate with e4:18:6b:3f:0c:f2 (try 1/3)
[124843.973431] wlan0: RX AssocResp from e4:18:6b:3f:0c:f2 (capab=0x811 status=0 aid=1)
[124843.976029] wlan0: associated

И вот хотелось бы понять, что это за глюк и вообще может быть это вообще в ноуте проблема ?

self-test (1).txt 664 \u041a\u0431 · 3 downloads

 

Link to comment
Share on other sites

  • 0

Текущая версия KeeneticOS: 3.6.10

Пользуюсь с неделю. Wi-Fi пропадает 6-10 раз за день. Бывает сам восстанавливается, бывает надо перезагружать модем.

Link to comment
Share on other sites

  • 0

Keneetik 4 g iii  прошивка NDMS v2.08(AAUR.4)C2 для модели Rev.A   WiFi соединение есть но при этом пишет нет подключения к интернету.  Через несколько минут самостоятельно восстанавливается. Подскажите пожалуйста в чем может быть причина?

Link to comment
Share on other sites

  • 0
1 час назад, Khameleon сказал:

Keneetik 4 g iii  прошивка NDMS v2.08(AAUR.4)C2 для модели Rev.A   WiFi соединение есть но при этом пишет нет подключения к интернету.  Через несколько минут самостоятельно восстанавливается. Подскажите пожалуйста в чем может быть причина?

Вам как минимум нужно обновить прошивку.

https://forum.keenetic.com/announcement/5-где-взять-тестовые-сборки/      

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...