Jump to content

Recommended Posts

17 часов назад, TheBB сказал:

1. https://forum.keenetic.net/topic/4299-entware/

2. эта тема с первой страницы + https://forum.keenetic.net/topic/5474-adguard-home-для-entware-возможно/ (для ознакомления)

Установил его, как быть дальше, как запустить и какие есть может быть подводные камни?

Edited by Andrey Kalinich
Link to comment
Share on other sites

Разобрался, написал просто AdGuardHome, и оно запустилось.

У меня стоит vpnZaborona (для обхода блокировок к Вк и тд), зашел в интерфейс настройки AdGuardHome

Стал в ступор на этапе настройки, подскажите, как правильно его настроить?

image.thumb.png.44444d7c690e8ebfd11c645b8256907d.png

Link to comment
Share on other sites

  • 2 months later...

Здравствуйте.

Пытаюсь прикрутить кинетиковский сертификат и ключ letsencrypt к AdGuard Home

Он их видит, но видимо ключ запароленный ?!

Кто-нибудь пробовал?

 

 

Скрытый текст

1618912720_adguardhome-keenetic-letsencrypt(censored).thumb.PNG.e92b35a02535001811c1c7e042db61ff.PNG

 

Link to comment
Share on other sites

Не что не предвещало быть проблеме, высокой загрузке CPU на релизах AdGuardHome 104 и даже при откате на

http://bin.entware.net/mipselsf-k3.4/keenetic/archive/adguardhome_0.103.3-1_mipsel-3.4.ipk

Началось при проблемах использования tls://dns.adguard.com и https://dns.adguard.com/dns-query а потом и процент загрузки.

Скрытый текст

Adguard.thumb.jpg.6dea788512a468fc142cd0db75c4dacd.jpg

 

Через некоторое время приходит в норму загрузка, так опять некоторое время нормально но потом бзик до 99%. Началось 2-3дня назад.

На адресах DNS серверов

Скрытый текст

  upstream_dns:
  - tls://dns.google.com
  - tls://1.1.1.1
  - https://dns.google/dns-query
  - https://dns.cloudflare.com/dns-query
  - sdns://AQQAAAAAAAAAEDc3Ljg4LjguNzg6MTUzNTMg04TAccn3RmKvKszVe13MlxTUB7atNgHhrtwG1W1JYyciMi5kbnNjcnlwdC1jZXJ0LmJyb3dzZXIueWFuZGV4Lm5ldA
  - sdns://AQAAAAAAAAAADjIwOC42Ny4yMjAuMjIwILc1EUAgbyJdPivYItf9aR6hwzzI1maNDL4Ev6vKQ_t5GzIuZG5zY3J5cHQtY2VydC5vcGVuZG5zLmNvbQ

При

opkg dns-override

/ # netstat -ntulp | grep AdGuardHome
tcp        0      0 192.168.1.9:8080     0.0.0.0:*               LISTEN      5113/AdGuardHome
tcp        0      0 :::53                   :::*                    LISTEN      5113/AdGuardHome
udp        0      0 :::53                   :::*                                5113/AdGuardHome
/ #

Как на ПО 3.6.1 так и на ПО 3.5.2

Link to comment
Share on other sites

На роутере сброс к заводским + 3.6.2 + https://github.com/AdguardTeam/AdGuardHome

/opt/home/AdGuard # ./AdGuardHome --version
AdGuard Home, version 0.104.0-beta2, channel beta, arch linux mipsle

C правкой DNS (удаление лишнего) серверов и установкой на параллельные запросы, чисткой фильтров так же не нужных

tls://dns.google.com
tls://1.1.1.1
https://dns.google/dns-query
https://dns.cloudflare.com/dns-query
quic://dns-unfiltered.adguard.com:784

И попробовать

  • quic://dns-unfiltered.adguard.com:784 – зашифрован DNS-over-QUIC (Экспериментальный)

Как бы пришло в норму, будем смотреть.

Link to comment
Share on other sites

Что-то как то тяжеловат стал AdguardHome для роутера да же на 256МБ и релиз 103.3 это выражается если судить по "Системному монитору" иногда при просмотре WEB страниц Интернета в загрузке проца более 50% и до 98%, в некоторых случаях даже остановки данного сервиса, т.е. отсутствие его в "ps". Текущий релиз 562. При настройках, даже кол-во фильтров уменьшил

Скрытый текст


dns:
  bind_host: 0.0.0.0
  port: 53

  upstream_dns:
  - tls://dns.google.com
  - tls://1.1.1.1
  - https://dns.google/dns-query
  - https://dns.cloudflare.com/dns-query

  all_servers: false
  fastest_addr: true

  cache_size: 4194304
  cache_ttl_min: 0
  cache_ttl_max: 0
  bogus_nxdomain: []

filters:
- enabled: true
  url: https://adguardteam.github.io/AdGuardSDNSFilter/Filters/filter.txt
  name: AdGuard DNS filter
  id: 1
- enabled: true
  url: https://raw.githubusercontent.com/AdguardTeam/FiltersRegistry/master/filters/filter_1_Russian/filter.txt
  name: Русский фильтр
  id: 1603440573
- enabled: true
  url: https://raw.githubusercontent.com/AdguardTeam/FiltersRegistry/master/filters/filter_14_Annoyances/filter.txt
  name: Фильтр раздражителей
  id: 1603440574

 

  1  [|||||                                                           6.4%]   Tasks: 50, 102 thr; 1 running
  2  [|||                                                             3.2%]   Load average: 0.39 0.23 0.19
  3  [|                                                               0.6%]   Uptime: 2 days, 00:48:28
  4  [                                                                0.0%]
  Mem[||||||||||||||||||||||||||||||||||||||||||||||||||        98.5M/249M]
  Swp[                                                            0K/2.00G]

  PID USER      PRI  NI  VIRT   RES   SHR S CPU% MEM%   TIME+  Command
22986 root       21   1  661M 39796 13400 S  0.0 15.6 10:51.26 AdGuardHome -w /opt/home/AdGuard -l /opt/tmp/AdGuard.log --pidfile /opt/var/run/adguardhome.pi
22990 root       20   0  661M 39796 13400 S  0.0 15.6  0:38.58 AdGuardHome -w /opt/home/AdGuard -l /opt/tmp/AdGuard.log --pidfile /opt/var/run/adguardhome.pi
23000 root       20   0  661M 39796 13400 S  0.0 15.6  1:32.24 AdGuardHome -w /opt/home/AdGuard -l /opt/tmp/AdGuard.log --pidfile /opt/var/run/adguardhome.pi
22988 root       20   0  661M 39796 13400 S  0.0 15.6  1:23.84 AdGuardHome -w /opt/home/AdGuard -l /opt/tmp/AdGuard.log --pidfile /opt/var/run/adguardhome.pi
23022 root       20   0  661M 39796 13400 S  0.0 15.6  1:31.02 AdGuardHome -w /opt/home/AdGuard -l /opt/tmp/AdGuard.log --pidfile /opt/var/run/adguardhome.pi
22994 root       20   0  661M 39796 13400 S  0.0 15.6  1:19.58 AdGuardHome -w /opt/home/AdGuard -l /opt/tmp/AdGuard.log --pidfile /opt/var/run/adguardhome.pi
 

Раньше не обращал внимание на такое кол-во дочерних процессов

 

Mem: 182464K used, 72168K free, 504K shrd, 17284K buff, 61068K cached
CPU:  1.3% usr  0.7% sys  0.0% nic 97.8% idle  0.0% io  0.0% irq  0.0% sirq
Load average: 0.19 0.20 0.18 2/252 26488
  PID  PPID USER     STAT   VSZ %VSZ CPU %CPU COMMAND
22986     1 root     SN    661m264.7   3  0.5 AdGuardHome -w /opt/home/AdGuard -l /opt/tmp/AdGuard.log --pidfile /opt/var/run/adguardhome.pid --no-check-upda

/ # cat /proc/meminfo
MemTotal:         254632 kB
MemFree:           76740 kB
MemAvailable:     133392 kB
Buffers:           17284 kB
Cached:            61068 kB
SwapCached:            0 kB
Active:            71056 kB
Inactive:          53272 kB
Active(anon):      26720 kB
Inactive(anon):    19760 kB
Active(file):      44336 kB
Inactive(file):    33512 kB
Unevictable:           0 kB
Mlocked:               0 kB
SwapTotal:       2096124 kB
SwapFree:        2096124 kB
Dirty:                 0 kB
Writeback:             0 kB
AnonPages:         46028 kB
Mapped:            42980 kB
Shmem:               504 kB
Slab:              23616 kB
SReclaimable:       4476 kB
SUnreclaim:        19140 kB
KernelStack:        2000 kB
PageTables:          936 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:     2223440 kB
Committed_AS:      95308 kB
VmallocTotal:    1048372 kB
VmallocUsed:           0 kB
VmallocChunk:          0 kB
/ #

Ранее такого не наблюдал после его установке в феврале 2020 и по 19-20.10.2020.

 

Edited by vasek00
Link to comment
Share on other sites

  • 3 weeks later...

104-я версия вообще убивает роутер. Обновил с 103 на 104, перезапустил сервис, и всё. Ultra II погибла (на 99% загрузка и так минут 10). Зашёл через SSH убил сервис и удалил приложение adguardhome. Пока что сижу на 103-й. У всех такое безобразие или только у меня?

Link to comment
Share on other sites

Подскажите, после установки и запуска, нужно стандартные настройки как-то переделывать, в плане добавлять фильтра или другие адреса DNS прописывать? Если да то какие? Или оставлять как настроено штатно?

 

И я так понял, если установлено из репозитория, то при перезагрузки роутера служба сама запускается, никакие скрипты для запуска создавать не нужно?

Edited by Leshiu
Link to comment
Share on other sites

  • 2 weeks later...
В 21.10.2020 в 11:08, vasek00 сказал:

Не что не предвещало быть проблеме, высокой загрузке CPU на релизах AdGuardHome 104 и даже при откате на

http://bin.entware.net/mipselsf-k3.4/keenetic/archive/adguardhome_0.103.3-1_mipsel-3.4.ipk

Началось при проблемах использования tls://dns.adguard.com и https://dns.adguard.com/dns-query а потом и процент загрузки.

  Показать содержимое

Adguard.thumb.jpg.6dea788512a468fc142cd0db75c4dacd.jpg

 

Через некоторое время приходит в норму загрузка, так опять некоторое время нормально но потом бзик до 99%. Началось 2-3дня назад.

На адресах DNS серверов

  Показать содержимое


  upstream_dns:
  - tls://dns.google.com
  - tls://1.1.1.1
  - https://dns.google/dns-query
  - https://dns.cloudflare.com/dns-query
  - sdns://AQQAAAAAAAAAEDc3Ljg4LjguNzg6MTUzNTMg04TAccn3RmKvKszVe13MlxTUB7atNgHhrtwG1W1JYyciMi5kbnNjcnlwdC1jZXJ0LmJyb3dzZXIueWFuZGV4Lm5ldA
  - sdns://AQAAAAAAAAAADjIwOC42Ny4yMjAuMjIwILc1EUAgbyJdPivYItf9aR6hwzzI1maNDL4Ev6vKQ_t5GzIuZG5zY3J5cHQtY2VydC5vcGVuZG5zLmNvbQ

При

opkg dns-override

/ # netstat -ntulp | grep AdGuardHome
tcp        0      0 192.168.1.9:8080     0.0.0.0:*               LISTEN      5113/AdGuardHome
tcp        0      0 :::53                   :::*                    LISTEN      5113/AdGuardHome
udp        0      0 :::53                   :::*                                5113/AdGuardHome
/ #

Как на ПО 3.6.1 так и на ПО 3.5.2

Вы победили тормоза? У меня странно, всю ночь работало нормально, а ближе к обеду проц 100% и жуткие лаги

Link to comment
Share on other sites

16 часов назад, Leshiu сказал:

Вы победили тормоза? У меня странно, всю ночь работало нормально, а ближе к обеду проц 100% и жуткие лаги

Остался на релизе 103 с минимальным набором серверов

tls://dns.google.com
tls://1.1.1.1
https://dns.google/dns-query
https://dns.cloudflare.com/dns-query

так же можно отключить и https сервера.

Link to comment
Share on other sites

Вдогонку более оптимальный (хотя как тут сказать про оптимальность скрины ниже) но в настройках DNS - "Распределение нагрузки" запрос по одному за раз и "Самый быстрый IP" опросить все DNS и вернуть самый быстрый по легче выглядит "Распределение нагрузки" (не заметно при просмотре страниц) но все равно загрузка есть.

 

Скрытый текст

"AdGuardHome": {
            "oom-adj": "0",
            "oom-score": "17",
            "oom-score-adj": "0",
            "arg": [
                "-w",
                "/opt/home/AdGuard",
                "-l",
                "/opt/tmp/AdGuard.log",
                "--pidfile",
                "/opt/var/run/adguardhome.pid",
                "--no-check-update"
            ],
            "state": "S (sleeping)",
            "pid": "826",
            "ppid": "1",
            "vm-size": "678312 kB",
            "vm-rss": "41952 kB",
            "vm-data": "37612 kB",
            "vm-stk": "132 kB",
            "vm-exe": "6364 kB",
            "vm-lib": "8484 kB",
            "vm-swap": "0 kB",
            "threads": "14",
            "fds": 38,
            "statistics": {
                "interval": 30,
                "cpu": {
                    "now": "185457.332536",
                    "min": 0,
                    "max": 90,
                    "avg": 13,
                    "cur": 73
                }
            }
        }

 

Скрытый текст

989384475_-2.thumb.jpg.a4dadf8dc2132e86c546a54ebf10e1c6.jpg1511696422_-3.thumb.jpg.71b27f8164d5a388dba25f8517cd4abc.jpg

 

Link to comment
Share on other sites

Добрый день, столкнулся с непонятной проблемой - после перезагрузки роутера не поднялся AdGuard Home. Запускаю руками - получаю вот такую ошибку. Если снести AdGuard и установить заново все работает. До первого перезапуска роутера. Подскажите куда копать?

Spoiler

/opt/home/AdGuard # ./AdGuardHome &
/opt/home/AdGuard # panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0xf pc=0xcd228]

goroutine 1 [running]:
reflect.ifaceIndir(...)
        /usr/local/go/src/reflect/type.go:3067
reflect.packEface(0x0, 0x0, 0x8, 0x0, 0x4)
        /usr/local/go/src/reflect/value.go:109 +0x38
reflect.valueInterface(0x0, 0x0, 0x8, 0x61da01, 0x9e223e, 0x1b)
        /usr/local/go/src/reflect/value.go:1030 +0x100
reflect.Value.Interface(...)
        /usr/local/go/src/reflect/value.go:1000
encoding/gob.decInt32Slice(0x12f0dc0, 0x0, 0x0, 0x8, 0x62c64, 0x12f4de0, 0x12f72a0, 0x0)
        /usr/local/go/src/encoding/gob/dec_helpers.go:235 +0x54
encoding/gob.(*encoderState).encodeUint(0x12f0dc0, 0x0, 0x0)
        /usr/local/go/src/encoding/gob/encode.go:107 +0x10

 

Link to comment
Share on other sites

1 час назад, wince сказал:

Добрый день, столкнулся с непонятной проблемой - после перезагрузки роутера не поднялся AdGuard Home. Запускаю руками - получаю вот такую ошибку. Если снести AdGuard и установить заново все работает. До первого перезапуска роутера. Подскажите куда копать?

Поставить другой релиз AdGuard Home, если не поможет я бы установил Entware заново или на flash и раздел должен быть Ext4 чисто для исключения вопросов.

Link to comment
Share on other sites

1 minute ago, vasek00 said:

Поставить другой релиз AdGuard Home, если не поможет я бы установил Entware заново или на flash и раздел должен быть Ext4 чисто для исключения вопросов.

Да, флешка в ext4. Другую ревизию тоже пробовал - ставил 100.9 и 104.3, все одинаково.Переустанавливать entware конечно очень грустно, все потом восстанавливать.

Link to comment
Share on other sites

17 часов назад, wince сказал:

Да, флешка в ext4. Другую ревизию тоже пробовал - ставил 100.9 и 104.3, все одинаково.Переустанавливать entware конечно очень грустно, все потом восстанавливать.

Нет там такого все потом восстанавливать, вам нужно сохранить /opt/etc и если есть какие еще инд.настройки от программ. После установки Entware просто поменять нужные конф /opt/etc и не тупо переписать а просто содержимое файлов подправить, думаю не более 1часа.

Link to comment
Share on other sites

  • 2 weeks later...

никакие фильтры там не обновляются чаще раза в час(дефолтом 24 стоит). жрёт проц в зависимости от сетевой активности. причём это не какая-то фееричная активность, а несколько запросов достаточно, чтобы проц ушёл в 100. откат на предыдущую версию ничего не даёт(ставил 102. не помню, правда, какая стояла до, но некоторые, пишут, откатились ещё дальше, и безрезультатно). вывод напрашивается такой- косяк в прошивке(опять-таки не знаю на какой работало, так как стоит автоапдейт) тостера.

unbound- наше всё. хотелось сделать проще, но уже не вариант, получается 😕

Link to comment
Share on other sites

Подскажите, как правильно закинуть AdGuard Home в автозагрузку? Скрипт:

#!/bin/sh

ENABLED=yes
PROCS=AdGuardHome
ARGS=""
PREARGS=""
DESC=$PROCS
PATH=/opt/sbin:/opt/bin:/opt/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/AdGuard

. /opt/etc/init.d/rc.func

Его я создал через VI в папке /opt/etc/init.d и назвал S101AdGuardHome. Сама программа находится по пути /opt/AdGuardHome/

В таких условиях при перезагрузке роутера программа не запускается и приходится заходить через ssh, чтобы вручную включить.

Link to comment
Share on other sites

1 час назад, Urik26 сказал:

Подскажите, как правильно закинуть AdGuard Home в автозагрузку? Скрипт:


#!/bin/sh

ENABLED=yes
PROCS=AdGuardHome
ARGS=""
PREARGS=""
DESC=$PROCS
PATH=/opt/sbin:/opt/bin:/opt/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/AdGuard

. /opt/etc/init.d/rc.func

Его я создал через VI в папке /opt/etc/init.d и назвал S101AdGuardHome. Сама программа находится по пути /opt/AdGuardHome/

В таких условиях при перезагрузке роутера программа не запускается и приходится заходить через ssh, чтобы вручную включить.

на запуск так же сделали

chmod 755 S101AdGuardHome

 

Link to comment
Share on other sites

4 часа назад, Urik26 сказал:

Сейчас сделал, перезагрузил - все равно не запускается.

Проверяйте сам файл что и как туда вставляли

 

 

20201220_184650.jpg

Link to comment
Share on other sites

Решил вопрос с автозагрузкой - просто неправильно был набран конфиг, а именно, почему-то не было этой строки:

#!/bin/sh

Теперь грузится как по маслу)

Link to comment
Share on other sites

В 18.10.2020 в 00:28, lbXKSxw1C сказал:

Здравствуйте.

Пытаюсь прикрутить кинетиковский сертификат и ключ letsencrypt к AdGuard Home

Он их видит, но видимо ключ запароленный ?!

Кто-нибудь пробовал?

 

 

  Скрыть содержимое

1618912720_adguardhome-keenetic-letsencrypt(censored).thumb.PNG.e92b35a02535001811c1c7e042db61ff.PNG

 

Нет идей как прикрутить кинетиковский сертификат и ключ letsencrypt к Aduard Home серверу?

Edited by lbXKSxw1C
исправление форматирования
  • Upvote 1
Link to comment
Share on other sites

  • 3 weeks later...
В 16.12.2020 в 16:35, BABUT сказал:

как писал камрад DennoN, юзать системный прокси на tcp40500- это выход

Набросьте схему как это сделать!? Искал инфу по форуму,но не нашёл. Заранее благодарен за помощь.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...